aboutsummaryrefslogtreecommitdiff
path: root/graphics/synaesthesia/Makefile
diff options
context:
space:
mode:
authorPete Fritchman <petef@FreeBSD.org>2004-01-07 03:38:01 +0000
committerPete Fritchman <petef@FreeBSD.org>2004-01-07 03:38:01 +0000
commite27313caf897b673fdd6d54b1e82336835bcac13 (patch)
treedcbc5f6094bceb82b1d7e174288036b37eb5eb7e /graphics/synaesthesia/Makefile
parent73a1763dc854f66aac2cbcb62301084cc87437ae (diff)
downloadports-e27313caf897b673fdd6d54b1e82336835bcac13.tar.gz
ports-e27313caf897b673fdd6d54b1e82336835bcac13.zip
Notes
Diffstat (limited to 'graphics/synaesthesia/Makefile')
-rw-r--r--graphics/synaesthesia/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/graphics/synaesthesia/Makefile b/graphics/synaesthesia/Makefile
index 3431c96ae8ca..3d2b6edbb55a 100644
--- a/graphics/synaesthesia/Makefile
+++ b/graphics/synaesthesia/Makefile
@@ -6,9 +6,9 @@
#
PORTNAME= synaesthesia
-PORTVERSION= 2.1
+PORTVERSION= 2.2
CATEGORIES= graphics
-MASTER_SITES= http://yoyo.cc.monash.edu.au/~pfh/
+MASTER_SITES= http://www.logarithmic.net/pfh/Synaesthesia/
MAINTAINER= petef@FreeBSD.org
COMMENT= Graphically represents sound in real time
@@ -18,12 +18,18 @@ LIB_DEPENDS= SDL-1.1.5:${PORTSDIR}/devel/sdl12
SDL_CONFIG= ${LOCALBASE}/bin/sdl11-config
USE_GMAKE= Yes
+USE_REINPLACE= Yes
USE_X_PREFIX= Yes
GNU_CONFIGURE= Yes
CONFIGURE_ARGS= --with-sdl-prefix=${LOCALBASE}
CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}"
+post-patch:
+ @${REINPLACE_CMD} -e 's,stdint.h,inttypes.h,' `${FIND} ${WRKSRC} -name \*.cc -or -name \*.c`
+ @${REINPLACE_CMD} -e 's,int16_t,u_int16_t,' \
+ -e 's,machine/soundcard.h,sys/soundcard.h,' ${WRKSRC}/sound.cc
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/synaesthesia ${PREFIX}/bin
.if !defined(NOPORTDOCS)