aboutsummaryrefslogtreecommitdiff
path: root/graphics/tesseract
diff options
context:
space:
mode:
authorBoris Samorodov <bsam@FreeBSD.org>2009-09-11 17:37:37 +0000
committerBoris Samorodov <bsam@FreeBSD.org>2009-09-11 17:37:37 +0000
commitc76ccdc219bb57a49f89e1d3cb8d9f42cd19c6f2 (patch)
tree2abe3f116cb427c4d028139c1dc2dc19e65b76f1 /graphics/tesseract
parented7fe72488c16d66dd44ab142ab0a4c4b1766727 (diff)
downloadports-c76ccdc219bb57a49f89e1d3cb8d9f42cd19c6f2.tar.gz
ports-c76ccdc219bb57a49f89e1d3cb8d9f42cd19c6f2.zip
Notes
Diffstat (limited to 'graphics/tesseract')
-rw-r--r--graphics/tesseract/Makefile6
-rw-r--r--graphics/tesseract/distinfo9
-rw-r--r--graphics/tesseract/files/patch-ccstruct_polyblk.cpp10
-rw-r--r--graphics/tesseract/files/patch-classify_adaptmatch.cpp10
-rw-r--r--graphics/tesseract/files/patch-java_makefile11
-rw-r--r--graphics/tesseract/files/patch-viewer_scrollview.cpp32
-rw-r--r--graphics/tesseract/files/patch-viewer_svmnode.cpp10
-rw-r--r--graphics/tesseract/files/patch-viewer_svutil.cpp11
-rw-r--r--graphics/tesseract/files/patch-wordrec_render.cpp19
-rw-r--r--graphics/tesseract/pkg-plist9
10 files changed, 85 insertions, 42 deletions
diff --git a/graphics/tesseract/Makefile b/graphics/tesseract/Makefile
index 71ae369b4579..fffe6f5218ce 100644
--- a/graphics/tesseract/Makefile
+++ b/graphics/tesseract/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= tesseract
-DISTVERSION= 2.03
-PORTREVISION= 1
+DISTVERSION= 2.04
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE} CENKES
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${LANGFILES}
@@ -20,8 +19,9 @@ LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff
PROJECTHOST= tesseract-ocr
LANGS2_00?= deu eng fra ita nld spa
LANGS2_01?= deu-f por vie
+LANGS2_04?= eus
-.for _N in 2_00 2_01
+.for _N in 2_00 2_01 2_04
LANGFILES+= ${LANGS${_N}:S|^|${PORTNAME}-${_N:S|_|.|}.|:S|$|${EXTRACT_SUFX}|}
.endfor
diff --git a/graphics/tesseract/distinfo b/graphics/tesseract/distinfo
index 0e3ffa86a11f..f80b50f1b87a 100644
--- a/graphics/tesseract/distinfo
+++ b/graphics/tesseract/distinfo
@@ -1,6 +1,6 @@
-MD5 (tesseract-2.03.tar.gz) = 5777b70b11df16c1ac9aa155d7cfc553
-SHA256 (tesseract-2.03.tar.gz) = f39097176b0b0ac83312b5994970d15283ad0e036bc174d98b87500f572acaae
-SIZE (tesseract-2.03.tar.gz) = 1075509
+MD5 (tesseract-2.04.tar.gz) = b44eba1a9f4892ac62e484c807fe0533
+SHA256 (tesseract-2.04.tar.gz) = 62866f283916553e02cebdeb1b485856c6a790f5f8bf86c30b87c6304374bef8
+SIZE (tesseract-2.04.tar.gz) = 1118386
MD5 (tesseract-2.00.deu.tar.gz) = 609d91b1ae3759a756b819b5d8403653
SHA256 (tesseract-2.00.deu.tar.gz) = 6083f16373689ef55651f4dd7773426ab4c32a12ebf7f398af982ac2971fe404
SIZE (tesseract-2.00.deu.tar.gz) = 1373777
@@ -28,3 +28,6 @@ SIZE (tesseract-2.01.por.tar.gz) = 2107696
MD5 (tesseract-2.01.vie.tar.gz) = 34a05c2ae1ec8524e6b7647bdeecd408
SHA256 (tesseract-2.01.vie.tar.gz) = 8026240029341d45a6142cfccf6f0f98e5b1f35cae5725f8379ac4a8de34283f
SIZE (tesseract-2.01.vie.tar.gz) = 964277
+MD5 (tesseract-2.04.eus.tar.gz) = 1f82f6c152dd10b5a7116b0a040a7125
+SHA256 (tesseract-2.04.eus.tar.gz) = 19aa30dda8049fb03e125e3b17d05ae402544e9ec81adcb18964d4a7b125a2fe
+SIZE (tesseract-2.04.eus.tar.gz) = 1207994
diff --git a/graphics/tesseract/files/patch-ccstruct_polyblk.cpp b/graphics/tesseract/files/patch-ccstruct_polyblk.cpp
new file mode 100644
index 000000000000..07f9356e901e
--- /dev/null
+++ b/graphics/tesseract/files/patch-ccstruct_polyblk.cpp
@@ -0,0 +1,10 @@
+--- ccstruct/polyblk.cpp.orig 2009-09-11 08:36:32.000000000 -0400
++++ ccstruct/polyblk.cpp 2009-09-11 08:38:14.000000000 -0400
+@@ -271,6 +271,7 @@
+ }
+ }
+ }
++ delete lines;
+ }
+ #endif
+
diff --git a/graphics/tesseract/files/patch-classify_adaptmatch.cpp b/graphics/tesseract/files/patch-classify_adaptmatch.cpp
new file mode 100644
index 000000000000..8d22665019fd
--- /dev/null
+++ b/graphics/tesseract/files/patch-classify_adaptmatch.cpp
@@ -0,0 +1,10 @@
+--- classify/adaptmatch.cpp.orig 2009-09-11 06:08:28.000000000 -0400
++++ classify/adaptmatch.cpp 2009-09-11 06:10:13.000000000 -0400
+@@ -444,6 +444,7 @@
+ char empty_lengths[] = {0};
+ if (!bln_numericmode)
+ tprintf ("Nil classification!\n"); // Should never normally happen.
++ delete Results;
+ return (append_choice (NIL, "", empty_lengths, 50.0f, -20.0f, -1));
+ }
+
diff --git a/graphics/tesseract/files/patch-java_makefile b/graphics/tesseract/files/patch-java_makefile
deleted file mode 100644
index 45dca2dda177..000000000000
--- a/graphics/tesseract/files/patch-java_makefile
+++ /dev/null
@@ -1,11 +0,0 @@
---- java/makefile.orig 2009-04-14 12:55:04.000000000 +0000
-+++ java/makefile 2009-04-14 12:55:14.000000000 +0000
-@@ -40,7 +40,7 @@
- rm -f ScrollView.jar *.class
-
- # all-am does nothing, to make the java part optional.
--all all-am :
-+all all-am install :
-
- # dist runs the autoconf makefile to archive the files correctly.
- dist distdir :
diff --git a/graphics/tesseract/files/patch-viewer_scrollview.cpp b/graphics/tesseract/files/patch-viewer_scrollview.cpp
index 5794366a818c..d3a6dc148159 100644
--- a/graphics/tesseract/files/patch-viewer_scrollview.cpp
+++ b/graphics/tesseract/files/patch-viewer_scrollview.cpp
@@ -1,11 +1,25 @@
---- viewer/scrollview.cpp.orig 2009-04-14 11:54:19.000000000 +0000
-+++ viewer/scrollview.cpp 2009-04-14 11:56:15.000000000 +0000
-@@ -35,6 +35,8 @@
- #include <algorithm>
- #include <vector>
- #include <string>
-+#include <cstring>
-+#include <climits>
+--- viewer/scrollview.cpp.orig 2009-09-11 08:24:19.000000000 -0400
++++ viewer/scrollview.cpp 2009-09-11 08:32:47.000000000 -0400
+@@ -416,6 +416,7 @@
+ SVEvent* ret = waiting_for_events[ea].second;
+ waiting_for_events.erase(ea);
+ mutex_waiting->Unlock();
++ delete sem;
+ return ret;
+ }
- #include "svutil.h"
+@@ -436,6 +437,7 @@
+ SVEvent* ret = waiting_for_events[ea].second;
+ waiting_for_events.erase(ea);
+ mutex_waiting->Unlock();
++ delete sem;
+ return ret;
+ }
+@@ -822,4 +824,4 @@
+ }
+
+
+-#endif // GRAPHICS_DISABLED
+\ No newline at end of file
++#endif // GRAPHICS_DISABLED
diff --git a/graphics/tesseract/files/patch-viewer_svmnode.cpp b/graphics/tesseract/files/patch-viewer_svmnode.cpp
deleted file mode 100644
index 1e8698321964..000000000000
--- a/graphics/tesseract/files/patch-viewer_svmnode.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- viewer/svmnode.cpp.orig 2009-04-14 11:54:39.000000000 +0000
-+++ viewer/svmnode.cpp 2009-04-14 11:57:02.000000000 +0000
-@@ -27,6 +27,7 @@
- #include "svmnode.h"
-
- #include <iostream>
-+#include <cstring>
-
- #include "scrollview.h"
-
diff --git a/graphics/tesseract/files/patch-viewer_svutil.cpp b/graphics/tesseract/files/patch-viewer_svutil.cpp
index 07d8c07d0230..0c5d5e4e95e7 100644
--- a/graphics/tesseract/files/patch-viewer_svutil.cpp
+++ b/graphics/tesseract/files/patch-viewer_svutil.cpp
@@ -1,6 +1,6 @@
---- viewer/svutil.cpp.orig 2008-04-22 00:07:25.000000000 +0000
-+++ viewer/svutil.cpp 2009-04-14 12:13:10.000000000 +0000
-@@ -34,10 +34,14 @@
+--- viewer/svutil.cpp.orig 2009-06-03 20:29:38.000000000 +0400
++++ viewer/svutil.cpp 2009-09-10 15:45:19.000000000 +0400
+@@ -40,9 +40,13 @@
#ifdef __linux__
#include <sys/prctl.h>
#endif
@@ -8,9 +8,8 @@
#endif
#include <iostream>
- #include <string>
-+#include <cstring>
-+#include <cstdio>
++#include <cstring>
++#include <cstdio>
+#include <cstdlib>
const int kBufferSize = 65536;
diff --git a/graphics/tesseract/files/patch-wordrec_render.cpp b/graphics/tesseract/files/patch-wordrec_render.cpp
new file mode 100644
index 000000000000..cc5a90e3d2ff
--- /dev/null
+++ b/graphics/tesseract/files/patch-wordrec_render.cpp
@@ -0,0 +1,19 @@
+--- wordrec/render.cpp.orig 2009-09-11 05:04:06.000000000 -0400
++++ wordrec/render.cpp 2009-09-11 05:07:37.000000000 -0400
+@@ -108,13 +108,13 @@
+ * that was supplied as input.
+ **********************************************************************/
+ void render_edgepts(void *window, EDGEPT *edgept, C_COL color) {
++ if (!edgept)
++ return;
++
+ float x = edgept->pos.x;
+ float y = edgept->pos.y;
+ EDGEPT *this_edge = edgept;
+
+- if (!edgept)
+- return;
+-
+ c_line_color_index(window, color);
+ c_move(window, x, y);
+ do {
diff --git a/graphics/tesseract/pkg-plist b/graphics/tesseract/pkg-plist
index 1542e41e4e4c..7907cdec3acf 100644
--- a/graphics/tesseract/pkg-plist
+++ b/graphics/tesseract/pkg-plist
@@ -270,6 +270,7 @@ lib/libtesseract_viewer.a
lib/libtesseract_wordrec.a
share/tessdata/configs/api_config
share/tessdata/configs/box.train
+share/tessdata/configs/box.train.stderr
share/tessdata/configs/inter
share/tessdata/configs/kannada
share/tessdata/configs/makebox
@@ -299,6 +300,14 @@ share/tessdata/eng.pffmtable
share/tessdata/eng.unicharset
share/tessdata/eng.user-words
share/tessdata/eng.word-dawg
+share/tessdata/eus.DangAmbigs
+share/tessdata/eus.freq-dawg
+share/tessdata/eus.inttemp
+share/tessdata/eus.normproto
+share/tessdata/eus.pffmtable
+share/tessdata/eus.unicharset
+share/tessdata/eus.user-words
+share/tessdata/eus.word-dawg
share/tessdata/fra.DangAmbigs
share/tessdata/fra.freq-dawg
share/tessdata/fra.inttemp