aboutsummaryrefslogtreecommitdiff
path: root/graphics/tif22pnm/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-08-23 19:05:06 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-08-23 19:05:06 +0000
commit4a74e581dfb62250e95dc296ea8a35ab4a849a24 (patch)
treefd7671e74f89f2f585dd0719a133966a72891539 /graphics/tif22pnm/Makefile
parentbea8da3952224c0965db82b63920fc92b58ecfb4 (diff)
downloadports-4a74e581dfb62250e95dc296ea8a35ab4a849a24.tar.gz
ports-4a74e581dfb62250e95dc296ea8a35ab4a849a24.zip
Notes
Diffstat (limited to 'graphics/tif22pnm/Makefile')
-rw-r--r--graphics/tif22pnm/Makefile16
1 files changed, 12 insertions, 4 deletions
diff --git a/graphics/tif22pnm/Makefile b/graphics/tif22pnm/Makefile
index 1b5621a2b070..4ee62f0869dd 100644
--- a/graphics/tif22pnm/Makefile
+++ b/graphics/tif22pnm/Makefile
@@ -7,25 +7,33 @@
#
PORTNAME= tif22pnm
-PORTVERSION= 0.10
+PORTVERSION= 0.11
CATEGORIES= graphics
MASTER_SITES= http://www.inf.bme.hu/~pts/
MAINTAINER= ports@FreeBSD.org
COMMENT= Converts TIFF- sampled images to PNM image
-BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash2
-LIB_DEPENDS= tiff:${PORTSDIR}/graphics/tiff
+BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash
+LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
+ tiff.4:${PORTSDIR}/graphics/tiff
-PLIST_FILES= bin/tif22pnm
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-libtiff-ldir=${LOCALBASE}/lib \
--with-libtiff-idir=${LOCALBASE}/include
+PLIST_FILES= bin/png22pnm bin/tif22pnm
+
+post-patch:
+ @${REINPLACE_CMD} -e 's| -O2| ${CFLAGS}|g' ${WRKSRC}/do.sh
+
do-build:
@(cd ${WRKSRC} ; ${LOCALBASE}/bin/bash do.sh compile)
do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/png22pnm ${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/tif22pnm ${PREFIX}/bin
.include <bsd.port.mk>