aboutsummaryrefslogtreecommitdiff
path: root/graphics/tiff2png/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-07-15 16:45:52 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-07-15 16:45:52 +0000
commit02a9459f39b0cba2c05d9fd4e3dc534dbf3e8796 (patch)
treed545c33c0751a41db52e78f6cde62e31927bbacf /graphics/tiff2png/Makefile
parentbe3946a7ab7f2bfd57285baa7ad5ea4927a280a5 (diff)
- Fix MASTER_SITES
- Support PLIST_FILES PR: ports/69115 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=113730
Diffstat (limited to 'graphics/tiff2png/Makefile')
-rw-r--r--graphics/tiff2png/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/graphics/tiff2png/Makefile b/graphics/tiff2png/Makefile
index 62358efe121d..8178838e8ac9 100644
--- a/graphics/tiff2png/Makefile
+++ b/graphics/tiff2png/Makefile
@@ -9,8 +9,9 @@ PORTNAME= tiff2png
PORTVERSION= 0.91
PORTEPOCH= 1
CATEGORIES= graphics
-MASTER_SITES= http://www.libpng.org/pub/png/src/ \
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
ftp://swrinde.nde.swri.edu/pub/png/applications/
+MASTER_SITE_SUBDIR= png-mng
MAINTAINER= ports@FreeBSD.org
COMMENT= Converts TIFF images to PNG format
@@ -19,8 +20,16 @@ LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff \
png.5:${PORTSDIR}/graphics/png
MAKEFILE= Makefile.unx
+MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
ALL_TARGET= tiff2png
+PORTDOCS= README
+PLIST_FILES= bin/tiff2png
+
+CFLAGS+= -DINVERT_MINISWHITE -DFAXPECT -DDEFAULT_DESTDIR_IS_CURDIR \
+ -I${LOCALBASE}/include
+LDFLAGS= -L${LOCALBASE}/lib -lpng -lz -ltiff -ljpeg -lm
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/tiff2png ${PREFIX}/bin
.if !defined(NOPORTDOCS)