aboutsummaryrefslogtreecommitdiff
path: root/graphics/tiff
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2004-11-15 20:01:45 +0000
committerMikhail Teterin <mi@FreeBSD.org>2004-11-15 20:01:45 +0000
commite550e6353edb7628b799ada1d21618b3f7147b9f (patch)
tree20d3b9719f9bc685aa10e9d131ca388776420abd /graphics/tiff
parentb4c03f6f7025a9f8f3cd6b87682cc6ec98f34bbb (diff)
Notes
Diffstat (limited to 'graphics/tiff')
-rw-r--r--graphics/tiff/Makefile1
-rw-r--r--graphics/tiff/files/patch-float9
2 files changed, 10 insertions, 0 deletions
diff --git a/graphics/tiff/Makefile b/graphics/tiff/Makefile
index b68f2ea08a24..6eb57c66f858 100644
--- a/graphics/tiff/Makefile
+++ b/graphics/tiff/Makefile
@@ -9,6 +9,7 @@
PORTNAME= tiff
PORTVERSION= 3.7.0
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= ftp://ftp.remotesensing.org/pub/libtiff/ \
http://dl1.maptools.org/dl/libtiff/
diff --git a/graphics/tiff/files/patch-float b/graphics/tiff/files/patch-float
new file mode 100644
index 000000000000..c95ec8069ac7
--- /dev/null
+++ b/graphics/tiff/files/patch-float
@@ -0,0 +1,9 @@
+--- tools/tiff2ps.c Thu Oct 14 13:53:28 2004
++++ tools/tiff2ps.c Mon Nov 15 10:05:30 2004
+@@ -412,5 +412,5 @@
+ setupPageState(TIFF* tif, uint32* pw, uint32* ph, double* pprw, double* pprh)
+ {
+- double xres = 0.0, yres = 0.0;
++ float xres = 0.0, yres = 0.0;
+
+ TIFFGetField(tif, TIFFTAG_IMAGEWIDTH, pw);