aboutsummaryrefslogtreecommitdiff
path: root/graphics/tiled
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2012-05-28 13:44:13 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2012-05-28 13:44:13 +0000
commitf14001c2bea2c308a4d110bdaa64626b0ab52925 (patch)
tree27dd94b76959d29a114d0784f0709062238dd2e8 /graphics/tiled
parent6e459bc84e4a5f26ca4b111fd9c7313288c0da22 (diff)
downloadports-f14001c2bea2c308a4d110bdaa64626b0ab52925.tar.gz
ports-f14001c2bea2c308a4d110bdaa64626b0ab52925.zip
Notes
Diffstat (limited to 'graphics/tiled')
-rw-r--r--graphics/tiled/Makefile41
-rw-r--r--graphics/tiled/distinfo2
-rw-r--r--graphics/tiled/pkg-descr18
-rw-r--r--graphics/tiled/pkg-plist30
4 files changed, 91 insertions, 0 deletions
diff --git a/graphics/tiled/Makefile b/graphics/tiled/Makefile
new file mode 100644
index 000000000000..f94285eabd82
--- /dev/null
+++ b/graphics/tiled/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: tiled
+# Date created: 03 May 2011
+# Whom: Dmitry Marakasov <amdmi3@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tiled
+PORTVERSION= 0.8.1
+CATEGORIES= graphics editors games
+MASTER_SITES= SF/tiled/tiled-qt/${PORTVERSION}
+DISTNAME= tiled-qt-${PORTVERSION}
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= General purpose tile map editor
+
+USE_QT_VER= 4
+QT_COMPONENTS= corelib gui opengl \
+ linguist_build qmake_build moc_build uic_build rcc_build
+MAKE_JOBS_SAFE= yes
+USE_LDCONFIG= yes
+
+PORTDOCS= *
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|lrelease|&-qt4|' \
+ ${WRKSRC}/translations/translations.pro
+ @${REINPLACE_CMD} -e 's|.*\(QT += opengl\)|\1|' \
+ ${WRKSRC}/src/tiled/tiled.pro
+
+do-configure:
+ cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} \
+ ${QMAKE} ${QMAKEFLAGS} PREFIX="${PREFIX}" tiled.pro
+
+.if !defined(NOPORTDOCS)
+post-install:
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.md ${DOCSDIR}/
+.endif
+
+.include <bsd.port.mk>
diff --git a/graphics/tiled/distinfo b/graphics/tiled/distinfo
new file mode 100644
index 000000000000..f2901f877902
--- /dev/null
+++ b/graphics/tiled/distinfo
@@ -0,0 +1,2 @@
+SHA256 (tiled-qt-0.8.1.tar.gz) = e5be7c38ceb24fbe0043648e8bc639804f3df5a60beb313eb039b2bcd56ad76c
+SIZE (tiled-qt-0.8.1.tar.gz) = 822180
diff --git a/graphics/tiled/pkg-descr b/graphics/tiled/pkg-descr
new file mode 100644
index 000000000000..299121e4a16e
--- /dev/null
+++ b/graphics/tiled/pkg-descr
@@ -0,0 +1,18 @@
+Tiled is a general purpose tile map editor. It's built to be easy
+to use, yet flexible enough to work with varying game engines,
+whether your game is an RPG, platformer or Breakout clone. Tiled
+is free software and written in C++, using the Qt application
+framework. The main features in a nutshell:
+
+ * General purpose tile map editor with XML-based map format
+ * Supports orthogonal and isometric maps
+ * Custom objects can be placed with pixel precision
+ * Full undo/redo and copy/paste support
+ * Add custom properties to tiles, layers, objects or the map
+ * Automatically reloads tilesets when changed externally
+ * Resize or offset your tile map later as needed
+ * Efficient tile editing tools like stamp and fill brushes
+ * Supports input/output plugins to open and save files in custom
+ formats
+
+WWW: http://www.mapeditor.org/
diff --git a/graphics/tiled/pkg-plist b/graphics/tiled/pkg-plist
new file mode 100644
index 000000000000..7662707623b5
--- /dev/null
+++ b/graphics/tiled/pkg-plist
@@ -0,0 +1,30 @@
+bin/tiled
+bin/tmxviewer
+lib/libtiled.so
+lib/libtiled.so.1
+lib/libtiled.so.1.0
+lib/libtiled.so.1.0.0
+lib/tiled/plugins/libdroidcraft.so
+lib/tiled/plugins/libflare.so
+lib/tiled/plugins/libjson.so
+lib/tiled/plugins/liblua.so
+lib/tiled/plugins/libtengine.so
+lib/tiled/plugins/libtmw.so
+%%DATADIR%%/translations/tiled_cs.qm
+%%DATADIR%%/translations/tiled_de.qm
+%%DATADIR%%/translations/tiled_en.qm
+%%DATADIR%%/translations/tiled_es.qm
+%%DATADIR%%/translations/tiled_fr.qm
+%%DATADIR%%/translations/tiled_he.qm
+%%DATADIR%%/translations/tiled_it.qm
+%%DATADIR%%/translations/tiled_ja.qm
+%%DATADIR%%/translations/tiled_lv.qm
+%%DATADIR%%/translations/tiled_nl.qm
+%%DATADIR%%/translations/tiled_pt.qm
+%%DATADIR%%/translations/tiled_pt_BR.qm
+%%DATADIR%%/translations/tiled_ru.qm
+%%DATADIR%%/translations/tiled_zh.qm
+@dirrm %%DATADIR%%/translations
+@dirrm %%DATADIR%%
+@dirrm lib/tiled/plugins
+@dirrm lib/tiled