aboutsummaryrefslogtreecommitdiff
path: root/graphics/tintfu/Makefile
diff options
context:
space:
mode:
authorHerve Quiroz <hq@FreeBSD.org>2005-02-03 01:46:28 +0000
committerHerve Quiroz <hq@FreeBSD.org>2005-02-03 01:46:28 +0000
commit0356ff91de5e25248aa8ee98bf3c959cc7121103 (patch)
treeb04e6ffa4cce1972d104c627a644b06f17244bbe /graphics/tintfu/Makefile
parent62e0b98f4e47729ccc34efda7c7ceab16371f5ac (diff)
downloadports-0356ff91de5e25248aa8ee98bf3c959cc7121103.tar.gz
ports-0356ff91de5e25248aa8ee98bf3c959cc7121103.zip
Notes
Diffstat (limited to 'graphics/tintfu/Makefile')
-rw-r--r--graphics/tintfu/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/graphics/tintfu/Makefile b/graphics/tintfu/Makefile
index e025711aac8f..0118f96a18d9 100644
--- a/graphics/tintfu/Makefile
+++ b/graphics/tintfu/Makefile
@@ -17,22 +17,24 @@ EXTRACT_SUFX= .jar
MAINTAINER= ports@FreeBSD.org
COMMENT= A GraphViz .dot file editor
+RUN_DEPENDS= java:${PORTSDIR}/java/javavmwrapper
+
NO_WRKSUBDIR= yes
EXTRACT_CMD= ${CP}
EXTRACT_BEFORE_ARGS= # empty
EXTRACT_AFTER_ARGS= .
NO_BUILD= yes
-USE_JAVA= 1.3+
+USE_JAVA= yes
+JAVA_VERSION= 1.3+
PLIST_FILES= %%JAVAJARDIR%%/${DISTNAME}.jar \
bin/tintfu
-post-patch:
- @${SED} -e 's,%%JAVAJARDIR%%,${JAVAJARDIR},' \
- -e 's,%%DISTNAME%%,${DISTNAME},' ${FILESDIR}/tintfu > ${WRKSRC}/tintfu
+SUB_FILES= tintfu.sh
+SUB_LIST= DISTNAME=${DISTNAME}
do-install:
${INSTALL_DATA} ${WRKSRC}/${DISTNAME}.jar ${JAVAJARDIR}
- ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKDIR}/tintfu.sh ${PREFIX}/bin/tintfu
.include <bsd.port.mk>