aboutsummaryrefslogtreecommitdiff
path: root/graphics/tosvcd
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2003-01-06 20:12:01 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2003-01-06 20:12:01 +0000
commitbeb50d53f97c99f600240d27787a3020f1b51d8c (patch)
tree6201520989b42e13312d6a0263d3d0f1a7f08051 /graphics/tosvcd
parentaa471278707302ab84d078af25c7b1ada5aca863 (diff)
Notes
Diffstat (limited to 'graphics/tosvcd')
-rw-r--r--graphics/tosvcd/Makefile26
-rw-r--r--graphics/tosvcd/distinfo1
-rw-r--r--graphics/tosvcd/files/patch-decode.c28
-rw-r--r--graphics/tosvcd/files/patch-makefile39
-rw-r--r--graphics/tosvcd/files/patch-tosvcd.c18
-rw-r--r--graphics/tosvcd/pkg-comment1
-rw-r--r--graphics/tosvcd/pkg-descr16
-rw-r--r--graphics/tosvcd/pkg-plist1
8 files changed, 0 insertions, 130 deletions
diff --git a/graphics/tosvcd/Makefile b/graphics/tosvcd/Makefile
deleted file mode 100644
index 1357f3241d41..000000000000
--- a/graphics/tosvcd/Makefile
+++ /dev/null
@@ -1,26 +0,0 @@
-# ex:ts=8
-# Ports collection makefile for: tosvcd
-# Date created: Oct 25, 2002
-# Whom: ijliao
-#
-# $FreeBSD$
-#
-
-PORTNAME= tosvcd
-PORTVERSION= 0.9
-CATEGORIES= graphics
-MASTER_SITES= http://muse.seh.de/tosvcd/
-
-MAINTAINER= ports@FreeBSD.org
-
-RUN_DEPNDS= mpeg2enc:${PORTSDIR}/multimedia/mjpegtools \
- vcdimager:${PORTSDIR}/graphics/vcdimager
-
-USE_BZIP2= yes
-USE_GMAKE= yes
-MAKEFILE= makefile
-MAKE_ENV= CC="${CXX}" CFLAGS="${CXXFLAGS}" \
- PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
- PTHREAD_LIBS="${PTHREAD_LIBS}"
-
-.include <bsd.port.mk>
diff --git a/graphics/tosvcd/distinfo b/graphics/tosvcd/distinfo
deleted file mode 100644
index 2cb73a19ca84..000000000000
--- a/graphics/tosvcd/distinfo
+++ /dev/null
@@ -1 +0,0 @@
-MD5 (tosvcd-0.9.tar.bz2) = 696c55f668e2019ffa87d9e11902451a
diff --git a/graphics/tosvcd/files/patch-decode.c b/graphics/tosvcd/files/patch-decode.c
deleted file mode 100644
index d7d17986f221..000000000000
--- a/graphics/tosvcd/files/patch-decode.c
+++ /dev/null
@@ -1,28 +0,0 @@
---- decode.c.orig Wed Dec 4 22:40:42 2002
-+++ decode.c Sat Dec 14 07:25:35 2002
-@@ -8,7 +8,6 @@
- #include "mm_accel.h"
- #include "attributes.h"
- #include "mmx.h"
--#include "malloc.h"
-
- extern FILE* log;
-
-@@ -21,7 +20,7 @@
- Mpeg2dec::Mpeg2dec(uint32_t mm_accel)
- {
- config.flags = mm_accel;
-- picture = (picture_t*)memalign (16, sizeof (picture_t));
-+ picture = (picture_t*)malloc(sizeof (picture_t));
- memset(picture, 0, sizeof (picture_t));
- frames = 0;
- frame_ptr[0] = 0;
-@@ -63,7 +62,7 @@
- int size = width() * height() / 4;
- if (frames)
- free(frames);
-- frames = (unsigned char*)memalign(64, size*18);
-+ frames = (unsigned char*)malloc(size*18);
- unsigned char* alloc = frames;
-
- for (int i = 0; i < 3; i++) {
diff --git a/graphics/tosvcd/files/patch-makefile b/graphics/tosvcd/files/patch-makefile
deleted file mode 100644
index 6adf8cd3506f..000000000000
--- a/graphics/tosvcd/files/patch-makefile
+++ /dev/null
@@ -1,39 +0,0 @@
---- makefile.orig Wed Dec 4 22:40:42 2002
-+++ makefile Sat Dec 14 07:27:00 2002
-@@ -1,15 +1,15 @@
- # use intel compiler 0.6.x
- INTEL = no
-
--CFLAGS = -DVERSION="\"0.9\""
-+CFLAGS += -DVERSION="\"0.9\""
-
- ifeq ($(INTEL),yes)
- #CC = icc -I/usr/lib/gcc-lib/i686-pc-linux-gnu/2.95.3/include -Kc++ -O -tpp6 -xiMK
- CC = icc -Kc++ -O -tpp6 -xiMK
- #CC = icc
- else
--CC = g++
--CFLAGS += -g -Wall -O3 -fno-exceptions -fno-rtti
-+CC ?= g++
-+CFLAGS += -fno-exceptions -fno-rtti ${PTHREAD_CFLAGS}
- endif
-
- SRC = tosvcd decode header idct idct_mmx motion_comp
-@@ -20,15 +20,13 @@
- all: tosvcd
-
- tosvcd: $(OBJ)
-- $(CC) -o tosvcd $(OBJ) -lpthread
-- su -c "cp tosvcd /usr/bin"
-+ $(CC) -o tosvcd $(OBJ) ${PTHREAD_LIBS}
-
- t:
- ./tosvcd -o mafia /home/ws/videos/Mafia/2002-10-21.00:33.50.50.rec
-
- install::
-- su -c "mv /usr/bin/tosvcd /usr/bin/tosvcd.old"
-- su -c "cp tosvcd /usr/bin"
-+ ${BSD_INSTALL_PROGRAM} tosvcd ${PREFIX}/bin
-
- clean:
- rm *.o
diff --git a/graphics/tosvcd/files/patch-tosvcd.c b/graphics/tosvcd/files/patch-tosvcd.c
deleted file mode 100644
index 26d7214618c0..000000000000
--- a/graphics/tosvcd/files/patch-tosvcd.c
+++ /dev/null
@@ -1,18 +0,0 @@
---- tosvcd.c.orig Mon Dec 9 18:24:57 2002
-+++ tosvcd.c Sat Dec 14 07:21:57 2002
-@@ -20,14 +20,12 @@
- #include <fcntl.h>
- #include <errno.h>
- #include <string.h>
--#include <stdint.h>
- #include <sys/stat.h>
- #include <time.h>
- #include <pthread.h>
- #include <list>
--#include <values.h>
- #include <signal.h>
--#include <wait.h>
-+#include <sys/wait.h>
- #include <glob.h>
-
- #include "mm_accel.h"
diff --git a/graphics/tosvcd/pkg-comment b/graphics/tosvcd/pkg-comment
deleted file mode 100644
index f28c892561e0..000000000000
--- a/graphics/tosvcd/pkg-comment
+++ /dev/null
@@ -1 +0,0 @@
-SVCD transcoder
diff --git a/graphics/tosvcd/pkg-descr b/graphics/tosvcd/pkg-descr
deleted file mode 100644
index 8fd0e26462b1..000000000000
--- a/graphics/tosvcd/pkg-descr
+++ /dev/null
@@ -1,16 +0,0 @@
-tosvcd takes one or more recorded vdr files and transcodes them to a SVCD
-image file ready for cdrdao to burn.
-
-Some functions:
- * synchronises Video/Audio
- * tries to repair demaged streams
- * split output(with help of mpeg2enc)
- * invoke yuvscaler, if input is not 480x576
- * invoke noise filter on request
- * predicts finish time
- * predicts final output size
- * restarts if output size exceeds CD's capacity to enable full automatic
- operation
- * invoke mplex and vcdimager
-
-WWW: http://muse.seh.de/tosvcd/
diff --git a/graphics/tosvcd/pkg-plist b/graphics/tosvcd/pkg-plist
deleted file mode 100644
index e56c2c408888..000000000000
--- a/graphics/tosvcd/pkg-plist
+++ /dev/null
@@ -1 +0,0 @@
-bin/tosvcd