aboutsummaryrefslogtreecommitdiff
path: root/graphics/truevision/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-03-12 07:28:30 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-03-12 07:28:30 +0000
commit20369ae60dbf3d725922fb3e2dba7474ffb4709a (patch)
tree1a7bc977189cd4729f137558e2973759349cbaa4 /graphics/truevision/Makefile
parent94a722860712952c838e13210414b8b787c192c6 (diff)
Notes
Diffstat (limited to 'graphics/truevision/Makefile')
-rw-r--r--graphics/truevision/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/graphics/truevision/Makefile b/graphics/truevision/Makefile
new file mode 100644
index 000000000000..485464e93b17
--- /dev/null
+++ b/graphics/truevision/Makefile
@@ -0,0 +1,33 @@
+# ex:ts=8
+# Ports collection makefile for: truevision
+# Date created: Mar 12, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= truevision
+PORTVERSION= 0.3.10
+CATEGORIES= graphics
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+
+LIB_DEPENDS= gtkgl:${PORTSDIR}/x11-toolkits/gtkglarea
+
+USE_X_PREFIX= yes
+USE_MESA= yes
+USE_GTK= yes
+USE_GNOME= yes
+GNU_CONFIGURE= yes
+CFLAGS+= ${PTHREAD_FLAGS}
+CONFIGURE_ENV= LDFLAGS="${PTHREAD_LIBS}"
+USE_GMAKE= yes
+
+post-patch:
+ @${PERL} -pi -e "s,Bison ,Bison,g" ${WRKSRC}/configure
+ @${PERL} -pi -e "s,-lgthread,-lgthread12,g ; \
+ s,-lpthread,${PTHREAD_LIBS},g" ${WRKSRC}/src/Makefile.in
+
+.include <bsd.port.mk>