aboutsummaryrefslogtreecommitdiff
path: root/graphics/truevision
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-10-21 08:33:23 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-10-21 08:33:23 +0000
commiteac37356e346880e8b28a13473ab9cfdbbdbdc36 (patch)
tree13b001d61c68e2ea683f15be03393b5c1573478e /graphics/truevision
parent22058a6157ccb3f5f34ea2b6f2461670f700e93a (diff)
downloadports-eac37356e346880e8b28a13473ab9cfdbbdbdc36.tar.gz
ports-eac37356e346880e8b28a13473ab9cfdbbdbdc36.zip
Notes
Diffstat (limited to 'graphics/truevision')
-rw-r--r--graphics/truevision/Makefile2
-rw-r--r--graphics/truevision/distinfo4
-rw-r--r--graphics/truevision/files/patch-src-density.cc14
-rw-r--r--graphics/truevision/files/patch-src-texnormal.cc14
-rw-r--r--graphics/truevision/files/patch-src-texpigment.cc12
-rw-r--r--graphics/truevision/files/patch-src__povfe.cc13
-rw-r--r--graphics/truevision/pkg-plist6
7 files changed, 41 insertions, 24 deletions
diff --git a/graphics/truevision/Makefile b/graphics/truevision/Makefile
index 59adee603f6c..2179cd42f775 100644
--- a/graphics/truevision/Makefile
+++ b/graphics/truevision/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= truevision
-PORTVERSION= 0.5.4
+PORTVERSION= 0.5.5
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/graphics/truevision/distinfo b/graphics/truevision/distinfo
index 0be8039613d0..27be010b9c7d 100644
--- a/graphics/truevision/distinfo
+++ b/graphics/truevision/distinfo
@@ -1,2 +1,2 @@
-MD5 (truevision-0.5.4.tar.bz2) = c8576083fe45a1a6384ff35f04b38a6c
-SIZE (truevision-0.5.4.tar.bz2) = 1692146
+MD5 (truevision-0.5.5.tar.bz2) = 98a2ff999253bb5b31bb73f075ca6097
+SIZE (truevision-0.5.5.tar.bz2) = 1798574
diff --git a/graphics/truevision/files/patch-src-density.cc b/graphics/truevision/files/patch-src-density.cc
index c70550009eb8..f93a18c8b3e9 100644
--- a/graphics/truevision/files/patch-src-density.cc
+++ b/graphics/truevision/files/patch-src-density.cc
@@ -1,6 +1,6 @@
---- src/density.cc.orig Thu Feb 17 04:10:34 2005
-+++ src/density.cc Wed Mar 16 22:21:17 2005
-@@ -194,9 +194,9 @@
+--- src/density.cc.orig Tue Oct 4 03:02:24 2005
++++ src/density.cc Tue Oct 18 18:54:34 2005
+@@ -198,9 +198,9 @@
if ( blockdens1 == NULL && type->value() == 1 )
{
@@ -10,10 +10,10 @@
+ blockdens1 = new PovTexDensity( app_ref, NULL, NULL, NULL, false );
+ blockdens2 = new PovTexDensity( app_ref, NULL, NULL, NULL, false );
+ blockdens3 = new PovTexDensity( app_ref, NULL, NULL, NULL, false );
- blockdens1->add_to_tree( ctree, ctree_node );
- blockdens2->add_to_tree( ctree, ctree_node );
+ blockdens1->add_to_tree( tree_view, tree_store, tree_selection, &node_iter );
+ blockdens2->add_to_tree( tree_view, tree_store, tree_selection, &node_iter );
}
-@@ -475,9 +475,9 @@
+@@ -479,9 +479,9 @@
if ( !strcmp( tag, "DENSITY" ) )
{
@@ -26,7 +26,7 @@
tvio_skip_section( file );
}
-@@ -553,7 +553,7 @@
+@@ -556,7 +556,7 @@
MapItem_density::MapItem_density( float val, guint8 c, app_objs *appref ) : MapItem( _("Density"), val )
{
color[0]=color[1]=color[2]=c; color[3]=255;
diff --git a/graphics/truevision/files/patch-src-texnormal.cc b/graphics/truevision/files/patch-src-texnormal.cc
index 81209a52032b..e9097d30fe8a 100644
--- a/graphics/truevision/files/patch-src-texnormal.cc
+++ b/graphics/truevision/files/patch-src-texnormal.cc
@@ -1,6 +1,6 @@
---- src/texnormal.cc.orig Wed Feb 23 22:32:55 2005
-+++ src/texnormal.cc Wed Mar 16 22:27:11 2005
-@@ -197,9 +197,9 @@
+--- src/texnormal.cc.orig Tue Oct 4 02:54:01 2005
++++ src/texnormal.cc Tue Oct 18 18:56:50 2005
+@@ -199,9 +199,9 @@
if ( normal1 == NULL && type->value() == 1 )
{
@@ -10,10 +10,10 @@
+ normal1 = new PovTexNormal( app_ref, NULL, false );
+ normal2 = new PovTexNormal( app_ref, NULL, false );
+ normal3 = new PovTexNormal( app_ref, NULL, false );
- normal1->add_to_tree( ctree, ctree_node );
- normal2->add_to_tree( ctree, ctree_node );
+ normal1->add_to_tree( tree_view, tree_store, tree_selection, &node_iter );
+ normal2->add_to_tree( tree_view, tree_store, tree_selection, &node_iter );
}
-@@ -524,9 +524,9 @@
+@@ -528,9 +528,9 @@
if ( !strcmp( tag, "NORMAL" ) )
{
@@ -26,7 +26,7 @@
tvio_skip_section( file );
}
-@@ -613,7 +613,7 @@
+@@ -614,7 +614,7 @@
MapItem_normal::MapItem_normal( float val, guint8 c, app_objs *appref ) : MapItem( _("Normal"), val )
{
color[0]=color[1]=color[2]=c; color[3]=255;
diff --git a/graphics/truevision/files/patch-src-texpigment.cc b/graphics/truevision/files/patch-src-texpigment.cc
index 4a236c1ad0f0..5487d5f30dac 100644
--- a/graphics/truevision/files/patch-src-texpigment.cc
+++ b/graphics/truevision/files/patch-src-texpigment.cc
@@ -1,6 +1,6 @@
---- src/texpigment.cc.orig Wed Feb 23 22:32:55 2005
-+++ src/texpigment.cc Wed Mar 16 22:29:09 2005
-@@ -234,9 +234,9 @@
+--- src/texpigment.cc.orig Tue Oct 4 02:54:41 2005
++++ src/texpigment.cc Tue Oct 18 18:58:11 2005
+@@ -236,9 +236,9 @@
if ( blockpig1 == NULL && type->value() == 2 )
{
@@ -10,10 +10,10 @@
+ blockpig1 = new PovTexPigment( app_ref, NULL, false );
+ blockpig2 = new PovTexPigment( app_ref, NULL, false );
+ blockpig3 = new PovTexPigment( app_ref, NULL, false );
- blockpig1->add_to_tree( ctree, ctree_node, NULL );
- blockpig2->add_to_tree( ctree, ctree_node, NULL );
+ blockpig1->add_to_tree( tree_view, tree_store, tree_selection, &node_iter );
+ blockpig2->add_to_tree( tree_view, tree_store, tree_selection, &node_iter );
}
-@@ -552,9 +552,9 @@
+@@ -555,9 +555,9 @@
if ( !strcmp( tag, "PIGMENT" ) )
{
diff --git a/graphics/truevision/files/patch-src__povfe.cc b/graphics/truevision/files/patch-src__povfe.cc
new file mode 100644
index 000000000000..befe9affcfd2
--- /dev/null
+++ b/graphics/truevision/files/patch-src__povfe.cc
@@ -0,0 +1,13 @@
+--- src/povfe.cc.orig Tue Oct 4 04:24:37 2005
++++ src/povfe.cc Tue Oct 18 19:11:46 2005
+@@ -36,6 +36,10 @@
+ #include "include/scene.h"
+ #include "include/tvio.h"
+
++#if defined(__FreeBSD__)
++ #define O_SYNC O_FSYNC
++#endif
++
+ // Output file format definitions
+ const int file_type_num = 4;
+ const char *file_type_list[file_type_num] = { "PNG", "PPM", "TGA", "TGA+RLE" };
diff --git a/graphics/truevision/pkg-plist b/graphics/truevision/pkg-plist
index f51e2eb6d050..aa4c75aea6e1 100644
--- a/graphics/truevision/pkg-plist
+++ b/graphics/truevision/pkg-plist
@@ -26,6 +26,7 @@ share/gnome/help/truevision/C/figures/interface_rendopt6.png
share/gnome/help/truevision/C/figures/interface_rendopt7.png
share/gnome/help/truevision/C/figures/interface_rendopt8.png
share/gnome/help/truevision/C/figures/interface_toolbar.png
+share/gnome/help/truevision/C/figures/perspcam.png
share/gnome/help/truevision/C/functions.xml
share/gnome/help/truevision/C/interface_editor.xml
share/gnome/help/truevision/C/interface_glviews.xml
@@ -85,6 +86,7 @@ share/gnome/pixmaps/truevision/object_text.xpm
share/gnome/pixmaps/truevision/object_torus.xpm
share/gnome/pixmaps/truevision/object_union.xpm
share/gnome/pixmaps/truevision/object_visible.xpm
+share/gnome/pixmaps/truevision/page_detach.png
share/gnome/pixmaps/truevision/render.xpm
share/gnome/pixmaps/truevision/rotate_icon.png
share/gnome/pixmaps/truevision/scale_icon.png
@@ -115,12 +117,14 @@ share/gnome/truevision/materials/Stones/Marble1.tvm
share/gnome/truevision/materials/Stones/granite3.tvm
share/gnome/truevision/materials/Woods/Golden_Oak.tvm
share/gnome/truevision/materials/Woods/Soft_Pine.tvm
+share/gnome/truevision/python/plug-ins/about_python.py
+share/gnome/truevision/python/plug-ins/starfield.py
share/gnome/truevision/python/tv_classes.py
share/locale/de/LC_MESSAGES/truevision.mo
share/locale/fr/LC_MESSAGES/truevision.mo
share/locale/ru/LC_MESSAGES/truevision.mo
-share/mime/application/x-truevision.xml
share/mime/packages/truevision.xml
+@dirrm share/gnome/truevision/python/plug-ins
@dirrm share/gnome/truevision/python
@dirrm share/gnome/truevision/materials/Woods
@dirrm share/gnome/truevision/materials/Stones