aboutsummaryrefslogtreecommitdiff
path: root/graphics/tulip/Makefile
diff options
context:
space:
mode:
authorDaichi GOTO <daichi@FreeBSD.org>2003-07-01 06:14:29 +0000
committerDaichi GOTO <daichi@FreeBSD.org>2003-07-01 06:14:29 +0000
commitce778a39d1bd24d730203d5826d5a147869e212b (patch)
tree8619db9c2281fe5865c09b81e259f8b35aa67fda /graphics/tulip/Makefile
parenta47f001dcc729ae1ec20644e4c50bf68e2e3de72 (diff)
downloadports-ce778a39d1bd24d730203d5826d5a147869e212b.tar.gz
ports-ce778a39d1bd24d730203d5826d5a147869e212b.zip
Notes
Diffstat (limited to 'graphics/tulip/Makefile')
-rw-r--r--graphics/tulip/Makefile14
1 files changed, 9 insertions, 5 deletions
diff --git a/graphics/tulip/Makefile b/graphics/tulip/Makefile
index e7b76fed66c0..2a51e359d358 100644
--- a/graphics/tulip/Makefile
+++ b/graphics/tulip/Makefile
@@ -7,13 +7,15 @@
#
PORTNAME= tulip
-PORTVERSION= 1.2.3
+PORTVERSION= 1.2.4
CATEGORIES= graphics
-MASTER_SITES= http://dept-info.labri.fr/~auber/projects/tulip/x345/
+MASTER_SITES= http://dept-info.labri.fr/~auber/projects/tulip/x345/%SUBDIR%/
+MASTER_SITE_SUBDIR= ${PORTNAME}-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= A system dedicated to the visualization of huge graphs
+USE_BZIP2= yes
USE_QT_VER= 3
QT_NONSTANDARD= yes
USE_REINPLACE= yes
@@ -28,9 +30,9 @@ CONFIGURE_ARGS= --with-qt-includes=${QT_PREFIX}/include \
INSTALLS_SHLIB= yes
CPPFLAGS= -I${LOCALBASE}/include -I${PREFIX}/include \
- -I${QT_PREFIX}/include -DHAVE_DECL_GETOPT
+ -I${QT_PREFIX}/include -DHAVE_DECL_GETOPT ${PTHREAD_CFLAGS}
LDFLAGS= -Wl,-export-dynamic -L${LOCALBASE}/lib -L${X11BASE}/lib \
- -ljpeg -L${QT_PREFIX}/lib -lcompat
+ -ljpeg -L${QT_PREFIX}/lib -lcompat ${PTHREAD_LIBS}
post-extract:
@${FIND} ${WRKSRC} -name "moc_*" -delete
@@ -41,6 +43,8 @@ post-patch:
's|malloc\.h|stdlib.h|g'
@${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
's|-ldl||g ; \
- s|-lpthread|${PTHREAD_LIBS}|g'
+ s|-lpthread||g ; \
+ s|-release @VERSION@|| ; \
+ s|LDFLAGS = -module|LDFLAGS = @LDFLAGS@ -module|g'
.include <bsd.port.mk>