aboutsummaryrefslogtreecommitdiff
path: root/graphics/tulip/Makefile
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2011-04-12 15:32:01 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2011-04-12 15:32:01 +0000
commit190d451ad0a4ba069e49a55667aad4148fd1676b (patch)
tree4fa7d3faa0daff062eb00aeaa76a1174c68c2beb /graphics/tulip/Makefile
parent9f2daf6b4f5622a0c07fd6d6e32f8946b390fb0f (diff)
downloadports-190d451ad0a4ba069e49a55667aad4148fd1676b.tar.gz
ports-190d451ad0a4ba069e49a55667aad4148fd1676b.zip
Notes
Diffstat (limited to 'graphics/tulip/Makefile')
-rw-r--r--graphics/tulip/Makefile28
1 files changed, 14 insertions, 14 deletions
diff --git a/graphics/tulip/Makefile b/graphics/tulip/Makefile
index 86ea24de6823..32450e8616d1 100644
--- a/graphics/tulip/Makefile
+++ b/graphics/tulip/Makefile
@@ -7,27 +7,35 @@
#
PORTNAME= tulip
-PORTVERSION= 3.4.1
+PORTVERSION= 3.5.0
CATEGORIES= graphics
MASTER_SITES= SF/auber/${PORTNAME}/${PORTNAME}-${PORTVERSION}
-DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
+DISTFILES= ${DISTNAME}-src${EXTRACT_SUFX}
MAINTAINER= gahr@FreeBSD.org
COMMENT= A system dedicated to the visualization of huge graphs
-LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2
+LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2 \
+ gzstream.0:${PORTSDIR}/devel/gzstream \
+ ftgl.2:${PORTSDIR}/graphics/ftgl \
+ qscintilla2:${PORTSDIR}/devel/qscintilla2 \
+ jpeg.11:${PORTSDIR}/graphics/jpeg
-USE_BZIP2= yes
USE_QT_VER= 4
QT_COMPONENTS= corelib moc_build uic_build rcc_build gui opengl xml network \
designer assistant assistantclient
USE_GL= glew glut
USE_GMAKE= yes
USE_GNOME= libxml2
-USE_AUTOTOOLS= libtool
-
+USE_PYTHON= yes
+USE_CMAKE= yes
+CMAKE_OUTSOURCE=yes
+CMAKE_ARGS+= -DLOCALBASE:PATH=${LOCALBASE} \
+ -DPYTHON_INCLUDEDIR:PATH=${PYTHON_INCLUDEDIR}
USE_LDCONFIG= yes
+WRKSRC= ${WRKDIR}/${DISTNAME}-src
+
PLIST_SUB+= TULIP_VERSION=${PORTVERSION} \
TULIP_VERS=${PORTVERSION:R}
@@ -41,18 +49,10 @@ CFLAGS+= -fPIC
# @${FIND} ${WRKSRC} -name "moc_*" -delete
post-patch:
- @${GREP} -lr '/usr/X11R6/include' ${WRKSRC} | ${XARGS} \
- ${REINPLACE_CMD} -e 's|/usr/X11R6/include|${LOCALBASE}/include|g'
@${REINPLACE_CMD} -e 's|<qdir.h>|<QtCore/qdir.h>|' \
${WRKSRC}/software/tulip/src/Application.cpp
@${REINPLACE_CMD} -e 's|<qtimer.h>|<QtCore/qtimer.h>|;s|<qlocale.h>|<QtCore/qlocale.h>|' \
${WRKSRC}/software/tulip/src/main.cpp
- @${REINPLACE_CMD} -e 's|doxygen||g' \
- ${WRKSRC}/docs/Makefile.am ${WRKSRC}/docs/Makefile.in
- @${REINPLACE_CMD} -e '534,535d' ${WRKSRC}/docs/doxygen/Makefile.in
- @${REINPLACE_CMD} -e '132,133d' ${WRKSRC}/docs/doxygen/Makefile.am
-
-# @${REINPLACE_CMD} -e 's|docs||g' ${WRKSRC}/Makefile.am ${WRKSRC}/Makefile.in
.if !defined(NOPORTDOCS)
DISTFILES+= ${PORTNAME}-${PORTVERSION}-html.tar.bz2