aboutsummaryrefslogtreecommitdiff
path: root/graphics/tulip/Makefile
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2014-04-22 13:24:48 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2014-04-22 13:24:48 +0000
commite1ab652da9351bd105ca606e88a89e3b925f8d2d (patch)
treebc7500495353af66c386accb799b7a375c8e3841 /graphics/tulip/Makefile
parent15ddf31e17124b986256b19b94b451a78983ed08 (diff)
downloadports-e1ab652da9351bd105ca606e88a89e3b925f8d2d.tar.gz
ports-e1ab652da9351bd105ca606e88a89e3b925f8d2d.zip
Notes
Diffstat (limited to 'graphics/tulip/Makefile')
-rw-r--r--graphics/tulip/Makefile14
1 files changed, 2 insertions, 12 deletions
diff --git a/graphics/tulip/Makefile b/graphics/tulip/Makefile
index 2b11c8f4aafd..47bc2218a9a9 100644
--- a/graphics/tulip/Makefile
+++ b/graphics/tulip/Makefile
@@ -10,12 +10,11 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}_src
MAINTAINER= gahr@FreeBSD.org
COMMENT= System dedicated to the visualization of huge graphs
-OPTIONS_DEFINE= DOCS
-
LIB_DEPENDS= libexecinfo.so:${PORTSDIR}/devel/libexecinfo \
libQxtCore.so:${PORTSDIR}/devel/libqxt \
libOGDF.so:${PORTSDIR}/math/ogdf \
- libpng.so:${PORTSDIR}/graphics/png
+ libpng.so:${PORTSDIR}/graphics/png \
+ libjpeg.so:${PORTSDIR}/graphics/jpeg
USES= cmake:outsource compiler:c++11-lib shebangfix dos2unix
SHEBANG_FILES= tulip-config.in
@@ -39,13 +38,4 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
PLIST_SUB+= TULIP_VERSION=${PORTVERSION} \
TULIP_VERS=${PORTVERSION:R}
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MDOCS}
-PORTDOCS= *
-post-install:
- ${INSTALL} -d ${STAGEDIR}${DOCSDIR}
- (cd ${WRKDIR}/${PORTNAME}-${PORTVERSION}-html && ${COPYTREE_SHARE} \* ${STAGEDIR}${DOCSDIR})
-.endif
-
.include <bsd.port.mk>