aboutsummaryrefslogtreecommitdiff
path: root/graphics/tulip
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2013-12-24 21:22:21 +0000
committerKoop Mast <kwm@FreeBSD.org>2013-12-24 21:22:21 +0000
commitb1bf1620a6571c5eb84bed4e3f06cf52094d0a48 (patch)
tree93506aaee5230ee46b75930c4b3a6b8e0f243d74 /graphics/tulip
parent123411e1ee17366ee88efd54b8482949b8e76eb5 (diff)
downloadports-b1bf1620a6571c5eb84bed4e3f06cf52094d0a48.tar.gz
ports-b1bf1620a6571c5eb84bed4e3f06cf52094d0a48.zip
Notes
Diffstat (limited to 'graphics/tulip')
-rw-r--r--graphics/tulip/files/patch-thirdparty-ftgl-CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/graphics/tulip/files/patch-thirdparty-ftgl-CMakeLists.txt b/graphics/tulip/files/patch-thirdparty-ftgl-CMakeLists.txt
new file mode 100644
index 000000000000..e6b48cb465d8
--- /dev/null
+++ b/graphics/tulip/files/patch-thirdparty-ftgl-CMakeLists.txt
@@ -0,0 +1,10 @@
+--- thirdparty/ftgl/CMakeLists.txt.orig 2013-12-24 22:28:17.000000000 +0200
++++ thirdparty/ftgl/CMakeLists.txt 2013-12-24 22:28:03.000000000 +0200
+@@ -104,6 +104,7 @@
+
+ INCLUDE_DIRECTORIES(${CMAKE_CURRENT_SOURCE_DIR})
+ INCLUDE_DIRECTORIES(${FREETYPE_INCLUDE_DIRS})
++INCLUDE_DIRECTORIES(${OPENGL_INCLUDE_DIR})
+
+ ADD_LIBRARY(ftgl SHARED ${ftgl_SRCS} ${ftgl_headers_SRCS} ${ftglyph_SRCS} ${ftfont_SRCS} ${ftlayout_SRCS})
+ TARGET_LINK_LIBRARIES(ftgl ${OPENGL_gl_LIBRARY} ${OPENGL_glu_LIBRARY} ${FREETYPE_LIBRARY})