aboutsummaryrefslogtreecommitdiff
path: root/graphics/ufraw/Makefile
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2006-06-04 17:51:54 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2006-06-04 17:51:54 +0000
commit6a353cae7cadab09934169be2ef2e749dd760ed0 (patch)
treebfe99e0547fec0ed93ded6ac9edbb1bce404e727 /graphics/ufraw/Makefile
parentee1d6dba74737524dfd1c4f7b31260e0f6d1a9d6 (diff)
downloadports-6a353cae7cadab09934169be2ef2e749dd760ed0.tar.gz
ports-6a353cae7cadab09934169be2ef2e749dd760ed0.zip
Notes
Diffstat (limited to 'graphics/ufraw/Makefile')
-rw-r--r--graphics/ufraw/Makefile28
1 files changed, 19 insertions, 9 deletions
diff --git a/graphics/ufraw/Makefile b/graphics/ufraw/Makefile
index a92050911f34..43fe2b5bfbcf 100644
--- a/graphics/ufraw/Makefile
+++ b/graphics/ufraw/Makefile
@@ -1,22 +1,23 @@
-# New ports collection makefile for: UFRaw gimp plugin
-# Date created: Sun 10 Apr 2005 14:44:15 BST
-# Whom: markm@FreeBSD.org
+# New ports collection makefile for: UFRaw
+# Date created: Sun 10 Apr 2005 14:44:15 BST
+# Whom: markm@FreeBSD.org
#
# $FreeBSD$
+#
-PORTNAME= gimp-ufraw
-PORTVERSION= 0.6
+PORTNAME= ufraw
+PORTVERSION= 0.8.1
CATEGORIES= graphics gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ufraw
-DISTNAME= ufraw-${PORTVERSION}
+MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= markm@FreeBSD.org
-COMMENT= GIMP plug-in for raw digital camera image importing
+COMMENT= Read and manipulate raw images from digital cameras
BUILD_DEPENDS= gimp:${PORTSDIR}/graphics/gimp
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
tiff.4:${PORTSDIR}/graphics/tiff
+RUN_DEPENDS= ${BUILD_DEPENDS}
GNU_CONFIGURE= yes
USE_X_PREFIX= yes
@@ -27,12 +28,21 @@ WANT_GNOME= yes
CONFIGURE_ENV= LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib" \
CFLAGS="${CFLAGS} -I ${LOCALBASE}/include"
+.ifndef WITHOUT_EXIF
+LIB_DEPENDS+= exif:${PORTSDIR}/graphics/libexif
+CONFIGURE_ARGS+= --with-libexif
+.ifndef WITHOUT_EXIV2
+LIB_DEPENDS+= exiv2:${PORTSDIR}/graphics/exiv2
+CONFIGURE_ARGS+= --with-exiv2
+.endif
+.endif
+
MAN1= ufraw.1
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 504105
-BROKEN= "Needs memmem(3)"
+BROKEN= Needs memmem(3)
.endif
.include <bsd.port.post.mk>