aboutsummaryrefslogtreecommitdiff
path: root/graphics/ufraw
diff options
context:
space:
mode:
authorMark Murray <markm@FreeBSD.org>2005-05-18 18:33:56 +0000
committerMark Murray <markm@FreeBSD.org>2005-05-18 18:33:56 +0000
commitb07de7862159aaa9669ec411856dad9fbcfdd20b (patch)
treebee3cc7a42cf5bc0fbf27b7e7ebeb4eefe155633 /graphics/ufraw
parent7bda937f26148dfa9d78378cc502b0af58076a00 (diff)
downloadports-b07de7862159aaa9669ec411856dad9fbcfdd20b.tar.gz
ports-b07de7862159aaa9669ec411856dad9fbcfdd20b.zip
Notes
Diffstat (limited to 'graphics/ufraw')
-rw-r--r--graphics/ufraw/Makefile4
-rw-r--r--graphics/ufraw/files/patch-Makefile26
2 files changed, 27 insertions, 3 deletions
diff --git a/graphics/ufraw/Makefile b/graphics/ufraw/Makefile
index fd64c71d8ae6..dcabb8a0f1ba 100644
--- a/graphics/ufraw/Makefile
+++ b/graphics/ufraw/Makefile
@@ -17,11 +17,9 @@ RUN_DEPENDS= gimp:${PORTSDIR}/graphics/gimp
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
tiff.4:${PORTSDIR}/graphics/tiff
-BROKEN= Missing dependency
-
USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_GNOME= gnomehack intltool intlhack gtk20 libartlgpl2
+USE_GNOME= glib20 gnomehack intltool intlhack gtk20 libartlgpl2
WANT_GNOME= yes
ALL_TARGET= build
INSTALL_TARGET= install-admin
diff --git a/graphics/ufraw/files/patch-Makefile b/graphics/ufraw/files/patch-Makefile
new file mode 100644
index 000000000000..9a5f5a0deadc
--- /dev/null
+++ b/graphics/ufraw/files/patch-Makefile
@@ -0,0 +1,26 @@
+--- ./Makefile.orig Tue Apr 19 23:53:14 2005
++++ ./Makefile Tue Apr 19 23:56:49 2005
+@@ -17,7 +17,7 @@
+ OBJECTS := $(filter-out dcraw.o,$(OBJECTS))
+ endif
+ CC = gcc
+-CFLAGS += -std=gnu99 -DUFRAW_VERSION='"$(VER)"'
++CFLAGS += -std=gnu99 -DUFRAW_VERSION='"$(VER)"' -I/usr/local/include
+ # To check that deprecated features are not used:
+ #CFLAGS += -DG_DISABLE_DEPRECATED -DGDK_DISABLE_DEPRECATED -DGTK_DISABLE_DEPRECATED
+ LDFLAGS += -llcms
+@@ -91,12 +91,12 @@
+ ifdef UFRAW_NO_JPEG
+ CFLAGS += -DNO_JPEG
+ else
+- LDFLAGS += -ljpeg
++ LDFLAGS += -L/usr/local/lib -ljpeg
+ endif
+ ifdef UFRAW_NO_TIFF
+ CFLAGS += -DNO_TIFF
+ else
+- LDFLAGS += -ltiff
++ LDFLAGS += -L/usr/local/lib -ltiff
+ endif
+ ifdef UFRAW_NO_ZLIB
+ CFLAGS += -DNO_ZLIB