aboutsummaryrefslogtreecommitdiff
path: root/graphics/ufraw
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2009-05-27 11:32:02 +0000
committerStanislav Sedov <stas@FreeBSD.org>2009-05-27 11:32:02 +0000
commit185429f8265f59eec835676deb3aca7e66847fb9 (patch)
tree7a24617b780b2d6b53240cc8f2d4044ba7e1f613 /graphics/ufraw
parent988845fe8ee58d46d658e8e833c9af91dd0867f8 (diff)
downloadports-185429f8265f59eec835676deb3aca7e66847fb9.tar.gz
ports-185429f8265f59eec835676deb3aca7e66847fb9.zip
Notes
Diffstat (limited to 'graphics/ufraw')
-rw-r--r--graphics/ufraw/Makefile20
1 files changed, 15 insertions, 5 deletions
diff --git a/graphics/ufraw/Makefile b/graphics/ufraw/Makefile
index 7ea38989f935..7f535ac44531 100644
--- a/graphics/ufraw/Makefile
+++ b/graphics/ufraw/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ufraw
PORTVERSION= 0.15
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics gnome
MASTER_SITES= SF
@@ -30,20 +30,30 @@ LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
CPPFLAGS= -I${LOCALBASE}/include
CONFIGURE_ENV= LDFLAGS="${LDFLAGS}" CPPFLAGS="${CPPFLAGS}"
CONFIGURE_ARGS= --enable-mime
-
PC_FALSE+= cinepaint
-.ifndef WITHOUT_EXIV2
+
+OPTIONS= EXIV2 "EXIF support via exiv2 library" on \
+ GIMP "Install GIMP UFRaw plugin" on \
+ LENSFUN "Build with LenFun library support" on
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_EXIV2)
LIB_DEPENDS+= exiv2:${PORTSDIR}/graphics/exiv2
.else
PC_FALSE+= exiv2
.endif
-.ifndef WITHOUT_GIMP
+.if !defined(WITHOUT_GIMP)
LIB_DEPENDS+= gimp-2.0.0:${PORTSDIR}/graphics/gimp-app
PLIST_SUB+= GIMP=""
.else
PC_FALSE+= gimp
PLIST_SUB+= GIMP="@comment "
.endif
+.if !defined(WITHOUT_LENSFUN)
+LIB_DEPENDS+= lensfun.0:${PORTSDIR}/graphics/lensfun
+CONFIGURE_ARGS+= --with-lensfun
+.endif
MAN1= ufraw.1
@@ -54,4 +64,4 @@ post-patch:
@${REINPLACE_CMD} -e '/PKG_CONFIG.*$i/s|$$PKG_CONFIG|${FALSE}|' ${WRKSRC}/configure
.endfor
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>