aboutsummaryrefslogtreecommitdiff
path: root/graphics/vertex
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2006-10-14 08:54:54 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2006-10-14 08:54:54 +0000
commit29747f458a1eb2ce23b4594b09d0256dd62760b8 (patch)
tree1b71ba5d9ffdd308b6c18130f7c116f5bab5dc12 /graphics/vertex
parent7aad84f808b93baa6a7077ce0b47573b9c4c79a0 (diff)
downloadports-29747f458a1eb2ce23b4594b09d0256dd62760b8.tar.gz
ports-29747f458a1eb2ce23b4594b09d0256dd62760b8.zip
Notes
Diffstat (limited to 'graphics/vertex')
-rw-r--r--graphics/vertex/Makefile4
-rw-r--r--graphics/vertex/files/patch-platforms.ini29
-rw-r--r--graphics/vertex/files/patch-vmahelp.c2
3 files changed, 23 insertions, 12 deletions
diff --git a/graphics/vertex/Makefile b/graphics/vertex/Makefile
index 2a3d43d25507..f7ed8594c9df 100644
--- a/graphics/vertex/Makefile
+++ b/graphics/vertex/Makefile
@@ -7,7 +7,7 @@
PORTNAME= vertex
PORTVERSION= 0.1.15
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= graphics
MASTER_SITES= http://wolfpack.twu.net/users/wolfpack/
@@ -17,7 +17,7 @@ COMMENT= A 3D modeller for generating efficient game models
LIB_DEPENDS= gtkgl.5:${PORTSDIR}/x11-toolkits/gtkglarea
USE_BZIP2= yes
-USE_X_PREFIX= yes
+USE_XLIB= yes
USE_GL= yes
USE_GNOME= imlib
USE_GMAKE= yes
diff --git a/graphics/vertex/files/patch-platforms.ini b/graphics/vertex/files/patch-platforms.ini
index 7428f4c3062b..647c154d41dd 100644
--- a/graphics/vertex/files/patch-platforms.ini
+++ b/graphics/vertex/files/patch-platforms.ini
@@ -1,6 +1,6 @@
---- vertex/platforms.ini.orig Wed Oct 1 06:44:17 2003
-+++ vertex/platforms.ini Tue Oct 21 22:05:42 2003
-@@ -22,23 +22,23 @@
+--- vertex/platforms.ini.orig Mon Nov 1 00:35:03 2004
++++ vertex/platforms.ini Thu Oct 5 17:14:40 2006
+@@ -22,23 +22,26 @@
Platform = UNIX
Description = For most any UNIX system
@@ -17,35 +17,46 @@
+ CPP = %%CXX%%
PlatformSearchPathInclude = /usr/include/
- PlatformSearchPathInclude = /usr/X11R6/include/
++ PlatformSearchPathInclude = %%LOCALBASE%%/include/
+ PlatformSearchPathInclude = %%X11BASE%%/include/
PlatformSearchPathLib = /lib/
PlatformSearchPathLib = /usr/lib/
- PlatformSearchPathLib = /usr/X11R6/lib/
++ PlatformSearchPathLib = %%LOCALBASE%%/lib/
+ PlatformSearchPathLib = %%X11BASE%%/lib/
PlatformSearchPathEtc = /etc/
PlatformSearchPathEtc = /usr/etc/
PlatformSearchPathBin = /bin/
PlatformSearchPathBin = /usr/bin/
- PlatformSearchPathBin = /usr/X11R6/bin/
++ PlatformSearchPathBin = %%LOCALBASE%%/bin/
+ PlatformSearchPathBin = %%X11BASE%%/bin/
PlatformSearchPathData = /usr/share/icons/
PlatformFeature = debug
Description = Just adds -g to the CFLAGS for debugging
-@@ -51,7 +51,7 @@
+@@ -51,7 +54,7 @@
# Newer versions of Imlib only need to link to -lImlib
# FeatureLIBS = -lImlib -lpng -ltiff -ljpeg -lz
FeatureLIBS = -lImlib
- FeatureLIB_DIR = -L/usr/X11R6/lib/
-+ FeatureLIB_DIR = -L%%X11BASE%%/lib/
++ FeatureLIB_DIR = -L%%LOCALBASE%%/lib/
FeatureDepend = Imlib-lib
DependType = Library
MustExist = Yes
-@@ -83,11 +83,11 @@
+@@ -66,6 +69,7 @@
+ Description = An implementation of OpenGL (ie Mesa3D)
+ MustExist = Yes
+ FeatureLIBS = -lGL -lGLU
++ FeatureLIB_DIR = -L%%X11BASE%%/lib/
+ FeatureDepend = gl-lib
+ DependType = Library
+ MustExist = Yes
+@@ -83,11 +87,11 @@
MustExist = Yes
FeatureCFLAGS = `gtk-config --cflags`
FeatureLIBS = `gtk-config --libs`
- FeatureLIB_DIR = -L/usr/X11R6/lib/
-+ FeatureLIB_DIR = -L%%X11BASE%%/lib/
++ FeatureLIB_DIR = -L%%LOCALBASE%%/lib/
FeatureDepend = gtk-lib
DependType = Library
MustExist = Yes
@@ -54,12 +65,12 @@
DependGrepString = gtk_init
FeatureDepend = gtk-devel
DependType = Program
-@@ -98,7 +98,7 @@
+@@ -98,7 +102,7 @@
MustExist = Yes
FeatureCFLAGS =
FeatureLIBS = -lgtkgl
- FeatureLIB_DIR = -L/usr/X11R6/lib/
-+ FeatureLIB_DIR = -L%%X11BASE%%/lib/
++ FeatureLIB_DIR = -L%%LOCALBASE%%/lib/
FeatureDepend = gtkgl-lib
DependType = Library
MustExist = Yes
diff --git a/graphics/vertex/files/patch-vmahelp.c b/graphics/vertex/files/patch-vmahelp.c
index 11789bbc9265..63dc6bb58d03 100644
--- a/graphics/vertex/files/patch-vmahelp.c
+++ b/graphics/vertex/files/patch-vmahelp.c
@@ -10,7 +10,7 @@ $FreeBSD$
- "/usr/bin/gnome-help-browser", "", (char *)HELP_PROG_INPUT_TYPE_URL, \
- "/usr/local/bin/gnome-help-browser", "", (char *)HELP_PROG_INPUT_TYPE_URL, \
- "/bin/gnome-help-browser", "", (char *)HELP_PROG_INPUT_TYPE_URL, \
-+ "%%X11BASE%%/bin/gnome-help-browser", "", (char *)HELP_PROG_INPUT_TYPE_URL, \
++ "%%LOCALBASE%%/bin/gnome-help-browser", "", (char *)HELP_PROG_INPUT_TYPE_URL, \
\
- "/usr/bin/netscape", "", (char *)HELP_PROG_INPUT_TYPE_URL, \
- "/usr/local/bin/netscape", "", (char *)HELP_PROG_INPUT_TYPE_URL, \