aboutsummaryrefslogtreecommitdiff
path: root/graphics/view3ds
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2002-04-24 14:05:05 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2002-04-24 14:05:05 +0000
commit8e2c7690f730653ab695bbada84bb7a4d94da98b (patch)
treeb8bdb1cb05455675cbadaf6c217f3a2492c22dc1 /graphics/view3ds
parent0967117d38f7162347cdddeba7f885cddcee8f3b (diff)
downloadports-8e2c7690f730653ab695bbada84bb7a4d94da98b.tar.gz
ports-8e2c7690f730653ab695bbada84bb7a4d94da98b.zip
Notes
Diffstat (limited to 'graphics/view3ds')
-rw-r--r--graphics/view3ds/Makefile5
-rw-r--r--graphics/view3ds/files/patch-view3ds::document.cpp38
2 files changed, 41 insertions, 2 deletions
diff --git a/graphics/view3ds/Makefile b/graphics/view3ds/Makefile
index d6bf3a8bb550..26834383c76d 100644
--- a/graphics/view3ds/Makefile
+++ b/graphics/view3ds/Makefile
@@ -13,14 +13,15 @@ MASTER_SITE_SUBDIR= lib3ds
MAINTAINER= sobomax@FreeBSD.org
-LIB_DEPENDS= 3ds.0:${PORTSDIR}/graphics/lib3ds
+LIB_DEPENDS= 3ds.1:${PORTSDIR}/graphics/lib3ds
USE_X_PREFIX= yes
USE_QT_VER= 2
USE_MESA= yes
USE_GMAKE= yes
USE_LIBTOOL= yes
-CONFIGURE_ENV= LDFLAGS="-lm ${PTHREAD_LIBS}" \
+CONFIGURE_ENV= CPPFLAGS="-fno-rtti -fno-exceptions" \
+ LDFLAGS="-lm ${PTHREAD_LIBS}" \
QTDIR=${X11BASE}
.include <bsd.port.mk>
diff --git a/graphics/view3ds/files/patch-view3ds::document.cpp b/graphics/view3ds/files/patch-view3ds::document.cpp
new file mode 100644
index 000000000000..6f2d0ae8e1ea
--- /dev/null
+++ b/graphics/view3ds/files/patch-view3ds::document.cpp
@@ -0,0 +1,38 @@
+
+$FreeBSD$
+
+--- view3ds/document.cpp 2002/04/24 11:23:51 1.1
++++ view3ds/document.cpp 2002/04/24 11:24:33
+@@ -42,7 +42,9 @@
+ Document::~Document()
+ {
+ if (d_file) {
++#if 0
+ lib3ds_close(d_file);
++#endif
+ d_file=0;
+ }
+ }
+@@ -55,17 +57,21 @@
+ Document::open(QString filename)
+ {
+ if (d_file) {
++#if 0
+ lib3ds_close(d_file);
++#endif
+ d_file=0;
+ }
+- d_file=lib3ds_open((const char*)filename);
++ d_file=lib3ds_file_load((const char*)filename);
+ if (!d_file) {
+ puts("***ERROR*** Loading 3DS file failed.");
+ return(false);
+ }
+ if (!d_file->cameras) {
+ puts("***ERROR*** No Camera found.");
++#if 0
+ lib3ds_close(d_file);
++#endif
+ d_file=0;
+ return(false);
+ }