aboutsummaryrefslogtreecommitdiff
path: root/graphics/vigra/Makefile
diff options
context:
space:
mode:
authorDima Panov <fluffy@FreeBSD.org>2013-03-13 13:53:29 +0000
committerDima Panov <fluffy@FreeBSD.org>2013-03-13 13:53:29 +0000
commit0179f700321ca7921727f52fef3936e4f2356806 (patch)
tree2059106c0e154d482d45798927213805a514cfc7 /graphics/vigra/Makefile
parent32c58244fa773d2974ffe6505887dff6ff3d8046 (diff)
downloadports-0179f700321ca7921727f52fef3936e4f2356806.tar.gz
ports-0179f700321ca7921727f52fef3936e4f2356806.zip
Notes
Diffstat (limited to 'graphics/vigra/Makefile')
-rw-r--r--graphics/vigra/Makefile24
1 files changed, 15 insertions, 9 deletions
diff --git a/graphics/vigra/Makefile b/graphics/vigra/Makefile
index 252dd6840e72..2aca42aa2753 100644
--- a/graphics/vigra/Makefile
+++ b/graphics/vigra/Makefile
@@ -3,7 +3,7 @@
PORTNAME= vigra
PORTVERSION= 1.9.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
MASTER_SITES= http://hci.iwr.uni-heidelberg.de/vigra/
DISTNAME= ${PORTNAME}-${PORTVERSION}-src
@@ -21,8 +21,9 @@ CMAKE_ARGS= -DDEPENDENCY_SEARCH_PREFIX:PATH=${LOCALBASE} \
USE_LDCONFIG= yes
-OPTIONS_DEFINE= HDF5 OPENEXR PYTHON
+OPTIONS_DEFINE= HDF5 OPENEXR NUMPY
OPTIONS_DEFAULT= HDF5 OPENEXR
+NUMPY_DESC= NumPy mathematical computing (USE Fortran/GCC46+)
.include <bsd.port.options.mk>
@@ -40,9 +41,11 @@ LIB_DEPENDS+= IlmImf:${PORTSDIR}/graphics/OpenEXR
CMAKE_ARGS+= -DWITH_OPENEXR=0
.endif
-.if ${PORT_OPTIONS:MPYTHON}
+.if ${PORT_OPTIONS:MNUMPY}
CONFLICTS_BUILD= python3*
CMAKE_ARGS+= -DWITH_VIGRANUMPY=1
+USE_GCC= 4.6+
+USE_FORTRAN= yes
USE_PYTHON= 2.6-2.7
BUILD_DEPENDS+= nosetests:${PORTSDIR}/devel/py-nose
BUILD_DEPENDS+= ${PYTHON_SITELIBDIR}/numpy/core/numeric.py:${PORTSDIR}/math/py-numpy
@@ -57,12 +60,6 @@ PLIST_SUB+= PYTHON="@comment "
.include <bsd.port.pre.mk>
-# Check for clang, else use gcc46+
-CPP_check!= ${CPP} --version | tr -d '()'
-.if !${CPP_check:Mclang}
-USE_GCC= 4.6+
-.endif
-
# Vigra's CMakeLists.txt does not support disabling those so we hook them
# as dependencies here unconditionally (without OPTIONS=) even though if
# they are not present then Vigra/CMake will do without them (they are not
@@ -91,6 +88,15 @@ LIB_DEPENDS+= fftw3:${PORTSDIR}/math/fftw3
LIB_DEPENDS+= fftw3f:${PORTSDIR}/math/fftw3-float
.endif
+pre-everything::
+.if ${PORT_OPTIONS:MNUMPY}
+ @${ECHO} ""
+ @${ECHO} "* BEWARE!"
+ @${ECHO} "* Using py-NumPY implies Fortran and GCC4.6+ as hard dependencies"
+ @${ECHO} "* and require to all ports, depended on vigra, set USE_GCC=4.6+"
+ @${ECHO} ""
+.endif
+
post-patch:
# FIXME: This is ugly
@${RM} ${WRKSRC}/include/vigra/*.orig