aboutsummaryrefslogtreecommitdiff
path: root/graphics/vips/Makefile
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2014-07-01 18:59:49 +0000
committerMikhail Teterin <mi@FreeBSD.org>2014-07-01 18:59:49 +0000
commit1a79a9e86fc7035723be71cf79dfcfcd9227f611 (patch)
tree466084704da829da74fa49dd5974f93e7c0f51bd /graphics/vips/Makefile
parent046f632b9dad646fde1414d4317a1498298e8c29 (diff)
Notes
Diffstat (limited to 'graphics/vips/Makefile')
-rw-r--r--graphics/vips/Makefile49
1 files changed, 19 insertions, 30 deletions
diff --git a/graphics/vips/Makefile b/graphics/vips/Makefile
index 96da514e09a4..b261b6aaf8a0 100644
--- a/graphics/vips/Makefile
+++ b/graphics/vips/Makefile
@@ -2,30 +2,29 @@
# $FreeBSD$
PORTNAME= vips
-PORTVERSION= 7.26.3
-PORTREVISION= 10
+PORTVERSION= 7.40.2
CATEGORIES= graphics
MASTER_SITES= http://www.vips.ecs.soton.ac.uk/supported/${PORTVERSION:R}/
MAINTAINER= mi@aldan.algebra.com
COMMENT= Free image processing system
-OPTIONS_DEFINE= LIBOIL PYTHON DOCS
-OPTIONS_DEFAULT= LIBOIL
-LIBOIL_DESC= Use liboil for CPU-optimized primitives
+OPTIONS_DEFINE= PYTHON DOCS
+OPTIONS_DEFAULT=
PYTHON_DESC= Create Python bindings
BUILD_DEPENDS= p5-XML-Parser>=0:${PORTSDIR}/textproc/p5-XML-Parser
LIB_DEPENDS= libfftw3.so:${PORTSDIR}/math/fftw3 \
libjpeg.so:${PORTSDIR}/graphics/jpeg \
libexif.so:${PORTSDIR}/graphics/libexif \
+ liblcms2.so:${PORTSDIR}/graphics/lcms2 \
libtiff.so:${PORTSDIR}/graphics/tiff \
libGraphicsMagick.so:${PORTSDIR}/graphics/GraphicsMagick \
libIlmImf.so:${PORTSDIR}/graphics/OpenEXR \
- liborc-0.4.so:${PORTSDIR}/devel/orc \
+ liborc-0.4.so:${PORTSDIR}/devel/orc \
+ libcfitsio.so:${PORTSDIR}/astro/cfitsio \
libpng15.so:${PORTSDIR}/graphics/png \
- libmatio.so:${PORTSDIR}/math/matio \
- liblcms.so:${PORTSDIR}/graphics/lcms
+ libmatio.so:${PORTSDIR}/math/matio
PYPRESENT!= which python > /dev/null && echo on || echo off
.if ${PYPRESENT} == on
@@ -34,7 +33,7 @@ OPTIONS_DEFAULT+= PYTHON
USES= gettext gmake libtool pathfix perl5 pkgconfig shebangfix
USE_PERL5= build
SHEBANG_FILES= tools/vips-${PORTVERSION:R}
-USE_GNOME= glib20 pango libxml2
+USE_GNOME= glib20 pango libxml2 libgsf
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
@@ -44,16 +43,17 @@ post-configure:
${WRKSRC}/po/Makefile
.include <bsd.port.options.mk>
-# Don't extract doc/ subdirectory - the simplest way:
+
.if ! ${PORT_OPTIONS:MDOCS}
-EXTRACT_AFTER_ARGS= --exclude doc
-EXTRA_PATCHES= ${FILESDIR}/nodoc-patch
+CONFIGURE_ARGS+=--disable-docs
+EXTRACT_AFTER_ARGS+= --exclude doc
+EXTRA_PATCHES+= ${FILESDIR}/nodoc-patch
.endif
+
PLIST_SUB+= VERSION=${PORTVERSION:R}
CONFIGURE_ENV+= MAGICK_CFLAGS="-I${LOCALBASE}/include/GraphicsMagick"
CONFIGURE_ARGS+=--without-x --mandir=${STAGEDIR}${PREFIX}/man --with-magickpackage=GraphicsMagick
-CONFIGURE_ARGS+=--without-v4l
.for p in tiff jpeg zip png
CONFIGURE_ARGS+=--with-$p-includes=${LOCALBASE}/include
CONFIGURE_ARGS+=--with-$p-libraries=${LOCALBASE}/lib
@@ -62,25 +62,14 @@ CONFIGURE_ARGS+=--with-$p-libraries=${LOCALBASE}/lib
.if ${PORT_OPTIONS:MPYTHON}
USE_PYTHON= yes
PLIST_SUB+= PY=""
-.else
-CONFIGURE_ARGS= --without-python
-PLIST_SUB+= PY="@comment "
-.endif
-.include <bsd.port.pre.mk>
+post-patch::
+ ${REINPLACE_CMD} -e 's|/usr/bin/python|${PYTHON_CMD}|' \
+ ${WRKSRC}/tools/vipsprofile
-.if ${ARCH} == "sparc64" && ${OSVERSION} > 900000
-BROKEN= Does not compile on sparc64-9
-.endif
-
-.if ${PORT_OPTIONS:MLIBOIL}
-LIB_DEPENDS+= liboil-0.3.so:${PORTSDIR}/devel/liboil
.else
-CONFIGURE_ARGS+= --without-liboil
+CONFIGURE_ARGS= --without-python
+PLIST_SUB+= PY="@comment "
.endif
-post-patch:
- @${REINPLACE_CMD} -e '/VIPS_CXX_LIBS="-lstdc++"/ d' \
- ${WRKSRC}/configure.in ${WRKSRC}/configure
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>