aboutsummaryrefslogtreecommitdiff
path: root/graphics/visionworkbench
diff options
context:
space:
mode:
authorGiuseppe Pilichi <jacula@FreeBSD.org>2010-08-07 12:35:37 +0000
committerGiuseppe Pilichi <jacula@FreeBSD.org>2010-08-07 12:35:37 +0000
commit4961f82123d8f6166a45bcfcd78b5ae67de5376c (patch)
tree123e32b9fdae6834a1165e2b86facfd260775fca /graphics/visionworkbench
parent2df7fabe1ec6b87bd513697370db836fcc51271b (diff)
downloadports-4961f82123d8f6166a45bcfcd78b5ae67de5376c.tar.gz
ports-4961f82123d8f6166a45bcfcd78b5ae67de5376c.zip
Notes
Diffstat (limited to 'graphics/visionworkbench')
-rw-r--r--graphics/visionworkbench/Makefile64
-rw-r--r--graphics/visionworkbench/distinfo3
-rw-r--r--graphics/visionworkbench/pkg-descr4
-rw-r--r--graphics/visionworkbench/pkg-plist248
4 files changed, 319 insertions, 0 deletions
diff --git a/graphics/visionworkbench/Makefile b/graphics/visionworkbench/Makefile
new file mode 100644
index 000000000000..3d4c1b102230
--- /dev/null
+++ b/graphics/visionworkbench/Makefile
@@ -0,0 +1,64 @@
+# New ports collection makefile for: visionworkbench
+# Date created: 2010-01-03
+# Whom: Steve Wills <steve@mouf.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= visionworkbench
+PORTVERSION= 2.0.0
+CATEGORIES= graphics
+MASTER_SITES= http://ti.arc.nasa.gov/m/project/nasa-vision-workbench/
+DISTNAME= VisionWorkbench-2.0.0
+
+MAINTAINER= steve@mouf.net
+COMMENT= A general purpose image processing and computer vision library
+
+LICENSE= NOSA
+LICENSE_NAME= NASA Open Source Agreement version 1.3
+LICENSE_GROUPS= OSI
+LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+GNU_CONFIGURE= yes
+USE_QT_VER= 4
+QT_COMPONENTS= moc_build qmake_build
+USE_GCC= 4.4+
+USE_LDCONFIG= yes
+USE_PYTHON= 2.4+
+
+LIB_DEPENDS+= jpeg.11:${PORTSDIR}/graphics/jpeg
+LIB_DEPENDS+= png.6:${PORTSDIR}/graphics/png
+LIB_DEPENDS+= boost_thread.4:${PORTSDIR}/devel/boost-libs
+LIB_DEPENDS+= boost_python.4:${PORTSDIR}/devel/boost-python-libs
+LIB_DEPENDS+= gdal:${PORTSDIR}/graphics/gdal
+LIB_DEPENDS+= lapack.4:${PORTSDIR}/math/lapack
+LIB_DEPENDS+= IlmImf.6:${PORTSDIR}/graphics/OpenEXR
+LIB_DEPENDS+= cairomm-1.0.1:${PORTSDIR}/graphics/cairomm
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 800025
+CFLAGS+= -Dsqrtl=sqrt
+. if ${OSVERSION} < 800022
+CFLAGS+= -Dtgammaf=tgamma
+. endif
+.endif
+
+pre-configure:
+ echo "HAVE_PKG_FLAPACK=yes" >> ${WRKSRC}/config.options
+ echo "PKG_FLAPACK_LDFLAGS=-L${LOCALBASE}/lib/${CC}" >> ${WRKSRC}/config.options
+ echo "HAVE_PKG_PYTHON=yes" >> ${WRKSRC}/config.options
+ echo "PYTHON_LDFLAGS=-L${PYTHON_LIBDIR} -lboost_python -l${PYTHON_VERSION} ${PTHREAD_LIBS}" >> ${WRKSRC}/config.options
+ echo "PYTHON_CPPFLAGS=-I${PYTHON_INCLUDEDIR}" >> ${WRKSRC}/config.options
+ echo "HAVE_PKG_QT=yes" >> ${WRKSRC}/config.options
+ echo "PKG_QT_LDFLAGS=-L${QT_LIBDIR}" >> ${WRKSRC}/config.options
+ echo "PKG_QT_CPPFLAGS=-I${QT_INCDIR}" >> ${WRKSRC}/config.options
+ echo "HAVE_PKG_BOOST=yes" >> ${WRKSRC}/config.options
+ echo "PKG_BOOST_THREAD_MORE_LIBS=${PTHREAD_LIBS}" >> ${WRKSRC}/config.options
+ echo "PKG_PATHS=${LOCALBASE}" >> ${WRKSRC}/config.options
+
+regression-test: build
+ @(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_ARGS} check)
+
+.include <bsd.port.post.mk>
diff --git a/graphics/visionworkbench/distinfo b/graphics/visionworkbench/distinfo
new file mode 100644
index 000000000000..1e46bc539306
--- /dev/null
+++ b/graphics/visionworkbench/distinfo
@@ -0,0 +1,3 @@
+MD5 (VisionWorkbench-2.0.0.tar.gz) = 2b8d340078cfee1bf233d46deab05a36
+SHA256 (VisionWorkbench-2.0.0.tar.gz) = 783808db4317d7d8624aab88143c639033c6cb0723e079ec3f8023ce87d894a6
+SIZE (VisionWorkbench-2.0.0.tar.gz) = 17580978
diff --git a/graphics/visionworkbench/pkg-descr b/graphics/visionworkbench/pkg-descr
new file mode 100644
index 000000000000..0b0ffac4db64
--- /dev/null
+++ b/graphics/visionworkbench/pkg-descr
@@ -0,0 +1,4 @@
+The NASA Vision Workbench (VW) is a general purpose image processing and
+computer vision library.
+
+WWW: http://ti.arc.nasa.gov/project/nasa-vision-workbench/
diff --git a/graphics/visionworkbench/pkg-plist b/graphics/visionworkbench/pkg-plist
new file mode 100644
index 000000000000..b3046a3a92e3
--- /dev/null
+++ b/graphics/visionworkbench/pkg-plist
@@ -0,0 +1,248 @@
+bin/bayer
+bin/blend
+bin/cnet_editor
+bin/colormap
+bin/contourgen
+bin/correlate
+bin/geoblend
+bin/georef
+bin/grassfirealpha
+bin/hdr_merge
+bin/hdr_tonemap
+bin/hillshade
+bin/image2qtree
+bin/image2toast
+bin/ipalign
+bin/ipfind
+bin/ipmatch
+bin/learnpca
+bin/print_exif
+bin/slopemap
+include/vw/BundleAdjustment.h
+include/vw/BundleAdjustment/AdjustBase.h
+include/vw/BundleAdjustment/AdjustRef.h
+include/vw/BundleAdjustment/AdjustRobustRef.h
+include/vw/BundleAdjustment/AdjustRobustSparse.h
+include/vw/BundleAdjustment/AdjustRobustSparseKGCP.h
+include/vw/BundleAdjustment/AdjustSparse.h
+include/vw/BundleAdjustment/BundleAdjustReport.h
+include/vw/BundleAdjustment/CameraRelation.h
+include/vw/BundleAdjustment/ControlNetwork.h
+include/vw/BundleAdjustment/ControlNetworkLoader.h
+include/vw/BundleAdjustment/ModelBase.h
+include/vw/Camera.h
+include/vw/Camera/BayerFilter.h
+include/vw/Camera/CAHVModel.h
+include/vw/Camera/CAHVORModel.h
+include/vw/Camera/CameraGeometry.h
+include/vw/Camera/CameraModel.h
+include/vw/Camera/CameraTransform.h
+include/vw/Camera/Exif.h
+include/vw/Camera/ExifData.h
+include/vw/Camera/Extrinsics.h
+include/vw/Camera/LensDistortion.h
+include/vw/Camera/LinearPushbroomModel.h
+include/vw/Camera/LinescanModel.h
+include/vw/Camera/OrbitingPushbroomModel.h
+include/vw/Camera/PinholeModel.h
+include/vw/Camera/PinholeModelCalibrate.h
+include/vw/Cartography.h
+include/vw/Cartography/CameraBBox.h
+include/vw/Cartography/Datum.h
+include/vw/Cartography/FileIO.h
+include/vw/Cartography/GeoReference.h
+include/vw/Cartography/GeoReferenceBase.h
+include/vw/Cartography/GeoReferenceResourceGDAL.h
+include/vw/Cartography/GeoReferenceResourcePDS.h
+include/vw/Cartography/GeoTransform.h
+include/vw/Cartography/OrthoImageView.h
+include/vw/Cartography/PointImageManipulation.h
+include/vw/Cartography/Projection.h
+include/vw/Cartography/SimplePointImageManipulation.h
+include/vw/Cartography/ToastTransform.h
+include/vw/Core.h
+include/vw/Core/Cache.h
+include/vw/Core/CompoundTypes.h
+include/vw/Core/ConfigParser.h
+include/vw/Core/Debugging.h
+include/vw/Core/Exception.h
+include/vw/Core/Features.h
+include/vw/Core/Functors.h
+include/vw/Core/FundamentalTypes.h
+include/vw/Core/Log.h
+include/vw/Core/ProgressCallback.h
+include/vw/Core/Settings.h
+include/vw/Core/Stopwatch.h
+include/vw/Core/Thread.h
+include/vw/Core/ThreadPool.h
+include/vw/Core/ThreadQueue.h
+include/vw/Core/TypeDeduction.h
+include/vw/Core/VarArray.h
+include/vw/FileIO.h
+include/vw/FileIO/DiskImageResource.h
+include/vw/FileIO/DiskImageResourceGDAL.h
+include/vw/FileIO/DiskImageResourceJPEG.h
+include/vw/FileIO/DiskImageResourceOpenEXR.h
+include/vw/FileIO/DiskImageResourcePBM.h
+include/vw/FileIO/DiskImageResourcePDS.h
+include/vw/FileIO/DiskImageResourcePNG.h
+include/vw/FileIO/DiskImageView.h
+include/vw/FileIO/KML.h
+include/vw/HDR.h
+include/vw/HDR/CameraCurve.h
+include/vw/HDR/GlobalToneMap.h
+include/vw/HDR/LDRtoHDR.h
+include/vw/HDR/LocalToneMap.h
+include/vw/Image.h
+include/vw/Image/Algorithms.h
+include/vw/Image/BlockProcessor.h
+include/vw/Image/BlockRasterize.h
+include/vw/Image/Convolution.h
+include/vw/Image/EdgeExtend.h
+include/vw/Image/EdgeExtension.h
+include/vw/Image/Filter.h
+include/vw/Image/Filter.tcc
+include/vw/Image/ImageIO.h
+include/vw/Image/ImageMath.h
+include/vw/Image/ImageResource.h
+include/vw/Image/ImageResourceView.h
+include/vw/Image/ImageView.h
+include/vw/Image/ImageViewBase.h
+include/vw/Image/ImageViewRef.h
+include/vw/Image/Interpolation.h
+include/vw/Image/Manipulation.h
+include/vw/Image/MaskViews.h
+include/vw/Image/Palette.h
+include/vw/Image/PerPixelAccessorViews.h
+include/vw/Image/PerPixelViews.h
+include/vw/Image/PixelAccessors.h
+include/vw/Image/PixelIterator.h
+include/vw/Image/PixelMask.h
+include/vw/Image/PixelMath.h
+include/vw/Image/PixelTypeInfo.h
+include/vw/Image/PixelTypes.h
+include/vw/Image/SparseImageCheck.h
+include/vw/Image/Statistics.h
+include/vw/Image/Transform.h
+include/vw/Image/UtilityViews.h
+include/vw/Image/ViewImageResource.h
+include/vw/InterestPoint.h
+include/vw/InterestPoint/BoxFilter.h
+include/vw/InterestPoint/Descriptor.h
+include/vw/InterestPoint/Detector.h
+include/vw/InterestPoint/Extrema.h
+include/vw/InterestPoint/ImageOctave.h
+include/vw/InterestPoint/ImageOctaveHistory.h
+include/vw/InterestPoint/IntegralDescriptor.h
+include/vw/InterestPoint/IntegralDetector.h
+include/vw/InterestPoint/IntegralImage.h
+include/vw/InterestPoint/IntegralInterestOperator.h
+include/vw/InterestPoint/InterestData.h
+include/vw/InterestPoint/InterestOperator.h
+include/vw/InterestPoint/InterestTraits.h
+include/vw/InterestPoint/LearnPCA.h
+include/vw/InterestPoint/Localize.h
+include/vw/InterestPoint/Matcher.h
+include/vw/InterestPoint/MatrixIO.h
+include/vw/InterestPoint/VectorIO.h
+include/vw/InterestPoint/WeightedHistogram.h
+include/vw/Math.h
+include/vw/Math/BBox.h
+include/vw/Math/ConjugateGradient.h
+include/vw/Math/DisjointSet.h
+include/vw/Math/EulerAngles.h
+include/vw/Math/Functions.h
+include/vw/Math/Functors.h
+include/vw/Math/FundamentalMatrix.h
+include/vw/Math/Geometry.h
+include/vw/Math/KDTree.h
+include/vw/Math/LapackExports.h
+include/vw/Math/LevenbergMarquardt.h
+include/vw/Math/LinearAlgebra.h
+include/vw/Math/Matrix.h
+include/vw/Math/MatrixSparseSkyline.h
+include/vw/Math/MinimumSpanningTree.h
+include/vw/Math/NelderMead.h
+include/vw/Math/ParticleSwarmOptimization.h
+include/vw/Math/PoseEstimation.h
+include/vw/Math/Quaternion.h
+include/vw/Math/RANSAC.h
+include/vw/Math/Statistics.h
+include/vw/Math/Vector.h
+include/vw/Mosaic.h
+include/vw/Mosaic/CelestiaQuadTreeConfig.h
+include/vw/Mosaic/GMapQuadTreeConfig.h
+include/vw/Mosaic/GigapanQuadTreeConfig.h
+include/vw/Mosaic/ImageComposite.h
+include/vw/Mosaic/KMLQuadTreeConfig.h
+include/vw/Mosaic/QuadTreeGenerator.h
+include/vw/Mosaic/TMSQuadTreeConfig.h
+include/vw/Mosaic/ToastQuadTreeConfig.h
+include/vw/Mosaic/UniviewQuadTreeConfig.h
+include/vw/Stereo.h
+include/vw/Stereo/AffineMixtureComponent.h
+include/vw/Stereo/Correlate.h
+include/vw/Stereo/CorrelatorView.h
+include/vw/Stereo/DisparityMap.h
+include/vw/Stereo/EMSubpixelCorrelatorView.h
+include/vw/Stereo/EMSubpixelCorrelatorView.hpp
+include/vw/Stereo/GammaMixtureComponent.h
+include/vw/Stereo/GaussianMixtureComponent.h
+include/vw/Stereo/MixtureComponent.h
+include/vw/Stereo/OptimizedCorrelator.h
+include/vw/Stereo/PyramidCorrelator.h
+include/vw/Stereo/ReferenceCorrelator.h
+include/vw/Stereo/StereoModel.h
+include/vw/Stereo/StereoView.h
+include/vw/Stereo/SubpixelView.h
+include/vw/Stereo/UniformMixtureComponent.h
+include/vw/config.h
+include/vw/vw.h
+lib/libvw.la
+lib/libvw.so
+lib/libvw.so.5
+lib/libvwBundleAdjustment.la
+lib/libvwBundleAdjustment.so.5
+lib/libvwBundleAdjustment.so
+lib/libvwCamera.la
+lib/libvwCamera.so
+lib/libvwCamera.so.5
+lib/libvwCartography.la
+lib/libvwCartography.so
+lib/libvwCartography.so.5
+lib/libvwCore.la
+lib/libvwCore.so
+lib/libvwCore.so.5
+lib/libvwFileIO.la
+lib/libvwFileIO.so
+lib/libvwFileIO.so.5
+lib/libvwHDR.la
+lib/libvwHDR.so
+lib/libvwHDR.so.5
+lib/libvwImage.la
+lib/libvwImage.so
+lib/libvwImage.so.5
+lib/libvwInterestPoint.la
+lib/libvwInterestPoint.so
+lib/libvwInterestPoint.so.5
+lib/libvwMath.la
+lib/libvwMath.so
+lib/libvwMath.so.5
+lib/libvwMosaic.la
+lib/libvwMosaic.so
+lib/libvwMosaic.so.5
+lib/libvwStereo.la
+lib/libvwStereo.so
+lib/libvwStereo.so.5
+@dirrm include/vw/BundleAdjustment
+@dirrm include/vw/Camera
+@dirrm include/vw/Cartography
+@dirrm include/vw/Core
+@dirrm include/vw/FileIO
+@dirrm include/vw/HDR
+@dirrm include/vw/Image
+@dirrm include/vw/InterestPoint
+@dirrm include/vw/Math
+@dirrm include/vw/Mosaic
+@dirrm include/vw/Stereo
+@dirrm include/vw