aboutsummaryrefslogtreecommitdiff
path: root/graphics/vulkan-loader/Makefile
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2022-02-06 02:05:51 +0000
committerJan Beich <jbeich@FreeBSD.org>2022-02-06 02:25:54 +0000
commit8287c8a0c70e663b233f3c091504b542196c07f7 (patch)
tree3daba4ab61bf74a470cbfd8b319e61b2eee5aff2 /graphics/vulkan-loader/Makefile
parent7e56934afa4718ea5aaed06ef2a734f93c61bf0b (diff)
downloadports-8287c8a0c70e663b233f3c091504b542196c07f7.tar.gz
ports-8287c8a0c70e663b233f3c091504b542196c07f7.zip
Diffstat (limited to 'graphics/vulkan-loader/Makefile')
-rw-r--r--graphics/vulkan-loader/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/graphics/vulkan-loader/Makefile b/graphics/vulkan-loader/Makefile
index 475a9554e6e1..1156de7e8bca 100644
--- a/graphics/vulkan-loader/Makefile
+++ b/graphics/vulkan-loader/Makefile
@@ -36,9 +36,12 @@ XLIB_CMAKE_BOOL= BUILD_WSI_XLIB_SUPPORT
post-patch:
# Extract (snapshot) version from the port
+# Respect PREFIX when XDG_CONFIG_DIRS and XDG_DATA_DIRS are unset
@${REINPLACE_CMD} -e '/find_.*Git/d' \
-e '/BRANCH/s/--unknown--/main/' \
-e '/TAG/s/--unknown--/${DISTVERSIONFULL}/' \
+ -e '/FALLBACK/s,/etc,${PREFIX}&,' \
+ -e 's,/usr/local,${PREFIX},' \
${WRKSRC}/CMakeLists.txt
# https://bugs.llvm.org/show_bug.cgi?id=47348
@if [ "${CHOSEN_COMPILER_TYPE}-${ARCH}-${_OSRELEASE:C/.*-//}" = "clang-i386-CURRENT" ]; then \