aboutsummaryrefslogtreecommitdiff
path: root/graphics/vv/Makefile
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-09-06 22:24:02 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-09-06 22:24:02 +0000
commitcd27d6a4a403cda54a58e349430f176921e4b05c (patch)
treef9895f6eb0310c0f38b5f8e6d5f48d07f91dee28 /graphics/vv/Makefile
parentfc2206a61e03b817d721ed9b827f3055a5ad6ad1 (diff)
Notes
Diffstat (limited to 'graphics/vv/Makefile')
-rw-r--r--graphics/vv/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/graphics/vv/Makefile b/graphics/vv/Makefile
new file mode 100644
index 000000000000..d252a19a8885
--- /dev/null
+++ b/graphics/vv/Makefile
@@ -0,0 +1,37 @@
+# $FreeBSD$
+
+PORTNAME= vv
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.4.0-271
+DISTVERSIONSUFFIX= -g24b75af3
+CATEGORIES= graphics
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Fast and simple 4D image viewer
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+LIB_DEPENDS= libexpat.so:textproc/expat2 \
+ libfreetype.so:print/freetype2 \
+ libgdcmCommon.so:devel/gdcm \
+ libhdf5_cpp.so:science/hdf5 \
+ libITKLabelMap-4.13.so:science/InsightToolkit \
+ libpng16.so:graphics/png \
+ libsz.so:science/szip \
+ libtiff.so:graphics/tiff \
+ libvtkIOSQL-8.1.so:math/vtk8
+
+USES= cmake:outsource compiler:c++11-lang jpeg qt:5
+USE_GITHUB= yes
+GH_ACCOUNT= open-vv
+USE_QT= core designer gui network sql widgets xml buildtools_build qmake_build
+USE_XORG= ice sm x11 xext xt
+USE_CXXSTD= c++11
+
+PLIST_FILES= bin/vv
+
+post-configure: # need to investigate where these strings come from
+ @${REINPLACE_CMD} 's| -lGTest::GTest -lGTest::Main | |' ${BUILD_WRKSRC}/build.ninja
+
+.include <bsd.port.mk>