aboutsummaryrefslogtreecommitdiff
path: root/graphics/waifu2x-converter-cpp
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2018-05-09 01:10:11 +0000
committerSteve Wills <swills@FreeBSD.org>2018-05-09 01:10:11 +0000
commit532105a93cf41f4fe7a4666875c156eabae2ae75 (patch)
tree61c3b03ca83f7ee408d0e57d069b884202696225 /graphics/waifu2x-converter-cpp
parent07485881725782b3552ec708bd2ec7ca164f918a (diff)
downloadports-532105a93cf41f4fe7a4666875c156eabae2ae75.tar.gz
ports-532105a93cf41f4fe7a4666875c156eabae2ae75.zip
graphics/opencv: Update to 3.4.1
PR: 210505 Submitted by: rozhuk.im@gmail.com (partially, further work was done) Exp-run by: antoine
Notes
Notes: svn path=/head/; revision=469420
Diffstat (limited to 'graphics/waifu2x-converter-cpp')
-rw-r--r--graphics/waifu2x-converter-cpp/files/patch-CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/graphics/waifu2x-converter-cpp/files/patch-CMakeLists.txt b/graphics/waifu2x-converter-cpp/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..06c9d057e28a
--- /dev/null
+++ b/graphics/waifu2x-converter-cpp/files/patch-CMakeLists.txt
@@ -0,0 +1,11 @@
+--- CMakeLists.txt.orig 2018-05-02 21:05:51.508265000 +0000
++++ CMakeLists.txt 2018-05-02 21:05:54.408309000 +0000
+@@ -22,7 +22,7 @@ else()
+ link_directories(${OPENCV_PREFIX}/lib)
+ endif()
+
+-check_include_file_cxx("opencv2/opencv.hpp" HAVE_OPENCV)
++check_include_file_cxx("opencv2/videoio.hpp" HAVE_OPENCV)
+ find_library(IMGCODECS_LIBRARY NAMES opencv_imgcodecs opencv_highgui
+ HINTS ${OPENCV_PKG_INCLUDE_DIRS} ${OPENCV_PREFIX}/lib)
+