aboutsummaryrefslogtreecommitdiff
path: root/graphics/webp
diff options
context:
space:
mode:
authorJohan van Selst <johans@FreeBSD.org>2013-12-29 08:51:10 +0000
committerJohan van Selst <johans@FreeBSD.org>2013-12-29 08:51:10 +0000
commit46f25a6df4eb9e0b003b87908dad90ec344b9681 (patch)
tree4d95bdce509bb719a9e30454c842bff1c2d73815 /graphics/webp
parent0da6350a9fc989e20fbbe51fff4750325fb146bb (diff)
downloadports-46f25a6df4eb9e0b003b87908dad90ec344b9681.tar.gz
ports-46f25a6df4eb9e0b003b87908dad90ec344b9681.zip
Notes
Diffstat (limited to 'graphics/webp')
-rw-r--r--graphics/webp/Makefile18
-rw-r--r--graphics/webp/pkg-plist2
2 files changed, 17 insertions, 3 deletions
diff --git a/graphics/webp/Makefile b/graphics/webp/Makefile
index d70bcb868b1b..028c23cdeade 100644
--- a/graphics/webp/Makefile
+++ b/graphics/webp/Makefile
@@ -3,7 +3,7 @@
PORTNAME= webp
PORTVERSION= 0.3.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= graphics
MASTER_SITES= GOOGLE_CODE
DISTNAME= lib${PORTNAME}-${PORTVERSION}
@@ -17,7 +17,6 @@ LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
libtiff.so:${PORTSDIR}/graphics/tiff
USE_LDCONFIG= yes
-USE_GL= glut
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
@@ -26,4 +25,19 @@ CONFIGURE_ARGS+=--with-pkgconfigdir=${PREFIX}/libdata/pkgconfig \
--enable-libwebpdemux \
--enable-libwebpdecoder
+OPTIONS_DEFINE= X11
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MX11}
+USE_GL= glut
+PLIST_SUB= X11=""
+.else
+CONFIGURE_ARGS+=--with-glincludedir=/dev/null
+PLIST_SUB= X11="@comment "
+.endif
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libwebp*.so
+
.include <bsd.port.mk>
diff --git a/graphics/webp/pkg-plist b/graphics/webp/pkg-plist
index 43264d7ebf24..0fd07e8f8f61 100644
--- a/graphics/webp/pkg-plist
+++ b/graphics/webp/pkg-plist
@@ -1,7 +1,7 @@
bin/cwebp
bin/dwebp
bin/gif2webp
-bin/vwebp
+%%X11%%bin/vwebp
bin/webpmux
include/webp/decode.h
include/webp/demux.h