aboutsummaryrefslogtreecommitdiff
path: root/graphics/webp
diff options
context:
space:
mode:
authorJohan van Selst <johans@FreeBSD.org>2010-11-23 20:46:13 +0000
committerJohan van Selst <johans@FreeBSD.org>2010-11-23 20:46:13 +0000
commitad671cd3828de34daafe8b6fc3e67b2b3516e4c5 (patch)
treef915e0b1605316581e1eb9e85eee17aca3c1a8e7 /graphics/webp
parent26f82f9fb86ee28f1bd8c2b2bb5fa07431cdb85b (diff)
downloadports-ad671cd3828de34daafe8b6fc3e67b2b3516e4c5.tar.gz
ports-ad671cd3828de34daafe8b6fc3e67b2b3516e4c5.zip
Notes
Diffstat (limited to 'graphics/webp')
-rw-r--r--graphics/webp/Makefile2
-rw-r--r--graphics/webp/distinfo4
-rw-r--r--graphics/webp/files/patch-leptonlib-1.066_src_environ.h10
3 files changed, 13 insertions, 3 deletions
diff --git a/graphics/webp/Makefile b/graphics/webp/Makefile
index 708ce120a3b0..25dbcb8dac70 100644
--- a/graphics/webp/Makefile
+++ b/graphics/webp/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= webp
-PORTVERSION= 0.0.3
+PORTVERSION= 0.0.4
CATEGORIES= graphics
MASTER_SITES= GOOGLE_CODE
DISTNAME= ${PORTNAME}-leptonica-${PORTVERSION}
diff --git a/graphics/webp/distinfo b/graphics/webp/distinfo
index 02089cdd3228..c5e4baab7c2f 100644
--- a/graphics/webp/distinfo
+++ b/graphics/webp/distinfo
@@ -1,2 +1,2 @@
-SHA256 (webp-leptonica-0.0.3.tar.gz) = 150e61b55fdff1ca32df6c685586765c04366d01b88c2d20ec7246152730a14c
-SIZE (webp-leptonica-0.0.3.tar.gz) = 1323724
+SHA256 (webp-leptonica-0.0.4.tar.gz) = 4afcd2fe9395074a74f590f0417b2d054c6dbca8fdbcd183e39d16f46c68c19f
+SIZE (webp-leptonica-0.0.4.tar.gz) = 1355152
diff --git a/graphics/webp/files/patch-leptonlib-1.066_src_environ.h b/graphics/webp/files/patch-leptonlib-1.066_src_environ.h
new file mode 100644
index 000000000000..6bd9a43bcf27
--- /dev/null
+++ b/graphics/webp/files/patch-leptonlib-1.066_src_environ.h
@@ -0,0 +1,10 @@
+--- leptonlib-1.066/src/environ.h.orig 2010-11-23 12:47:09.000000000 +0100
++++ leptonlib-1.066/src/environ.h 2010-11-23 12:45:55.000000000 +0100
+@@ -205,6 +205,7 @@ enum {
+ * on all heap data except for Pix. Memory management for Pix
+ * also defaults to malloc and free. See pix1.c for details.
+ *------------------------------------------------------------------------*/
++#include <stdlib.h>
+ #define MALLOC(blocksize) malloc(blocksize)
+ #define CALLOC(numelem, elemsize) calloc(numelem, elemsize)
+ #define REALLOC(ptr, blocksize) realloc(ptr, blocksize)