aboutsummaryrefslogtreecommitdiff
path: root/graphics/white_dune
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
commit2b74a89bc8342f0b9b737c37d87737caf7b0ea1e (patch)
treec04604583d8be53b3ed7f10975be828c731f87cb /graphics/white_dune
parent24315159daa0089f08acea4ba1b130fb6721ad5c (diff)
downloadports-2b74a89bc8342f0b9b737c37d87737caf7b0ea1e.tar.gz
ports-2b74a89bc8342f0b9b737c37d87737caf7b0ea1e.zip
Notes
Diffstat (limited to 'graphics/white_dune')
-rw-r--r--graphics/white_dune/Makefile4
-rw-r--r--graphics/white_dune/files/patch-src-pngLoad.c11
2 files changed, 13 insertions, 2 deletions
diff --git a/graphics/white_dune/Makefile b/graphics/white_dune/Makefile
index 3efb7316caae..2d628f89a09a 100644
--- a/graphics/white_dune/Makefile
+++ b/graphics/white_dune/Makefile
@@ -9,7 +9,7 @@
PORTNAME= white_dune
PORTVERSION= ${DISTVERSION:S/pl/./}
DISTVERSION= 0.30pl5
-PORTREVISION= 2
+PORTREVISION= 3
PORTEPOCH= 1
CATEGORIES= graphics
MASTER_SITES= http://vrml.cip.ica.uni-stuttgart.de/dune/ CENKES
@@ -18,7 +18,7 @@ MAINTAINER= devel@stasyan.com
COMMENT= Graphical VRML97 Editor and animation tool
LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg \
- png.6:${PORTSDIR}/graphics/png
+ png15:${PORTSDIR}/graphics/png
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
diff --git a/graphics/white_dune/files/patch-src-pngLoad.c b/graphics/white_dune/files/patch-src-pngLoad.c
new file mode 100644
index 000000000000..a95df605f2ad
--- /dev/null
+++ b/graphics/white_dune/files/patch-src-pngLoad.c
@@ -0,0 +1,11 @@
+--- src/pngLoad.c.orig 2010-12-09 08:36:57.000000000 +0100
++++ src/pngLoad.c 2012-05-05 08:32:20.000000000 +0200
+@@ -139,7 +139,7 @@
+ * the normal method of doing things with libpng). REQUIRED unless you
+ * set up your own error handlers in the png_create_read_struct() earlier.
+ */
+- if (setjmp(png_ptr->jmpbuf))
++ if (setjmp(png_jmpbuf(png_ptr)))
+ {
+ /* If we get here, we had a problem reading the file */
+ return 0;