aboutsummaryrefslogtreecommitdiff
path: root/graphics/wings/Makefile
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2005-07-21 00:01:35 +0000
committerKris Kennaway <kris@FreeBSD.org>2005-07-21 00:01:35 +0000
commita7f90fdd5a4c7008f5694c518889f9f1fd1e2ca8 (patch)
tree8b5f63778f69203eb9a85649fadfc8d381978ee7 /graphics/wings/Makefile
parent10aa230913abcbfc4916a7a3836c69d6025cf1e9 (diff)
downloadports-a7f90fdd5a4c7008f5694c518889f9f1fd1e2ca8.tar.gz
ports-a7f90fdd5a4c7008f5694c518889f9f1fd1e2ca8.zip
Notes
Diffstat (limited to 'graphics/wings/Makefile')
-rw-r--r--graphics/wings/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/graphics/wings/Makefile b/graphics/wings/Makefile
index 36cbefd486b5..9143b33c4dc1 100644
--- a/graphics/wings/Makefile
+++ b/graphics/wings/Makefile
@@ -27,6 +27,12 @@ USE_BZIP2= yes
USE_GMAKE= yes
USE_REINPLACE= yes
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 504001
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
post-patch:
@${CP} ${FILESDIR}/wings.sh ${WRKSRC}/wings.sh
@${REINPLACE_CMD} -e 's|!!PREFIX!!|${PREFIX}|g' ${WRKSRC}/wings.sh
@@ -44,4 +50,4 @@ do-install:
@${INSTALL_SCRIPT} ${WRKSRC}/wings.sh ${PREFIX}/bin/wings
@${LN} -sf ${DISTNAME} ${PREFIX}/lib/erlang/lib/${PORTNAME}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>