aboutsummaryrefslogtreecommitdiff
path: root/graphics/wxsvg
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2013-03-27 06:19:16 +0000
committerMartin Wilke <miwi@FreeBSD.org>2013-03-27 06:19:16 +0000
commit2a6f8d86a1ad0b2e43135af33acda32182340968 (patch)
tree03073cda0c122eff45fe57ad7bde954bac7758ad /graphics/wxsvg
parent68398e16c6758740c1b6913ed6e2703174d05f0f (diff)
downloadports-2a6f8d86a1ad0b2e43135af33acda32182340968.tar.gz
ports-2a6f8d86a1ad0b2e43135af33acda32182340968.zip
- Update to 1.1.13
PR: 177260 Submitted by: ports fury
Notes
Notes: svn path=/head/; revision=315350
Diffstat (limited to 'graphics/wxsvg')
-rw-r--r--graphics/wxsvg/Makefile44
-rw-r--r--graphics/wxsvg/distinfo4
-rw-r--r--graphics/wxsvg/files/patch-Makefile.am11
3 files changed, 22 insertions, 37 deletions
diff --git a/graphics/wxsvg/Makefile b/graphics/wxsvg/Makefile
index 6ebc0d0b588a..021238b6856a 100644
--- a/graphics/wxsvg/Makefile
+++ b/graphics/wxsvg/Makefile
@@ -1,41 +1,37 @@
-# New ports collection makefile for: wxsvg
-# Date created: 2006-01-08
-# Whom: Michael Johnson <ahze@FreeBSD.org>
-#
+# Created by: Michael Johnson <ahze@FreeBSD.org>
# $FreeBSD$
-# $MCom: ports/graphics/wxsvg/Makefile,v 1.1 2006/09/22 01:48:33 ahze Exp $
PORTNAME= wxsvg
-PORTVERSION= 1.1.8
-PORTREVISION= 1
+PORTVERSION= 1.1.13
CATEGORIES= graphics
MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= C++ library to create, manipulate, and render SVG files
-LIB_DEPENDS+= avformat.1:${PORTSDIR}/multimedia/ffmpeg
+LICENSE= LGPL21 # (or later)
+
+LIB_DEPENDS= avcodec1:${PORTSDIR}/multimedia/ffmpeg1 \
+ expat:${PORTSDIR}/textproc/expat2
USE_BZIP2= yes
-USE_AUTOTOOLS= automake
-USE_LDCONFIG= yes
-GNU_CONFIGURE= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-USE_GNOME= libartlgpl2
-USE_GMAKE= yes
+USES= pathfix
USE_WX= yes
-USE_AUTOTOOLS= automake
WX_CONF_ARGS= absolute
+USE_GNOME= cairo
+USE_PKGCONFIG= build
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= LIBAV_CFLAGS="${LIBAV_CFLAGS}" LIBAV_LIBS="${LIBAV_LIBS}"
+MAKE_ENV= AM_CPPFLAGS="${LIBAV_CFLAGS}"
+USE_LDCONFIG= yes
+MAKE_JOBS_SAFE= yes
-AUTOTOOLSFILES= aclocal.m4
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
-post-patch:
- @${REINPLACE_CMD} -e 's|1.11.1|%%AUTOMAKE_APIVER%%|g' \
- ${WRKSRC}/aclocal.m4
- @cd ${WRKSRC} && \
- ${TOUCH} -f NEWS INSTALL
-# @${REINPLACE_CMD} -e 's|WX_CONFIG_NAME=wx-config|WX_CONFIG_NAME=${WX_CONFIG}|' \
-# ${WRKSRC}/*.m4
+LIBAV_PC= libavcodec1 libavformat1 libavutil1 libswscale1
+LIBAV_CFLAGS= $$(pkg-config --cflags ${LIBAV_PC})
+LIBAV_LIBS= $$(pkg-config --libs ${LIBAV_PC})
.include <bsd.port.mk>
diff --git a/graphics/wxsvg/distinfo b/graphics/wxsvg/distinfo
index 84ea5d829118..e119dd797eb5 100644
--- a/graphics/wxsvg/distinfo
+++ b/graphics/wxsvg/distinfo
@@ -1,2 +1,2 @@
-SHA256 (wxsvg-1.1.8.tar.bz2) = 9512d78d4bb0d92893907c4d33566730b6d140955864f1c44e52a4ff2452399a
-SIZE (wxsvg-1.1.8.tar.bz2) = 666364
+SHA256 (wxsvg-1.1.13.tar.bz2) = ebaecb322bb7fad97a3cd686bed9827b00afe84063cf2784a7e19891dabd805e
+SIZE (wxsvg-1.1.13.tar.bz2) = 669378
diff --git a/graphics/wxsvg/files/patch-Makefile.am b/graphics/wxsvg/files/patch-Makefile.am
deleted file mode 100644
index 87aa78f127e8..000000000000
--- a/graphics/wxsvg/files/patch-Makefile.am
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.am.orig 2010-10-11 21:27:01.000000000 +0200
-+++ Makefile.am 2010-10-11 21:27:18.000000000 +0200
-@@ -1,7 +1,7 @@
- SUBDIRS = src svgview include
- ACLOCAL_AMFLAGS = -I. -I m4
-
--pkgconfigdir = $(libdir)/pkgconfig
-+pkgconfigdir = $(prefix)/libdata/pkgconfig
- pkgconfig_DATA = libwxsvg.pc
- EXTRA_DIST = libwxsvg.pc.in
-