aboutsummaryrefslogtreecommitdiff
path: root/graphics/wxsvg
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2015-04-10 19:04:19 +0000
committerJohn Marino <marino@FreeBSD.org>2015-04-10 19:04:19 +0000
commit637a8c132c00b0a80516e047b765c3e3d102957c (patch)
tree06a641c9a5c34f159616bdc9d331dbee9985118e /graphics/wxsvg
parent923cf2f9b6f0c8245dc93ebb7bbbc514b2844c1c (diff)
downloadports-637a8c132c00b0a80516e047b765c3e3d102957c.tar.gz
ports-637a8c132c00b0a80516e047b765c3e3d102957c.zip
Unbreak five wxgtk30-based ports by adding -std=c++11 to cxxflags
The breakage was a result of moving wxgtk30 to c++11 from c++01
Notes
Notes: svn path=/head/; revision=383750
Diffstat (limited to 'graphics/wxsvg')
-rw-r--r--graphics/wxsvg/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/graphics/wxsvg/Makefile b/graphics/wxsvg/Makefile
index 92d8b161f0f1..4fc9c099a937 100644
--- a/graphics/wxsvg/Makefile
+++ b/graphics/wxsvg/Makefile
@@ -20,7 +20,8 @@ WX_UNICODE= yes
WX_CONF_ARGS= absolute
USE_GNOME= cairo
GNU_CONFIGURE= yes
-CONFIGURE_ENV= LIBAV_CFLAGS="${LIBAV_CFLAGS}" LIBAV_LIBS="${LIBAV_LIBS}"
+CONFIGURE_ENV= LIBAV_CFLAGS="${LIBAV_CFLAGS}" LIBAV_LIBS="${LIBAV_LIBS}" \
+ CXXFLAGS="${CXXFLAGS} -std=c++11"
MAKE_ENV= AM_CPPFLAGS="${LIBAV_CFLAGS}"
USE_LDCONFIG= yes
INSTALL_TARGET= install-strip