aboutsummaryrefslogtreecommitdiff
path: root/graphics/wxsvg
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2006-01-08 21:32:55 +0000
committerMichael Johnson <ahze@FreeBSD.org>2006-01-08 21:32:55 +0000
commit6584b9441c7224f31fdd87247f2bbbd795974a4f (patch)
tree4f4751209822a6b59aafc1fceb1d0f15cd4f4cf6 /graphics/wxsvg
parentb9f6b0710b43848d1269ae5d03ccf6baa7549050 (diff)
downloadports-6584b9441c7224f31fdd87247f2bbbd795974a4f.tar.gz
ports-6584b9441c7224f31fdd87247f2bbbd795974a4f.zip
Notes
Diffstat (limited to 'graphics/wxsvg')
-rw-r--r--graphics/wxsvg/Makefile30
-rw-r--r--graphics/wxsvg/distinfo3
-rw-r--r--graphics/wxsvg/pkg-descr3
-rw-r--r--graphics/wxsvg/pkg-plist188
4 files changed, 224 insertions, 0 deletions
diff --git a/graphics/wxsvg/Makefile b/graphics/wxsvg/Makefile
new file mode 100644
index 000000000000..75cdadd119bb
--- /dev/null
+++ b/graphics/wxsvg/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: wxsvg
+# Date created: 2006-01-08
+# Whom: Michael Johnson <ahze@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= wxsvg
+DISTVERSION= 1.0b4
+CATEGORIES= graphics
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ahze@FreeBSD.org
+COMMENT= C++ library to create, manipulate, and render SVG files
+
+BUILD_DEPENDS= ${WX_CONFIG}:${PORTSDIR}/x11-toolkits/wxgtk26
+RUN_DEPENDS= ${WX_CONFIG}:${PORTSDIR}/x11-toolkits/wxgtk26
+
+INSTALLS_SHLIB= yes
+WX_CONFIG= wxgtk2-2.6-config
+USE_REINPLACE= yes
+USE_AUTOTOOLS= libtool:15
+USE_GNOME= libartlgpl2
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|wx-config|${WX_CONFIG}|' \
+ ${WRKSRC}/configure
+
+.include <bsd.port.mk>
diff --git a/graphics/wxsvg/distinfo b/graphics/wxsvg/distinfo
new file mode 100644
index 000000000000..831c5000d908
--- /dev/null
+++ b/graphics/wxsvg/distinfo
@@ -0,0 +1,3 @@
+MD5 (wxsvg-1.0b4.tar.gz) = 963057f2eb53662c09a8589ce6a7ae56
+SHA256 (wxsvg-1.0b4.tar.gz) = b90675cb35b61c5418a1c1100478fd5e9474c880dbcdd85b4dc4c2ec3492a040
+SIZE (wxsvg-1.0b4.tar.gz) = 617389
diff --git a/graphics/wxsvg/pkg-descr b/graphics/wxsvg/pkg-descr
new file mode 100644
index 000000000000..9ca0f71d383b
--- /dev/null
+++ b/graphics/wxsvg/pkg-descr
@@ -0,0 +1,3 @@
+C++ library to create, manipulate, and render SVG files
+
+WWW: http://wxsvg.sourceforge.net/
diff --git a/graphics/wxsvg/pkg-plist b/graphics/wxsvg/pkg-plist
new file mode 100644
index 000000000000..35e0c58676c0
--- /dev/null
+++ b/graphics/wxsvg/pkg-plist
@@ -0,0 +1,188 @@
+bin/svgview
+include/wxSVG/Animated.h
+include/wxSVG/CSSStyleDeclaration.h
+include/wxSVG/CSSValue.h
+include/wxSVG/CSSValues.h
+include/wxSVG/Document.h
+include/wxSVG/DocumentCSS.h
+include/wxSVG/DocumentEvent.h
+include/wxSVG/Element.h
+include/wxSVG/ElementTimeControl.h
+include/wxSVG/EventTarget.h
+include/wxSVG/GetSVGDocument.h
+include/wxSVG/NodeList.h
+include/wxSVG/RGBColor.h
+include/wxSVG/SVGAElement.h
+include/wxSVG/SVGAltGlyphDefElement.h
+include/wxSVG/SVGAltGlyphElement.h
+include/wxSVG/SVGAltGlyphItemElement.h
+include/wxSVG/SVGAngle.h
+include/wxSVG/SVGAnimateColorElement.h
+include/wxSVG/SVGAnimateElement.h
+include/wxSVG/SVGAnimateMotionElement.h
+include/wxSVG/SVGAnimateTransformElement.h
+include/wxSVG/SVGAnimatedAngle.h
+include/wxSVG/SVGAnimatedBoolean.h
+include/wxSVG/SVGAnimatedEnumeration.h
+include/wxSVG/SVGAnimatedInteger.h
+include/wxSVG/SVGAnimatedLength.h
+include/wxSVG/SVGAnimatedLengthList.h
+include/wxSVG/SVGAnimatedNumber.h
+include/wxSVG/SVGAnimatedNumberList.h
+include/wxSVG/SVGAnimatedPathData.h
+include/wxSVG/SVGAnimatedPoints.h
+include/wxSVG/SVGAnimatedPreserveAspectRatio.h
+include/wxSVG/SVGAnimatedRect.h
+include/wxSVG/SVGAnimatedString.h
+include/wxSVG/SVGAnimatedTransformList.h
+include/wxSVG/SVGAnimationElement.h
+include/wxSVG/SVGCSSRule.h
+include/wxSVG/SVGCanvas.h
+include/wxSVG/SVGCanvasItem.h
+include/wxSVG/SVGCircleElement.h
+include/wxSVG/SVGClipPathElement.h
+include/wxSVG/SVGColor.h
+include/wxSVG/SVGColorProfileElement.h
+include/wxSVG/SVGColorProfileRule.h
+include/wxSVG/SVGComponentTransferFunctionElement.h
+include/wxSVG/SVGCursorElement.h
+include/wxSVG/SVGDTD.h
+include/wxSVG/SVGDefinitionSrcElement.h
+include/wxSVG/SVGDefsElement.h
+include/wxSVG/SVGDescElement.h
+include/wxSVG/SVGDocument.h
+include/wxSVG/SVGElement.h
+include/wxSVG/SVGElementInstance.h
+include/wxSVG/SVGElementInstanceList.h
+include/wxSVG/SVGEllipseElement.h
+include/wxSVG/SVGEvent.h
+include/wxSVG/SVGExternalResourcesRequired.h
+include/wxSVG/SVGFEBlendElement.h
+include/wxSVG/SVGFEColorMatrixElement.h
+include/wxSVG/SVGFEComponentTransferElement.h
+include/wxSVG/SVGFECompositeElement.h
+include/wxSVG/SVGFEConvolveMatrixElement.h
+include/wxSVG/SVGFEDiffuseLightingElement.h
+include/wxSVG/SVGFEDisplacementMapElement.h
+include/wxSVG/SVGFEDistantLightElement.h
+include/wxSVG/SVGFEFloodElement.h
+include/wxSVG/SVGFEFuncAElement.h
+include/wxSVG/SVGFEFuncBElement.h
+include/wxSVG/SVGFEFuncGElement.h
+include/wxSVG/SVGFEFuncRElement.h
+include/wxSVG/SVGFEGaussianBlurElement.h
+include/wxSVG/SVGFEImageElement.h
+include/wxSVG/SVGFEMergeElement.h
+include/wxSVG/SVGFEMergeNodeElement.h
+include/wxSVG/SVGFEMorphologyElement.h
+include/wxSVG/SVGFEOffsetElement.h
+include/wxSVG/SVGFEPointLightElement.h
+include/wxSVG/SVGFESpecularLightingElement.h
+include/wxSVG/SVGFESpotLightElement.h
+include/wxSVG/SVGFETileElement.h
+include/wxSVG/SVGFETurbulenceElement.h
+include/wxSVG/SVGFilterElement.h
+include/wxSVG/SVGFilterPrimitiveStandardAttributes.h
+include/wxSVG/SVGFitToViewBox.h
+include/wxSVG/SVGFontElement.h
+include/wxSVG/SVGFontFaceElement.h
+include/wxSVG/SVGFontFaceFormatElement.h
+include/wxSVG/SVGFontFaceNameElement.h
+include/wxSVG/SVGFontFaceSrcElement.h
+include/wxSVG/SVGFontFaceUriElement.h
+include/wxSVG/SVGForeignObjectElement.h
+include/wxSVG/SVGGElement.h
+include/wxSVG/SVGGlyphElement.h
+include/wxSVG/SVGGlyphRefElement.h
+include/wxSVG/SVGGradientElement.h
+include/wxSVG/SVGHKernElement.h
+include/wxSVG/SVGICCColor.h
+include/wxSVG/SVGImageElement.h
+include/wxSVG/SVGLangSpace.h
+include/wxSVG/SVGLength.h
+include/wxSVG/SVGLengthCalculate.h
+include/wxSVG/SVGLengthList.h
+include/wxSVG/SVGLineElement.h
+include/wxSVG/SVGLinearGradientElement.h
+include/wxSVG/SVGLocatable.h
+include/wxSVG/SVGMPathElement.h
+include/wxSVG/SVGMarkerElement.h
+include/wxSVG/SVGMaskElement.h
+include/wxSVG/SVGMatrix.h
+include/wxSVG/SVGMetadataElement.h
+include/wxSVG/SVGMissingGlyphElement.h
+include/wxSVG/SVGNumber.h
+include/wxSVG/SVGNumberList.h
+include/wxSVG/SVGPaint.h
+include/wxSVG/SVGPathElement.h
+include/wxSVG/SVGPathSeg.h
+include/wxSVG/SVGPathSegArcAbs.h
+include/wxSVG/SVGPathSegArcRel.h
+include/wxSVG/SVGPathSegClosePath.h
+include/wxSVG/SVGPathSegCurvetoCubicAbs.h
+include/wxSVG/SVGPathSegCurvetoCubicRel.h
+include/wxSVG/SVGPathSegCurvetoCubicSmoothAbs.h
+include/wxSVG/SVGPathSegCurvetoCubicSmoothRel.h
+include/wxSVG/SVGPathSegCurvetoQuadraticAbs.h
+include/wxSVG/SVGPathSegCurvetoQuadraticRel.h
+include/wxSVG/SVGPathSegCurvetoQuadraticSmoothAbs.h
+include/wxSVG/SVGPathSegCurvetoQuadraticSmoothRel.h
+include/wxSVG/SVGPathSegLinetoAbs.h
+include/wxSVG/SVGPathSegLinetoHorizontalAbs.h
+include/wxSVG/SVGPathSegLinetoHorizontalRel.h
+include/wxSVG/SVGPathSegLinetoRel.h
+include/wxSVG/SVGPathSegLinetoVerticalAbs.h
+include/wxSVG/SVGPathSegLinetoVerticalRel.h
+include/wxSVG/SVGPathSegList.h
+include/wxSVG/SVGPathSegMovetoAbs.h
+include/wxSVG/SVGPathSegMovetoRel.h
+include/wxSVG/SVGPatternElement.h
+include/wxSVG/SVGPoint.h
+include/wxSVG/SVGPointList.h
+include/wxSVG/SVGPolygonElement.h
+include/wxSVG/SVGPolylineElement.h
+include/wxSVG/SVGPreserveAspectRatio.h
+include/wxSVG/SVGRadialGradientElement.h
+include/wxSVG/SVGRect.h
+include/wxSVG/SVGRectElement.h
+include/wxSVG/SVGRenderingIntent.h
+include/wxSVG/SVGSVGElement.h
+include/wxSVG/SVGScriptElement.h
+include/wxSVG/SVGSetElement.h
+include/wxSVG/SVGStopElement.h
+include/wxSVG/SVGStringList.h
+include/wxSVG/SVGStylable.h
+include/wxSVG/SVGStyleElement.h
+include/wxSVG/SVGSwitchElement.h
+include/wxSVG/SVGSymbolElement.h
+include/wxSVG/SVGTRefElement.h
+include/wxSVG/SVGTSpanElement.h
+include/wxSVG/SVGTests.h
+include/wxSVG/SVGTextContentElement.h
+include/wxSVG/SVGTextElement.h
+include/wxSVG/SVGTextPathElement.h
+include/wxSVG/SVGTextPositioningElement.h
+include/wxSVG/SVGTitleElement.h
+include/wxSVG/SVGTransform.h
+include/wxSVG/SVGTransformList.h
+include/wxSVG/SVGTransformable.h
+include/wxSVG/SVGURIReference.h
+include/wxSVG/SVGUnitTypes.h
+include/wxSVG/SVGUseElement.h
+include/wxSVG/SVGVKernElement.h
+include/wxSVG/SVGVideoElement.h
+include/wxSVG/SVGViewElement.h
+include/wxSVG/SVGViewSpec.h
+include/wxSVG/SVGZoomAndPan.h
+include/wxSVG/SVGZoomEvent.h
+include/wxSVG/String.h
+include/wxSVG/ViewCSS.h
+include/wxSVG/svg.h
+include/wxSVG/svgctrl.h
+include/wxXML/xml.h
+include/wxXML/xmlhelpr.h
+lib/libwxsvg.a
+lib/libwxsvg.so
+lib/libwxsvg.so.0
+@dirrm include/wxXML
+@dirrm include/wxSVG