aboutsummaryrefslogtreecommitdiff
path: root/graphics/wxsvg
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2006-10-14 08:54:54 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2006-10-14 08:54:54 +0000
commit29747f458a1eb2ce23b4594b09d0256dd62760b8 (patch)
tree1b71ba5d9ffdd308b6c18130f7c116f5bab5dc12 /graphics/wxsvg
parent7aad84f808b93baa6a7077ce0b47573b9c4c79a0 (diff)
Notes
Diffstat (limited to 'graphics/wxsvg')
-rw-r--r--graphics/wxsvg/Makefile5
-rw-r--r--graphics/wxsvg/files/patch-src_freetype_SVGCanvasTestFreetype.cpp49
2 files changed, 52 insertions, 2 deletions
diff --git a/graphics/wxsvg/Makefile b/graphics/wxsvg/Makefile
index 572fa3d88ab2..0eb3c86e55c0 100644
--- a/graphics/wxsvg/Makefile
+++ b/graphics/wxsvg/Makefile
@@ -3,10 +3,11 @@
# Whom: Michael Johnson <ahze@FreeBSD.org>
#
# $FreeBSD$
-#
+# $MCom: ports/graphics/wxsvg/Makefile,v 1.1 2006/09/22 01:48:33 ahze Exp $
PORTNAME= wxsvg
DISTVERSION= 1.0b6
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -17,7 +18,7 @@ COMMENT= C++ library to create, manipulate, and render SVG files
BUILD_DEPENDS= ${WX_CONFIG}:${PORTSDIR}/x11-toolkits/wxgtk26
RUN_DEPENDS= ${WX_CONFIG}:${PORTSDIR}/x11-toolkits/wxgtk26
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
WX_CONFIG= wxgtk2-2.6-config
USE_AUTOTOOLS= libtool:15
USE_GNOME= libartlgpl2
diff --git a/graphics/wxsvg/files/patch-src_freetype_SVGCanvasTestFreetype.cpp b/graphics/wxsvg/files/patch-src_freetype_SVGCanvasTestFreetype.cpp
new file mode 100644
index 000000000000..f0182faeaa77
--- /dev/null
+++ b/graphics/wxsvg/files/patch-src_freetype_SVGCanvasTestFreetype.cpp
@@ -0,0 +1,49 @@
+--- src/freetype/SVGCanvasTextFreetype.cpp.orig Thu Sep 21 21:42:35 2006
++++ src/freetype/SVGCanvasTextFreetype.cpp Thu Sep 21 21:45:02 2006
+@@ -165,7 +165,7 @@
+ }
+ }
+
+-gint moveto(FT_Vector* to, gpointer data)
++gint moveto(const FT_Vector* to, gpointer data)
+ {
+ wxSVGCanvasTextFreetype* canvasText = (wxSVGCanvasTextFreetype*) data;
+
+@@ -181,7 +181,7 @@
+ return 0;
+ }
+
+-static gint lineto (FT_Vector* to, gpointer data)
++static gint lineto (const FT_Vector* to, gpointer data)
+ {
+ wxSVGCanvasTextFreetype* canvasText = (wxSVGCanvasTextFreetype*) data;
+ if (!canvasText->m_endpath)
+@@ -194,7 +194,7 @@
+ return 0;
+ }
+
+-static gint conicto(FT_Vector* ftcontrol, FT_Vector* to, gpointer data)
++static gint conicto(const FT_Vector* ftcontrol, const FT_Vector* to, gpointer data)
+ {
+ wxSVGCanvasTextFreetype* canvasText = (wxSVGCanvasTextFreetype*) data;
+ if (!canvasText->m_endpath)
+@@ -209,8 +209,8 @@
+ return 0;
+ }
+
+-static gint cubicto(FT_Vector* ftcontrol1, FT_Vector* ftcontrol2,
+- FT_Vector* to, gpointer data)
++static gint cubicto(const FT_Vector* ftcontrol1, const FT_Vector* ftcontrol2,
++ const FT_Vector* to, gpointer data)
+ {
+ wxSVGCanvasTextFreetype* canvasText = (wxSVGCanvasTextFreetype*) data;
+ if (!canvasText->m_endpath)
+@@ -227,7 +227,7 @@
+ return 0;
+ }
+
+-static const FT_Outline_Funcs outline_funcs =
++static FT_Outline_Funcs outline_funcs =
+ {
+ moveto, lineto, conicto, cubicto, 0, 0
+ };