aboutsummaryrefslogtreecommitdiff
path: root/graphics/xaos/Makefile
diff options
context:
space:
mode:
authorJoseph Koshy <jkoshy@FreeBSD.org>2004-02-29 17:06:20 +0000
committerJoseph Koshy <jkoshy@FreeBSD.org>2004-02-29 17:06:20 +0000
commit9f323fd5dcdf1131f6a52f11ea7ef285650fad17 (patch)
tree3bd6c51f6f77024292f76dc69a5d9d9e0e55bca4 /graphics/xaos/Makefile
parent55a5379a39b006650d77fb4f02d5b8c9a31e8ebb (diff)
downloadports-9f323fd5dcdf1131f6a52f11ea7ef285650fad17.tar.gz
ports-9f323fd5dcdf1131f6a52f11ea7ef285650fad17.zip
Notes
Diffstat (limited to 'graphics/xaos/Makefile')
-rw-r--r--graphics/xaos/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/graphics/xaos/Makefile b/graphics/xaos/Makefile
index aa176d2f2857..2991f176c41c 100644
--- a/graphics/xaos/Makefile
+++ b/graphics/xaos/Makefile
@@ -30,6 +30,12 @@ CONFIGURE_ENV= LDFLAGS=-L${LOCALBASE}/lib
CONFIGURE_ARGS= --with-svga-driver=no
.endif
+.if defined(WITH_PTHREAD)
+CONFIGURE_ARGS+= --with-pthread=yes
+CONFIGURE_ENV+= LIBS="${PTHREAD_LIBS}" \
+ CFLAGS="${PTHREAD_CFLAGS} ${CFLAGS}"
+.endif
+
CFLAGS= -DHAVE_SYS_PARAM_H \
-I${PREFIX}/include \
-pipe -O6 -fstrength-reduce -ffast-math -fomit-frame-pointer\