aboutsummaryrefslogtreecommitdiff
path: root/graphics/xaos
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
commit2b74a89bc8342f0b9b737c37d87737caf7b0ea1e (patch)
treec04604583d8be53b3ed7f10975be828c731f87cb /graphics/xaos
parent24315159daa0089f08acea4ba1b130fb6721ad5c (diff)
downloadports-2b74a89bc8342f0b9b737c37d87737caf7b0ea1e.tar.gz
ports-2b74a89bc8342f0b9b737c37d87737caf7b0ea1e.zip
Notes
Diffstat (limited to 'graphics/xaos')
-rw-r--r--graphics/xaos/Makefile6
-rw-r--r--graphics/xaos/files/patch-png.c20
2 files changed, 23 insertions, 3 deletions
diff --git a/graphics/xaos/Makefile b/graphics/xaos/Makefile
index 5c2171e525e4..19f2907c331c 100644
--- a/graphics/xaos/Makefile
+++ b/graphics/xaos/Makefile
@@ -7,14 +7,14 @@
PORTNAME= xaos
PORTVERSION= 3.5
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= graphics math
MASTER_SITES= SF/${PORTNAME}/XaoS/${PORTVERSION}
MAINTAINER= makc@FreeBSD.org
COMMENT= A real-time fractal browser for X11 and ASCII terminals
-LIB_DEPENDS= png.6:${PORTSDIR}/graphics/png
+LIB_DEPENDS= png15:${PORTSDIR}/graphics/png
USE_XORG= x11 xext
GNU_CONFIGURE= yes
@@ -24,7 +24,7 @@ OPTIONS= PTHREAD "Enable SMP support (experimental)" off \
GTK2 "GTK+ User Interface (experimental)" off \
NLS "Native Language Support" on
-CPPFLAGS+= -I${LOCALBASE}/include
+CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/libpng15
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --with-aa-driver=no --with-dga-driver=no \
--with-ggi-driver=no --with-svga-driver=no \
diff --git a/graphics/xaos/files/patch-png.c b/graphics/xaos/files/patch-png.c
new file mode 100644
index 000000000000..17ec32ea93ab
--- /dev/null
+++ b/graphics/xaos/files/patch-png.c
@@ -0,0 +1,20 @@
+--- src/util/png.c.orig 2009-07-18 01:50:39.000000000 +0200
++++ src/util/png.c 2012-05-05 08:36:16.000000000 +0200
+@@ -3,6 +3,8 @@
+ #include <aconfig.h>
+ #ifdef USE_PNG
+ #include <png.h>
++#include <zlib.h>
++#include <pngpriv.h>
+ #endif
+ #include <stdlib.h>
+ #include <stdio.h>
+@@ -59,7 +61,7 @@
+ png_destroy_write_struct(&png_ptr, (png_infopp) NULL);
+ return "No memory to create png info structure";
+ }
+- if (setjmp(png_ptr->jmpbuf)) {
++ if (setjmp(png_jmpbuf(png_ptr))) {
+ png_destroy_write_struct(&png_ptr, &info_ptr);
+ fclose(file);
+ return strerror(errno);