aboutsummaryrefslogtreecommitdiff
path: root/graphics/xaos
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2010-01-07 21:45:10 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2010-01-07 21:45:10 +0000
commit794a0f62810e2dddb49a13b8be3e9bafdbcd10fc (patch)
treed41425aced819db2a50863d139dcdab712452736 /graphics/xaos
parente38dc7c0ac0b322f7e09cc5b640dfd22237cc109 (diff)
downloadports-794a0f62810e2dddb49a13b8be3e9bafdbcd10fc.tar.gz
ports-794a0f62810e2dddb49a13b8be3e9bafdbcd10fc.zip
Notes
Diffstat (limited to 'graphics/xaos')
-rw-r--r--graphics/xaos/Makefile30
-rw-r--r--graphics/xaos/distinfo6
-rw-r--r--graphics/xaos/files/patch-configure.in27
-rw-r--r--graphics/xaos/files/patch-src__Makefile.in10
-rw-r--r--graphics/xaos/files/patch-src_include_aconfig.h.in8
-rw-r--r--graphics/xaos/files/patch-src_ui_ui.c11
-rw-r--r--graphics/xaos/pkg-plist24
7 files changed, 42 insertions, 74 deletions
diff --git a/graphics/xaos/Makefile b/graphics/xaos/Makefile
index 13c37b3a3e09..a5f39b50f0e3 100644
--- a/graphics/xaos/Makefile
+++ b/graphics/xaos/Makefile
@@ -6,27 +6,25 @@
#
PORTNAME= xaos
-PORTVERSION= 3.4
-PORTREVISION= 1
+PORTVERSION= 3.5
CATEGORIES= graphics math
MASTER_SITES= SF/${PORTNAME}/XaoS/${PORTVERSION}
-DISTNAME= XaoS-${PORTVERSION}
MAINTAINER= makc@FreeBSD.org
COMMENT= A real-time fractal browser for X11 and ASCII terminals
LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
-USE_XORG= x11 xau xdmcp xext
+USE_XORG= x11 xext
GNU_CONFIGURE= yes
USE_GMAKE= yes
-USE_AUTOTOOLS= autoconf:262
OPTIONS= PTHREAD "Enable SMP support (experimental)" off \
+ GTK2 "GTK+ User Interface (experimental)" off \
NLS "Native Language Support" on
-CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
- LDFLAGS="-L${PREFIX}/lib -L${LOCALBASE}/lib"
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --with-aa-driver=no --with-dga-driver=no \
--with-ggi-driver=no --with-svga-driver=no \
--with-sffe=no
@@ -36,9 +34,9 @@ INFO= xaos
PLIST_SUB+= XAOSDIR="share/XaoS"
-DESKTOP_ENTRIES="XaoS" "Fractal zoomer" "" "xaos" "" false
+DESKTOP_ENTRIES= "XaoS" "Fractal zoomer" "" "xaos" "" false
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if defined(WITH_PTHREAD)
CONFIGURE_ARGS+= --with-pthread=yes
@@ -48,12 +46,22 @@ CONFIGURE_ENV+= LIBS="${PTHREAD_LIBS}" \
CONFIGURE_ARGS+= --with-pthread=no
.endif
+.if defined(WITH_GTK2)
+USE_GNOME= gtk20
+CONFIGURE_ARGS+= --with-gtk-driver=yes --with-x11-driver=no
+.endif
+
.if !defined(WITHOUT_NLS)
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
.else
-CONFIGURE_ARGS+=--disable-nls
+CONFIGURE_ARGS+= --disable-nls
PLIST_SUB+= NLS="@comment "
.endif
-.include <bsd.port.post.mk>
+pre-configure:
+ ${REINPLACE_CMD} -e 's,/usr\(/share/locale\),${PREFIX}\1,g' \
+ ${WRKSRC}/configure \
+ ${WRKSRC}/src/ui/ui.c
+
+.include <bsd.port.mk>
diff --git a/graphics/xaos/distinfo b/graphics/xaos/distinfo
index a694a0d51105..e126074d9e97 100644
--- a/graphics/xaos/distinfo
+++ b/graphics/xaos/distinfo
@@ -1,3 +1,3 @@
-MD5 (XaoS-3.4.tar.gz) = 366fd8151e9642a0d9afce889912e388
-SHA256 (XaoS-3.4.tar.gz) = 2cdba9b356f725b278b20eaf925b54478ba24b722b1ddda3879a84ddc16a8c00
-SIZE (XaoS-3.4.tar.gz) = 1977108
+MD5 (xaos-3.5.tar.gz) = 465d1469b276501a58bf325e493ea591
+SHA256 (xaos-3.5.tar.gz) = 471fa752154a8e4c4687797fe1241df1b3f82400b2ef4e6a603969a27cd74842
+SIZE (xaos-3.5.tar.gz) = 2930590
diff --git a/graphics/xaos/files/patch-configure.in b/graphics/xaos/files/patch-configure.in
deleted file mode 100644
index fdc7ffa082d2..000000000000
--- a/graphics/xaos/files/patch-configure.in
+++ /dev/null
@@ -1,27 +0,0 @@
---- ./configure.in.orig 2008-03-13 20:23:57.000000000 +0300
-+++ ./configure.in 2008-04-10 22:34:25.000000000 +0400
-@@ -284,7 +284,7 @@
-
- use_cc_g_flag=no
- DRIVERDIRS=""
--LOCALEDIR="/usr/share/locale"
-+LOCALEDIR="${prefix}/share/locale"
- DRIVERLIBS="lib/libui.a lib/libui-hlp.a lib/libengine.a lib/libutil.a lib/libfilter.a"
- CFLAGS="$CCOPTS"
- AC_PROG_INSTALL
-@@ -429,6 +429,7 @@
- fi
- fi
- case $target_os in
-+*freebsd*) CMPLX_O_TARGET=elf;;
- *linux*) CMPLX_O_TARGET=elf;;
- *cygwin*) CMPLX_O_TARGET=coff;;
- *darwin*) CMPLX_O_TARGET=macho;;
-@@ -735,6 +736,7 @@
- eval datadir3=$datadir2
- # This is a madness! eval can evaluate only one level of variable...
- AC_DEFINE_UNQUOTED(DATAPATH,"${datadir3}/XaoS")
-+AC_DEFINE_UNQUOTED(PREFIX,"${prefix}")
-
- AC_CHECK_SIZEOF(short)
- AC_CHECK_SIZEOF(int)
diff --git a/graphics/xaos/files/patch-src__Makefile.in b/graphics/xaos/files/patch-src__Makefile.in
deleted file mode 100644
index 943f1c22681f..000000000000
--- a/graphics/xaos/files/patch-src__Makefile.in
+++ /dev/null
@@ -1,10 +0,0 @@
---- ./src/Makefile.in.orig 2008-03-05 16:00:12.000000000 +0300
-+++ ./src/Makefile.in 2008-06-04 22:29:31.000000000 +0400
-@@ -1,6 +1,6 @@
- CC = @CC@
- CFLAGS = @CFLAGS@
--LIBS = @LIBS@
-+LIBS = @LIBS@ @LTLIBINTL@
- LFLAGS = @LDFLAGS@
- AR = @AR@
- RANLIB = @RANLIB@
diff --git a/graphics/xaos/files/patch-src_include_aconfig.h.in b/graphics/xaos/files/patch-src_include_aconfig.h.in
deleted file mode 100644
index ebc1d881deb1..000000000000
--- a/graphics/xaos/files/patch-src_include_aconfig.h.in
+++ /dev/null
@@ -1,8 +0,0 @@
---- ./src/include/aconfig.h.in.orig 2008-05-22 00:23:37.000000000 +0400
-+++ ./src/include/aconfig.h.in 2008-06-04 22:29:31.000000000 +0400
-@@ -56,4 +56,5 @@
- #undef SIZEOF_LONG
- #undef HAVE_GETTEXT
- #undef NO_MALLOC_H
-+#undef PREFIX
- #endif
diff --git a/graphics/xaos/files/patch-src_ui_ui.c b/graphics/xaos/files/patch-src_ui_ui.c
deleted file mode 100644
index bdc0d7ec64c8..000000000000
--- a/graphics/xaos/files/patch-src_ui_ui.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/ui/ui.c.orig 2008-05-22 00:23:37.000000000 +0400
-+++ ./src/ui/ui.c 2008-06-04 22:36:27.000000000 +0400
-@@ -1243,7 +1243,7 @@
- #ifdef USE_LOCALEPATH
- localepath)
- #else
-- "/usr/share/locale")
-+ PREFIX "/share/locale")
- #endif
- #ifdef DEBUG
- )
diff --git a/graphics/xaos/pkg-plist b/graphics/xaos/pkg-plist
index e22cdea34ef1..4318dea19b73 100644
--- a/graphics/xaos/pkg-plist
+++ b/graphics/xaos/pkg-plist
@@ -7,12 +7,15 @@ bin/xaos
%%XAOSDIR%%/catalogs/francais.cat
%%XAOSDIR%%/catalogs/italiano.cat
%%XAOSDIR%%/catalogs/magyar.cat
+%%XAOSDIR%%/catalogs/portuguese.cat
%%XAOSDIR%%/catalogs/romanian.cat
%%XAOSDIR%%/doc/AUTHORS
-%%XAOSDIR%%/doc/PROBLEMS
-%%XAOSDIR%%/doc/README
-%%XAOSDIR%%/doc/README.bugs
-%%XAOSDIR%%/doc/compilers.txt
+%%XAOSDIR%%/doc/COPYING
+%%XAOSDIR%%/doc/ChangeLog
+%%XAOSDIR%%/doc/ChangeLog.old
+%%XAOSDIR%%/doc/INSTALL
+%%XAOSDIR%%/doc/NEWS
+%%XAOSDIR%%/doc/TODO
%%XAOSDIR%%/examples/0rfel1.xpf
%%XAOSDIR%%/examples/0rfel2.xpf
%%XAOSDIR%%/examples/2spirals.xpf
@@ -27,6 +30,7 @@ bin/xaos
%%XAOSDIR%%/examples/3d9.xpf
%%XAOSDIR%%/examples/README
%%XAOSDIR%%/examples/alien.xpf
+%%XAOSDIR%%/examples/animal.xpf
%%XAOSDIR%%/examples/axe.xpf
%%XAOSDIR%%/examples/barnsl1.xpf
%%XAOSDIR%%/examples/barnsl2.xpf
@@ -57,6 +61,7 @@ bin/xaos
%%XAOSDIR%%/examples/edge2.xpf
%%XAOSDIR%%/examples/edge3.xpf
%%XAOSDIR%%/examples/eifell.xpf
+%%XAOSDIR%%/examples/eye.xpf
%%XAOSDIR%%/examples/eyes.xpf
%%XAOSDIR%%/examples/fract0.xpf
%%XAOSDIR%%/examples/fract1.xpf
@@ -124,13 +129,18 @@ bin/xaos
%%XAOSDIR%%/examples/mandanim.xaf
%%XAOSDIR%%/examples/minibrot.xpf
%%XAOSDIR%%/examples/nap.xpf
+%%XAOSDIR%%/examples/newcolor.xpf
+%%XAOSDIR%%/examples/newt.xpf
+%%XAOSDIR%%/examples/newt2.xpf
%%XAOSDIR%%/examples/newton.xaf
%%XAOSDIR%%/examples/newton.xpf
%%XAOSDIR%%/examples/newton2.xpf
%%XAOSDIR%%/examples/newton3.xpf
%%XAOSDIR%%/examples/octo.xpf
%%XAOSDIR%%/examples/orveny.xpf
+%%XAOSDIR%%/examples/paisleypillow.xpf
%%XAOSDIR%%/examples/palace.xpf
+%%XAOSDIR%%/examples/paramecium.xpf
%%XAOSDIR%%/examples/pavaszem.xpf
%%XAOSDIR%%/examples/pavaszem2.xpf
%%XAOSDIR%%/examples/pentafrac.xpf
@@ -142,10 +152,14 @@ bin/xaos
%%XAOSDIR%%/examples/perb5.xpf
%%XAOSDIR%%/examples/phoenix1.xpf
%%XAOSDIR%%/examples/phoenix2.xpf
+%%XAOSDIR%%/examples/pretty.xpf
+%%XAOSDIR%%/examples/pretty2.xpf
%%XAOSDIR%%/examples/redjulia.xpf
%%XAOSDIR%%/examples/redmand.xpf
%%XAOSDIR%%/examples/redmand2.xpf
%%XAOSDIR%%/examples/rocks.xpf
+%%XAOSDIR%%/examples/royal.xpf
+%%XAOSDIR%%/examples/rpg.xpf
%%XAOSDIR%%/examples/shell.xpf
%%XAOSDIR%%/examples/skullfrm.xpf
%%XAOSDIR%%/examples/something.xpf
@@ -168,6 +182,7 @@ bin/xaos
%%XAOSDIR%%/examples/truecol7.xpf
%%XAOSDIR%%/examples/ufo.xpf
%%XAOSDIR%%/examples/warriormask.xpf
+%%XAOSDIR%%/examples/whisp.xpf
%%XAOSDIR%%/examples/zsigapro.xpf
%%XAOSDIR%%/help/xaos.hlp
%%XAOSDIR%%/tutorial/3dtutor.xaf
@@ -230,6 +245,7 @@ bin/xaos
%%NLS%%share/locale/fr/LC_MESSAGES/xaos.mo
%%NLS%%share/locale/hu/LC_MESSAGES/xaos.mo
%%NLS%%share/locale/it/LC_MESSAGES/xaos.mo
+%%NLS%%share/locale/pt/LC_MESSAGES/xaos.mo
%%NLS%%share/locale/ro/LC_MESSAGES/xaos.mo
@dirrm %%XAOSDIR%%/tutorial
@dirrm %%XAOSDIR%%/help