aboutsummaryrefslogtreecommitdiff
path: root/graphics/xaralx
diff options
context:
space:
mode:
authorVasil Dimov <vd@FreeBSD.org>2006-06-05 15:29:49 +0000
committerVasil Dimov <vd@FreeBSD.org>2006-06-05 15:29:49 +0000
commite60eff4ac9ffc0747639021a6c0b879abbc773de (patch)
tree00bb260975f941275d2c58458a6d24b4c6d20f87 /graphics/xaralx
parentaf28f3770b5437feca6d08944d5235fcc1b6ea28 (diff)
downloadports-e60eff4ac9ffc0747639021a6c0b879abbc773de.tar.gz
ports-e60eff4ac9ffc0747639021a6c0b879abbc773de.zip
Notes
Diffstat (limited to 'graphics/xaralx')
-rw-r--r--graphics/xaralx/Makefile11
-rw-r--r--graphics/xaralx/files/patch-configure.in62
2 files changed, 18 insertions, 55 deletions
diff --git a/graphics/xaralx/Makefile b/graphics/xaralx/Makefile
index 862455bcecfd..f0a37b148d1e 100644
--- a/graphics/xaralx/Makefile
+++ b/graphics/xaralx/Makefile
@@ -29,14 +29,12 @@ RUN_DEPENDS+= ${WXDEP}:${PORTSDIR}/x11-toolkits/wxgtk26-unicode
LIB_DEPENDS+= dlmalloc.2:${PORTSDIR}/devel/libdlmalloc \
xml2.5:${PORTSDIR}/textproc/libxml2
-USE_AUTOTOOLS= autoconf:259:env aclocal:19:env automake:19:env
+USE_AUTOTOOLS= autoconf:259:env aclocal:19:env automake:19:env libtool:15:env
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS+= --with-wx-config=wxgtk2u-2.6-config \
--program-suffix=${PKGNAMESUFFIX}
-PKGCONFIGS=atk fontconfig gdk-2.0 pango
-CONFIGURE_ENV+= CPPFLAGS_APPEND="`pkg-config --cflags ${PKGCONFIGS}` \
- -I${LOCALBASE}/include/atk-1.0/atk \
+CONFIGURE_ENV+= CPPFLAGS_APPEND="-I${LOCALBASE}/include/atk-1.0/atk \
-I${X11BASE}/include/gtk-2.0/gtk"
# we're using dlmalloc because the stock libc does not have malloc_usable_size()
CONFIGURE_ENV+= LIBS="-L${LOCALBASE}/lib -ldlmalloc"
@@ -88,7 +86,10 @@ post-patch:
${WRKSRC}/xaralx.desktop
pre-configure:
- cd ${WRKSRC} && ${SETENV} ${AUTOTOOLS_ENV} ${AUTORECONF} -f -s -i
+ cd ${WRKSRC} && \
+ ${SETENV} ${AUTOTOOLS_ENV} \
+ ACLOCAL="${ACLOCAL} -I ${LOCALBASE}/share/aclocal" \
+ ${AUTORECONF} -f -i -s
.if !target(do-install)
do-install:
diff --git a/graphics/xaralx/files/patch-configure.in b/graphics/xaralx/files/patch-configure.in
index 8d33883a5b64..932bd36803e7 100644
--- a/graphics/xaralx/files/patch-configure.in
+++ b/graphics/xaralx/files/patch-configure.in
@@ -1,45 +1,15 @@
---- configure.in.orig Wed May 10 14:01:21 2006
-+++ configure.in Wed May 10 14:04:32 2006
-@@ -47,7 +47,7 @@
- AC_PROG_INSTALL
- # We don't need dlopen right now and it's not supported on Darwin
- # AC_LIBTOOL_DLOPEN
--AC_PROG_LIBTOOL
-+AC_PROG_RANLIB
-
- AC_C_BIGENDIAN
- AC_CHECK_SIZEOF(void*)
-@@ -141,7 +141,6 @@
- if echo $WX_CPPFLAGS | grep -q '__WXGTK__' ; then
- WX_GTK="yes"
- AC_MSG_RESULT([found])
-- PKG_CHECK_MODULES(GTK, [gtk+-2.0])
- else
- AC_MSG_RESULT([not found])
- fi
-@@ -215,20 +214,7 @@
- # GTK build, so call FTTEST function to test for FreeType
- FTTEST
- FT_CFLAGS="`$FTCONFIG --cflags`"
--
-- # check for the Pango package
-- PkgError="no"
-- PKG_CHECK_MODULES(PANGOX, pangox,
-- [
-- PANGO_CFLAGS="$PANGOX_CFLAGS"
-- ],
-- [
-- PkgError="yes"
-- ]
-- )
-- if test PkgError = "yes"; then
-- AC_MSG_ERROR([pangox library not found])
-- fi
-+ PANGO_CFLAGS=""
- else
- # non-GTK build, i.e., MacOS, so Pango and FreeType are not required
- FT_CFLAGS=""
-@@ -246,8 +232,8 @@
+--- configure.in.orig Mon Jun 5 15:06:26 2006
++++ configure.in Mon Jun 5 15:07:19 2006
+@@ -139,7 +139,7 @@
+ WX_CPPFLAGS="`$WXCONFIG --static=$StaticEnable --debug=$DebugEnable --unicode=yes --cppflags`"
+ WX_CXXFLAGS="`$WXCONFIG --static=$StaticEnable --debug=$DebugEnable --unicode=yes --cxxflags | sed -e 's/-fno-exceptions//'`"
+ WX_LIBS="`$WXCONFIG --static=$StaticEnable --debug=$DebugEnable --unicode=yes --libs`"
+- WXRC="`$WXCONFIG --utility=wxrc`"
++ WXRC="`$WXCONFIG --utility=wxrc-gtk2u`"
+
+ # See if we are running on GTK
+ WX_GTK="no"
+@@ -252,8 +252,8 @@
fi
# pass the Pango, FreeType and GTK flags (required for wxGTK font rendering)
@@ -50,11 +20,3 @@
AC_MSG_CHECKING([Linker])
case $host in
-@@ -286,6 +272,7 @@
- AM_CONDITIONAL(DARWIN_LINK, [test "$DarwinLink" = "yes"])
-
- AC_SUBST(TOPDIR)
-+AC_SUBST(WX_CPPFLAGS)
- AC_SUBST(WX_LIBS)
- AC_SUBST(XRCINCLUDE)
- AC_SUBST(XARALANGUAGE)