aboutsummaryrefslogtreecommitdiff
path: root/graphics/xaralx
diff options
context:
space:
mode:
authorVasil Dimov <vd@FreeBSD.org>2006-05-31 11:14:29 +0000
committerVasil Dimov <vd@FreeBSD.org>2006-05-31 11:14:29 +0000
commit8762e9c7533b30a41db2d3b312f5093566fbb0a8 (patch)
treedda9ff1a7ea5157198755d7d0c16479c37e396e9 /graphics/xaralx
parent80bf4b51382294f0c9c8cc373fd4f25aba8436f8 (diff)
downloadports-8762e9c7533b30a41db2d3b312f5093566fbb0a8.tar.gz
ports-8762e9c7533b30a41db2d3b312f5093566fbb0a8.zip
Notes
Diffstat (limited to 'graphics/xaralx')
-rw-r--r--graphics/xaralx/Makefile61
-rw-r--r--graphics/xaralx/pkg-plist71
2 files changed, 128 insertions, 4 deletions
diff --git a/graphics/xaralx/Makefile b/graphics/xaralx/Makefile
index 03cb3de713b7..862455bcecfd 100644
--- a/graphics/xaralx/Makefile
+++ b/graphics/xaralx/Makefile
@@ -7,6 +7,7 @@
PORTNAME= XaraLX
PORTVERSION?= 0.5r1175
+PORTREVISION?= 1
CATEGORIES= graphics
MASTER_SITES= http://downloads.xara.com/opensource/
DISTFILES?= ${PORTNAME}Src-${PORTVERSION}.tar.bz2
@@ -15,6 +16,7 @@ MAINTAINER= vd@FreeBSD.org
COMMENT?= Top-tier vector/general purpose graphics program (recommended version)
USE_BZIP2= yes
+USE_X_PREFIX= yes
#WXDEP= ${X11BASE}/libwx_baseu-2.6.so.0.3.1
WXDEP= wxgtk2-unicode>=2.6.3
@@ -45,24 +47,75 @@ MAKE_ENV+= INCLUDES="-I../wxOil -I- -I${LOCALBASE}/include/dlmalloc"
USE_GCC= 3.4+
+MAN1= XaraLX${PKGNAMESUFFIX}.1
+
+.if !defined(NOPORTDOCS)
+DOCS_IN_WRKSRC= AUTHORS GPL LICENSE README
+DOCS_IN_DOC= en/xaralx.htm gifutil.txt mtrand.txt
+PORTDOCS= ${DOCS_IN_WRKSRC} en ${DOCS_IN_DOC:M*.txt}
+.endif
+
+# make non-conflicting with the slave port
+DOCSDIR?= ${PREFIX}/share/doc/${PORTNAME}${PKGNAMESUFFIX}
+EXAMPLESDIR?= ${PREFIX}/share/examples/${PORTNAME}${PKGNAMESUFFIX}
+
+PIXMAPSDIR= ${PREFIX}/share/pixmaps
+
+# directories with .xar files
+XARDIRS= Designs Templates TextDesigns testfiles
+
+PLIST_SUB+= PKGNAMESUFFIX=${PKGNAMESUFFIX} \
+ DESKTOPDIR=${DESKTOPDIR:S|^${PREFIX}/||} \
+ PIXMAPSDIR=${PIXMAPSDIR:S|^${PREFIX}/||}
+
.include <bsd.port.pre.mk>
.if ${ARCH} != "i386" && ${ARCH} != "amd64" && ${ARCH} != "powerpc"
BROKEN= does not configure due to the lack of CDraw libraries for ${ARCH}
.endif
-PROG= XaraLX${PKGNAMESUFFIX}
-
-PLIST_FILES= bin/${PROG}
-
# we need to strip wxOil from the include path because it contains file
# named strings.h which when included by /usr/include/string.h results
# in a complete mess
post-patch:
${REINPLACE_CMD} -E -e 's|-I[^[:space:]]*/wxOil[[:space:]]||g' \
${WRKSRC}/Makefile.am
+ ${REINPLACE_CMD} -E \
+ -e 's/^Name=Xara LX$$/Name=Xara LX (${PORTVERSION})/' \
+ -e 's/^FilePattern=xaralx;$$/FilePattern=XaraLX/' \
+ -e 's/^Exec=xaralx %F$$/Exec=XaraLX %F/' \
+ -e 's/^TryExec=xaralx$$/TryExec=XaraLX/' \
+ ${WRKSRC}/xaralx.desktop
pre-configure:
cd ${WRKSRC} && ${SETENV} ${AUTOTOOLS_ENV} ${AUTORECONF} -f -s -i
+.if !target(do-install)
+do-install:
+ ${MKDIR} ${DESKTOPDIR}
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/XaraLX \
+ ${PREFIX}/bin/XaraLX${PKGNAMESUFFIX}
+ ${INSTALL_DATA} ${WRKSRC}/xaralx.desktop \
+ ${DESKTOPDIR}/xaralx${PKGNAMESUFFIX}.desktop
+ ${INSTALL_DATA} ${WRKSRC}/xaralx.png \
+ ${PIXMAPSDIR}/xaralx${PKGNAMESUFFIX}.png
+.for xardir in ${XARDIRS}
+ ${MKDIR} ${EXAMPLESDIR}/${xardir}
+ ${INSTALL_DATA} ${WRKSRC}/${xardir}/*.xar ${EXAMPLESDIR}/${xardir}/
+.endfor
+ ${INSTALL_MAN} ${WRKSRC}/doc/XaraLX.1 \
+ ${MANPREFIX}/man/man1/XaraLX${PKGNAMESUFFIX}.1
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${MKDIR} ${DOCSDIR}/en
+.for d in ${DOCS_IN_WRKSRC}
+ ${INSTALL_DATA} ${WRKSRC}/${d} ${DOCSDIR}/${d}
+.endfor
+.for d in ${DOCS_IN_DOC}
+ ${INSTALL_DATA} ${WRKSRC}/doc/${d} ${DOCSDIR}/${d}
+.endfor
+.endif
+.endif
+
.include <bsd.port.post.mk>
diff --git a/graphics/xaralx/pkg-plist b/graphics/xaralx/pkg-plist
new file mode 100644
index 000000000000..c3428730231c
--- /dev/null
+++ b/graphics/xaralx/pkg-plist
@@ -0,0 +1,71 @@
+bin/XaraLX%%PKGNAMESUFFIX%%
+%%DESKTOPDIR%%/xaralx%%PKGNAMESUFFIX%%.desktop
+%%PIXMAPSDIR%%/xaralx%%PKGNAMESUFFIX%%.png
+%%EXAMPLESDIR%%/Designs/53 Corvette.xar
+%%EXAMPLESDIR%%/Designs/55 Mercedes.xar
+%%EXAMPLESDIR%%/Designs/BLUECAR.xar
+%%EXAMPLESDIR%%/Designs/CatWoman graphs.xar
+%%EXAMPLESDIR%%/Designs/Cube4.xar
+%%EXAMPLESDIR%%/Designs/EngineTimings.xar
+%%EXAMPLESDIR%%/Designs/Fill Types simple.xar
+%%EXAMPLESDIR%%/Designs/GardenPlan.xar
+%%EXAMPLESDIR%%/Designs/Girard_simple.xar
+%%EXAMPLESDIR%%/Designs/Groucho2.xar
+%%EXAMPLESDIR%%/Designs/JagSS100 simple.xar
+%%EXAMPLESDIR%%/Designs/Phil Hill-fontsremoved.xar
+%%EXAMPLESDIR%%/Designs/Probe.xar
+%%EXAMPLESDIR%%/Designs/Simple Sphere.xar
+%%EXAMPLESDIR%%/Designs/SoftShadow.xar
+%%EXAMPLESDIR%%/Designs/Spitfire.xar
+%%EXAMPLESDIR%%/Designs/TextCurve.xar
+%%EXAMPLESDIR%%/Designs/WATCH.xar
+%%EXAMPLESDIR%%/Designs/WATCH2.xar
+%%EXAMPLESDIR%%/Designs/Watch4.xar
+%%EXAMPLESDIR%%/Designs/amurdove.xar
+%%EXAMPLESDIR%%/Designs/feathers.xar
+%%EXAMPLESDIR%%/Designs/leafgirl.xar
+%%EXAMPLESDIR%%/Designs/scope3 simple.xar
+%%EXAMPLESDIR%%/Templates/1024 by 768 drawing.xar
+%%EXAMPLESDIR%%/Templates/640 by 480 drawing.xar
+%%EXAMPLESDIR%%/Templates/800 by 600 drawing.xar
+%%EXAMPLESDIR%%/Templates/A4 Landscape.xar
+%%EXAMPLESDIR%%/Templates/A4 Portrait.xar
+%%EXAMPLESDIR%%/Templates/A4 double page spread.xar
+%%EXAMPLESDIR%%/Templates/U S Letter.xar
+%%EXAMPLESDIR%%/Templates/animation.xar
+%%EXAMPLESDIR%%/TextDesigns/AngledText.xar
+%%EXAMPLESDIR%%/TextDesigns/BaselineShift.xar
+%%EXAMPLESDIR%%/TextDesigns/FontChangesInText.xar
+%%EXAMPLESDIR%%/TextDesigns/Kerning.xar
+%%EXAMPLESDIR%%/TextDesigns/LineSpacing.xar
+%%EXAMPLESDIR%%/TextDesigns/ManualKern.xar
+%%EXAMPLESDIR%%/TextDesigns/Paragraph.xar
+%%EXAMPLESDIR%%/TextDesigns/Rotated.xar
+%%EXAMPLESDIR%%/TextDesigns/SimpleText.xar
+%%EXAMPLESDIR%%/TextDesigns/SuperSub.xar
+%%EXAMPLESDIR%%/TextDesigns/TextJust.xar
+%%EXAMPLESDIR%%/TextDesigns/Tracking.xar
+%%EXAMPLESDIR%%/TextDesigns/embeddedFonts.xar
+%%EXAMPLESDIR%%/TextDesigns/hebrew.xar
+%%EXAMPLESDIR%%/testfiles/10000GradFilledShapes.xar
+%%EXAMPLESDIR%%/testfiles/20000GradFilledShapes.xar
+%%EXAMPLESDIR%%/testfiles/20000GradFilledShapes50PCtransparent.xar
+%%EXAMPLESDIR%%/testfiles/Broken Butt Cap.xar
+%%EXAMPLESDIR%%/testfiles/OneCurve.xar
+%%EXAMPLESDIR%%/testfiles/OneLine.xar
+%%EXAMPLESDIR%%/testfiles/ProbeX16.xar
+%%EXAMPLESDIR%%/testfiles/RedStar.xar
+%%EXAMPLESDIR%%/testfiles/ScaleTest.xar
+%%EXAMPLESDIR%%/testfiles/ScaleTest2.xar
+%%EXAMPLESDIR%%/testfiles/Test00.xar
+%%EXAMPLESDIR%%/testfiles/Test01.xar
+%%EXAMPLESDIR%%/testfiles/Test02.xar
+%%EXAMPLESDIR%%/testfiles/TestBitmapFill.xar
+%%EXAMPLESDIR%%/testfiles/sortcrash.xar
+%%EXAMPLESDIR%%/testfiles/testsmooth.xar
+@dirrm %%EXAMPLESDIR%%/Designs
+@dirrm %%EXAMPLESDIR%%/Templates
+@dirrm %%EXAMPLESDIR%%/TextDesigns
+@dirrm %%EXAMPLESDIR%%/testfiles
+@dirrm %%EXAMPLESDIR%%
+@dirrmtry %%DESKTOPDIR%%