aboutsummaryrefslogtreecommitdiff
path: root/graphics/xaralx
diff options
context:
space:
mode:
authorVasil Dimov <vd@FreeBSD.org>2006-04-04 16:02:30 +0000
committerVasil Dimov <vd@FreeBSD.org>2006-04-04 16:02:30 +0000
commitf24538a4190334bba4ea34602d8b425435276686 (patch)
tree1ad0bbd049639e95294c8da70f8782ede718a9b4 /graphics/xaralx
parent2a6c84112de554ce56cf0ae4457bf47bb9030f40 (diff)
downloadports-f24538a4190334bba4ea34602d8b425435276686.tar.gz
ports-f24538a4190334bba4ea34602d8b425435276686.zip
Notes
Diffstat (limited to 'graphics/xaralx')
-rw-r--r--graphics/xaralx/Makefile49
-rw-r--r--graphics/xaralx/distinfo3
-rw-r--r--graphics/xaralx/files/patch-Makefile.am22
-rw-r--r--graphics/xaralx/files/patch-PreComp_Makefile.am17
-rw-r--r--graphics/xaralx/files/patch-configure.in94
-rw-r--r--graphics/xaralx/files/patch-wxOil_compatdef.h29
-rw-r--r--graphics/xaralx/files/patch-wxOil_errors.cpp11
-rw-r--r--graphics/xaralx/files/patch-wxOil_errors.h22
-rw-r--r--graphics/xaralx/pkg-descr6
9 files changed, 253 insertions, 0 deletions
diff --git a/graphics/xaralx/Makefile b/graphics/xaralx/Makefile
new file mode 100644
index 000000000000..dd981e4468c4
--- /dev/null
+++ b/graphics/xaralx/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: XaraLX
+# Date created: 22 Mar 2006
+# Whom: Vasil Dimov <vd@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= XaraLX
+PORTVERSION= 0.4r762
+CATEGORIES= graphics
+MASTER_SITES= http://downloads.xara.com/opensource/
+
+MAINTAINER= vd@FreeBSD.org
+COMMENT= A top-tier vector and general purpose graphics program
+
+#WXDEP= ${X11BASE}/libwx_baseu-2.6.so.0.3.1
+WXDEP= wxgtk2-unicode>=2.6.3
+BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig \
+ ${WXDEP}:${PORTSDIR}/x11-toolkits/wxgtk26-unicode \
+ ${LOCALBASE}/bin/md5sum:${PORTSDIR}/archivers/dpkg \
+ ${LOCALBASE}/bin/zip:${PORTSDIR}/archivers/zip
+RUN_DEPENDS= ${BUILD_DEPENDS}
+LIB_DEPENDS= dlmalloc.2:${PORTSDIR}/devel/libdlmalloc
+
+USE_AUTOTOOLS= autoconf:259:env aclocal:19:env automake:19:env
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ARGS= --with-wx-config=wxgtk2u-2.6-config
+PKGCONFIGS=atk fontconfig gdk-2.0 pango
+CONFIGURE_ENV= CPPFLAGS_APPEND="`pkg-config --cflags ${PKGCONFIGS}` \
+ -I${LOCALBASE}/include/atk-1.0/atk \
+ -I${X11BASE}/include/gtk-2.0/gtk"
+
+USE_GMAKE= yes
+USE_GCC= 3.4+
+
+PROG= XaraLX
+
+PLIST_FILES= bin/${PROG}
+
+pre-configure:
+ cd ${WRKSRC} && ${SETENV} ${AUTOTOOLS_ENV} ${AUTORECONF} -f -s -i
+
+# the stock install target installs include/camtypes.h in addition which
+# is absolutely completely not necessary
+#do-install:
+# ${INSTALL_PROGRAM} ${WRKSRC}/${PROG} ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/graphics/xaralx/distinfo b/graphics/xaralx/distinfo
new file mode 100644
index 000000000000..1fd84c0fcfc8
--- /dev/null
+++ b/graphics/xaralx/distinfo
@@ -0,0 +1,3 @@
+MD5 (XaraLX-0.4r762.tar.gz) = 8a2bdcaa46a0ef0513c20bed600f2c77
+SHA256 (XaraLX-0.4r762.tar.gz) = f3d5e73c9017b616a2c825e9032ecff2c161b5895464507d18b8e64de697c28a
+SIZE (XaraLX-0.4r762.tar.gz) = 25588884
diff --git a/graphics/xaralx/files/patch-Makefile.am b/graphics/xaralx/files/patch-Makefile.am
new file mode 100644
index 000000000000..e0e0e3689518
--- /dev/null
+++ b/graphics/xaralx/files/patch-Makefile.am
@@ -0,0 +1,22 @@
+--- Makefile.am.orig Mon Apr 3 18:50:40 2006
++++ Makefile.am Tue Apr 4 15:41:30 2006
+@@ -1,5 +1,10 @@
++# we need -I- to prevent /usr/include/string.h from including our strings.h
++# instead of /usr/include/strings.h
++# Also we are using dlmalloc because the stock libc does not have
++# malloc_usable_size()
+ export XARAFLAGS = -I../PreComp -I$(TOPDIR)/Kernel -I$(TOPDIR)/wxOil -I$(TOPDIR)/wxOil/Res \
+ -I$(TOPDIR)/tools -I$(TOPDIR)/GDraw -I$(TOPDIR)/PreComp -I$(TOPDIR)/wxXtra \
++ -I- -I$(LOCALBASE)/include/dlmalloc $(WX_CPPFLAGS) \
+ -DUSE_NATIVE_XLONG -DBUILDSHADOWS -DOLD_MATRIX_TRANSFORMATIONS \
+ -DVECTOR_STROKING -DEXCLUDE_FROM_XARALX -DNEW_SHADOW_RENDER -DNO_XARACMS \
+ -DNEW_FEATURES -DSHOWPORTNOTE
+@@ -22,7 +27,7 @@
+ XaraLX_SOURCES = Kernel/libKernel.a wxOil/libwxOil.a tools/libTools.a wxXtra/libwxXtra.a
+ XaraLX_LDSOURCE = -Wl,--start-group $(XaraLX_SOURCES) -Wl,--end-group
+ endif
+-XaraLX_LDFLAGS = --debug -L$(srcdir)/$(CDRAW_LIB_DIR) $(WX_LIBS) $(LIBS) -lCDraw
++XaraLX_LDFLAGS = --debug -L$(srcdir)/$(CDRAW_LIB_DIR) $(WX_LIBS) $(LIBS) -lCDraw -L$(LOCALBASE) -ldlmalloc
+ XaraLX_LD = $(CXX)
+
+ if STATIC_ENABLE
diff --git a/graphics/xaralx/files/patch-PreComp_Makefile.am b/graphics/xaralx/files/patch-PreComp_Makefile.am
new file mode 100644
index 000000000000..9b4c5e1810ec
--- /dev/null
+++ b/graphics/xaralx/files/patch-PreComp_Makefile.am
@@ -0,0 +1,17 @@
+--- PreComp/Makefile.am.orig Mon Mar 27 09:58:41 2006
++++ PreComp/Makefile.am Mon Mar 27 09:58:52 2006
+@@ -13,10 +13,10 @@
+ camtypes.h.gch: camtypes.h
+ if $(CXXCOMPILE) -x c++-header -MT $@ -MD -MP -MF "$(DEPDIR)/camtypes.h.Tpo" -c -o $@ $<; \
+ then mv -f "$(DEPDIR)/camtypes.h.Tpo" "$(DEPDIR)/camtypes.h.Po"; else rm -f "$(DEPDIR)/camtypes.h.Tpo"; exit 1; fi
+- make -C ../Kernel clean
+- make -C ../wxXtra clean
+- make -C ../tools clean
+- make -C ../wxOil clean
++ $(MAKE) -C ../Kernel clean
++ $(MAKE) -C ../wxXtra clean
++ $(MAKE) -C ../tools clean
++ $(MAKE) -C ../wxOil clean
+
+
+
diff --git a/graphics/xaralx/files/patch-configure.in b/graphics/xaralx/files/patch-configure.in
new file mode 100644
index 000000000000..2959a9463af3
--- /dev/null
+++ b/graphics/xaralx/files/patch-configure.in
@@ -0,0 +1,94 @@
+--- configure.in.orig Mon Apr 3 18:50:40 2006
++++ configure.in Tue Apr 4 16:01:33 2006
+@@ -8,7 +8,7 @@
+ AC_ARG_ENABLE(debug,
+ [[ --enable-debug Add more debug information and checks to executable]],
+ [
+- if test $enableval == "yes"; then
++ if test $enableval = "yes"; then
+ DEBUG_FLAGS="-ggdb -D_DEBUG"
+ OPT_FLAGS="-O0"
+ DebugEnable="yes"
+@@ -19,7 +19,7 @@
+ AC_ARG_ENABLE(static-exec,
+ [[ --enable-static-exec Build a statically linked version of the executable]],
+ [
+- if test $enableval == "yes"; then
++ if test $enableval = "yes"; then
+ StaticEnable="yes"
+ DebugEnable="no"
+ fi
+@@ -47,7 +47,7 @@
+ AC_PROG_INSTALL
+ # We don't need dlopen right now and it's not supported on Darwin
+ # AC_LIBTOOL_DLOPEN
+-AC_PROG_LIBTOOL
++AC_PROG_RANLIB
+
+ AC_C_BIGENDIAN
+ AC_CHECK_SIZEOF(void*)
+@@ -72,7 +72,7 @@
+ PrecompileEnable="yes"
+
+ AC_MSG_CHECKING([Compiler])
+-if test $ac_compiler_gnu == "yes"; then
++if test $ac_compiler_gnu = "yes"; then
+ GccVersion=`$CXX -v 2>&1 | $AWK '{ if ($2 ~ /version/) print $3 }'`
+ GccVersion=`echo $GccVersion | $AWK 'BEGIN { FS = "."; } { printf "% d", ($1 * 1000 + $2) * 1000 + $3;}'`
+
+@@ -141,7 +141,6 @@
+ if echo $WX_CPPFLAGS | grep -q '__WXGTK__' ; then
+ WX_GTK="yes"
+ AC_MSG_RESULT([found])
+- PKG_CHECK_MODULES(GTK, [gtk+-2.0])
+ else
+ AC_MSG_RESULT([not found])
+ fi
+@@ -173,24 +172,15 @@
+ AC_MSG_ERROR([freetype is required. Try --with-freetype-config.])
+ fi])
+
+-if test $WX_GTK == "yes"; then
++if test $WX_GTK = "yes"; then
+ # GTK build, so call FTTEST function to test for FreeType
+ FTTEST
+ FT_CFLAGS="`$FTCONFIG --cflags`"
+-
+- # check for the Pango package
+- PKG_CHECK_MODULES(PANGOX, pangox,
+- [
+- PANGO_CFLAGS="$PANGOX_CFLAGS"
+- ],
+- [
+- AC_MSG_ERROR([pangox library not found])
+- ]
+- )
++ PANGO_CFLAGS=""
+ else
+ # non-GTK build, i.e., MacOS, so Pango and FreeType are not required
+- FT_CFLAGS = ""
+- PANGO_CFLAGS = ""
++ FT_CFLAGS=""
++ PANGO_CFLAGS=""
+ fi
+
+ TOPDIR=$srcdir;
+@@ -204,8 +194,8 @@
+ fi
+
+ # pass the Pango, FreeType and GTK flags (required for wxGTK font rendering)
+-CPPFLAGS="$CPPFLAGS $WX_CPPFLAGS $PANGO_CFLAGS $FT_CFLAGS $GTK_CFLAGS"
+-CXXFLAGS="$CXXFLAGS $WX_CPPFLAGS $PANGO_CFLAGS $FT_CFLAGS $GTK_CFLAGS"
++CPPFLAGS="$CPPFLAGS $WX_CPPFLAGS $PANGO_CFLAGS $FT_CFLAGS $GTK_CFLAGS $CPPFLAGS_APPEND"
++CXXFLAGS="$CXXFLAGS $WX_CPPFLAGS $PANGO_CFLAGS $FT_CFLAGS $GTK_CFLAGS $CPPFLAGS_APPEND"
+
+ AC_MSG_CHECKING([Linker])
+ case $host in
+@@ -244,6 +234,7 @@
+ AM_CONDITIONAL(DARWIN_LINK, [test "$DarwinLink" = "yes"])
+
+ AC_SUBST(TOPDIR)
++AC_SUBST(WX_CPPFLAGS)
+ AC_SUBST(WX_LIBS)
+ AC_SUBST(XRCINCLUDE)
+ AC_SUBST(XARALANGUAGE)
diff --git a/graphics/xaralx/files/patch-wxOil_compatdef.h b/graphics/xaralx/files/patch-wxOil_compatdef.h
new file mode 100644
index 000000000000..54ea08ab8a68
--- /dev/null
+++ b/graphics/xaralx/files/patch-wxOil_compatdef.h
@@ -0,0 +1,29 @@
+--- wxOil/compatdef.h.orig Thu Mar 23 18:43:35 2006
++++ wxOil/compatdef.h Thu Mar 23 18:45:19 2006
+@@ -136,7 +136,7 @@
+ #define lstrcpyn wcsncpy
+ #define lstrcat wcscat
+ #define lstrcmp wcscmp
+-#if defined(__WXMAC__)
++#if defined(__WXMAC__) || defined(__FreeBSD__)
+ //PORTNOTE("MacPort", "Horrendous bodge - can't find case insensitive string compare function")
+ // NOTE! wcscasecmp not available in wchar.h on Mac OS X (???) Bodged to be case senstive temporarilly...
+ #define lstrcmpi wcscmp
+@@ -153,7 +153,7 @@
+ #define _tcsncpy wcsncpy
+ #define _tcscat wcscat
+ #define _tcschr wcschr
+-#if defined(__WXMAC__)
++#if defined(__WXMAC__) || defined(__FreeBSD__)
+ #define _tcsdup wxStrdup
+ #else
+ #define _tcsdup wcsdup
+@@ -162,7 +162,7 @@
+ #define tcstok wcstok
+ #define _tcscmp wcscmp
+ #define _tcsncmp wcsncmp
+-#if defined(__WXMAC__)
++#if defined(__WXMAC__) || defined(__FreeBSD__)
+ //PORTNOTE("MacPort", "Horrendous bodge - can't find case insensitive string compare function")
+ // NOTE! wcsncasecmp not available in wchar.h on Mac OS X (???) Bodged to be case senstive temporarilly...
+ #define _tcsnicmp wcsncmp
diff --git a/graphics/xaralx/files/patch-wxOil_errors.cpp b/graphics/xaralx/files/patch-wxOil_errors.cpp
new file mode 100644
index 000000000000..a95a92b79ee8
--- /dev/null
+++ b/graphics/xaralx/files/patch-wxOil_errors.cpp
@@ -0,0 +1,11 @@
+--- wxOil/errors.cpp.orig Thu Mar 23 20:23:57 2006
++++ wxOil/errors.cpp Thu Mar 23 20:24:13 2006
+@@ -1558,7 +1558,7 @@
+
+ ********************************************************************************************/
+
+-#ifndef __WXMAC__
++#if !defined(__WXMAC__) && !defined(__FreeBSD__)
+ void Error::StackWalker::OnStackFrame(const wxStackFrame & frame)
+ {
+ #ifdef _DEBUG
diff --git a/graphics/xaralx/files/patch-wxOil_errors.h b/graphics/xaralx/files/patch-wxOil_errors.h
new file mode 100644
index 000000000000..b5f5890f054f
--- /dev/null
+++ b/graphics/xaralx/files/patch-wxOil_errors.h
@@ -0,0 +1,22 @@
+--- wxOil/errors.h.orig Thu Mar 23 18:38:06 2006
++++ wxOil/errors.h Thu Mar 23 18:39:20 2006
+@@ -106,7 +106,8 @@
+ #ifndef INC_ERRORS
+ #define INC_ERRORS
+
+-#ifndef __WXMAC__
++// FreeBSD does not provide backtrace()
++#if !defined(__WXMAC__) && !defined(__FreeBSD__)
+ #include <wx/stackwalk.h>
+ #endif
+
+@@ -594,7 +595,8 @@
+ public:
+ static void DumpStack(UINT32 frames=0);
+
+-#ifndef __WXMAC__
++// FreeBSD does not provide backtrace()
++#if !defined(__WXMAC__) && !defined(__FreeBSD__)
+ class StackWalker : public wxStackWalker
+ {
+ public:
diff --git a/graphics/xaralx/pkg-descr b/graphics/xaralx/pkg-descr
new file mode 100644
index 000000000000..dee704196ec6
--- /dev/null
+++ b/graphics/xaralx/pkg-descr
@@ -0,0 +1,6 @@
+Xara X has been a commercial shipping Windows product for
+10 years (and non-Windows versions go back before that).
+It's a modern, object orientated design that's highly
+stable, and has gained hundreds of thousands of users.
+
+WWW: http://www.xaralx.org