aboutsummaryrefslogtreecommitdiff
path: root/graphics/xfig-devel
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2007-12-15 20:48:48 +0000
committerPav Lucistnik <pav@FreeBSD.org>2007-12-15 20:48:48 +0000
commit7120c495245c489739a5ed087d3e925b288a2602 (patch)
tree4f54732010f3c4c9966bceccd015bbd8d2c8b8af /graphics/xfig-devel
parentfb68a5185acb4a34bafe10bc316e57de2c3e7728 (diff)
downloadports-7120c495245c489739a5ed087d3e925b288a2602.tar.gz
ports-7120c495245c489739a5ed087d3e925b288a2602.zip
Notes
Diffstat (limited to 'graphics/xfig-devel')
-rw-r--r--graphics/xfig-devel/Makefile2
-rw-r--r--graphics/xfig-devel/files/patch-u_fonts.c11
-rw-r--r--graphics/xfig-devel/files/patch-w_fontpanel.c20
3 files changed, 32 insertions, 1 deletions
diff --git a/graphics/xfig-devel/Makefile b/graphics/xfig-devel/Makefile
index f3816685c5d7..202c44699c1e 100644
--- a/graphics/xfig-devel/Makefile
+++ b/graphics/xfig-devel/Makefile
@@ -7,7 +7,7 @@
PORTNAME= xfig
PORTVERSION= 3.2.5.a5
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= graphics
MASTER_SITES= http://xfig.org/software/xfig/${PORTVERSION:R}-alpha/
DISTNAME= ${PORTNAME}.${PORTVERSION:S,.a,-alpha,}.full
diff --git a/graphics/xfig-devel/files/patch-u_fonts.c b/graphics/xfig-devel/files/patch-u_fonts.c
new file mode 100644
index 000000000000..4ea1704b38cc
--- /dev/null
+++ b/graphics/xfig-devel/files/patch-u_fonts.c
@@ -0,0 +1,11 @@
+--- u_fonts.c.old 2007-10-17 12:22:24.000000000 -0700
++++ u_fonts.c 2007-10-17 12:23:36.000000000 -0700
+@@ -107,7 +107,7 @@
+ /* PostScript font names matched with X11 font names in x_fontinfo */
+
+ struct _fstruct ps_fontinfo[NUM_FONTS + 1] = {
+- {"Default", -1},
++ {"Default", 0},
+ {"Times-Roman", 0},
+ {"Times-Italic", 1},
+ {"Times-Bold", 2},
diff --git a/graphics/xfig-devel/files/patch-w_fontpanel.c b/graphics/xfig-devel/files/patch-w_fontpanel.c
new file mode 100644
index 000000000000..edee4939bd7c
--- /dev/null
+++ b/graphics/xfig-devel/files/patch-w_fontpanel.c
@@ -0,0 +1,20 @@
+--- w_fontpanel.c.orig Fri Feb 24 12:23:06 2006
++++ w_fontpanel.c
+@@ -143,7 +143,7 @@
+ ps_fontmenu_items[i].type = MENU_IMAGESTRING; /* put the fontnames in
+ * menu */
+ ps_fontmenu_items[i].label = ps_fontinfo[i].name;
+- ps_fontmenu_items[i].info = (caddr_t) (i - 1); /* index for font # */
++ ps_fontmenu_items[i].info = (caddr_t) i; /* index for font # */
+ }
+
+ for (i = 0; i < NUM_LATEX_FONTS; i++) {
+@@ -359,7 +359,7 @@
+ char *font_name = mi->label;
+
+ if (*flag_sel)
+- *font_ps_sel = (int) mi->info; /* set ps font to one selected */
++ *font_ps_sel = (int) mi->info - 1; /* set ps font to one selected */
+ else
+ *font_latex_sel = (int) mi->info; /* set latex font to one
+ * selected */