aboutsummaryrefslogtreecommitdiff
path: root/graphics/xfractint
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2017-01-09 13:16:49 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2017-01-09 13:16:49 +0000
commit9d79e7b1469f6887d302e13ce7c67c54408a2453 (patch)
tree263754af5ddd95f1ad55b06c101378a0cf71009b /graphics/xfractint
parenta0e384abe8236d5d12c69354d90c0de5342f7efb (diff)
downloadports-9d79e7b1469f6887d302e13ce7c67c54408a2453.tar.gz
ports-9d79e7b1469f6887d302e13ce7c67c54408a2453.zip
Notes
Diffstat (limited to 'graphics/xfractint')
-rw-r--r--graphics/xfractint/Makefile8
-rw-r--r--graphics/xfractint/files/pre-1000034-libm-patch44
2 files changed, 1 insertions, 51 deletions
diff --git a/graphics/xfractint/Makefile b/graphics/xfractint/Makefile
index b06270efd72e..a7e2af0da8ff 100644
--- a/graphics/xfractint/Makefile
+++ b/graphics/xfractint/Makefile
@@ -17,12 +17,6 @@ ALL_TARGET= ${PORTNAME}
DESKTOP_ENTRIES= "Xfracint" "${COMMENT}" "" "${PORTNAME}" "" "false"
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 1000034
-EXTRA_PATCHES= ${FILESDIR}/pre-1000034-libm-patch
-.endif
-
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/xfractint ${STAGEDIR}${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/unix/xfractint.man \
@@ -34,4 +28,4 @@ do-install:
cd ${WRKSRC} && ${COPYTREE_SHARE} ${dir} ${STAGEDIR}${DATADIR}
.endfor
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/xfractint/files/pre-1000034-libm-patch b/graphics/xfractint/files/pre-1000034-libm-patch
deleted file mode 100644
index 5d2ad985bb3c..000000000000
--- a/graphics/xfractint/files/pre-1000034-libm-patch
+++ /dev/null
@@ -1,44 +0,0 @@
---- common/mpmath_c.c.orig 2012-03-10 17:28:37.000000000 -0500
-+++ common/mpmath_c.c 2012-03-10 17:34:32.000000000 -0500
-@@ -220,7 +220,7 @@
- if(t.x < -690)
- e2x = 0.0;
- else
-- e2x = expl(t.x);
-+ e2x = exp(t.x);
- #ifdef XFRACT
- if (isnan(e2x) || isinf(e2x))
- e2x = 1.0;
---- common/soi.c.orig 2011-05-07 15:36:36.000000000 -0500
-+++ common/soi.c 2012-03-10 17:08:47.000000000 -0500
-@@ -25,7 +25,7 @@
- #define FABS(x) fabsl(x)
- /* the following needs to be changed back to frexpl once the portability
- issue has been addressed JCO */
--#ifndef XFRACT
-+#ifndef __FreeBSD__
- #define FREXP(x,y) frexpl(x,y)
- #else
- #define FREXP(x,y) frexp(x,y)
---- unix/fpu087.c.orig 2012-03-10 17:28:49.000000000 -0500
-+++ unix/fpu087.c 2012-03-10 17:36:40.000000000 -0500
-@@ -86,8 +86,8 @@
- *Sinh = 1.0;
- *Cosh = 1.0;
- } else {
-- *Sinh = (LDBL)sinhl(*Angle);
-- *Cosh = (LDBL)coshl(*Angle);
-+ *Sinh = (LDBL)sinh(*Angle);
-+ *Cosh = (LDBL)cosh(*Angle);
- }
- if (isnan(*Sinh) || isinf(*Sinh))
- *Sinh = 1.0;
-@@ -119,7 +119,7 @@
- {
- LDBL pwr,y;
- y = x->y;
-- pwr = expl(x->x);
-+ pwr = exp(x->x);
- if (isnan(pwr) || isinf(pwr))
- pwr = 1.0;
- z->x = (double)(pwr*cosl(y));