aboutsummaryrefslogtreecommitdiff
path: root/graphics/xli
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2011-05-18 08:18:43 +0000
committerWen Heping <wen@FreeBSD.org>2011-05-18 08:18:43 +0000
commitb0cf11b5677ae92c508c406f3ac61ed15a7e0175 (patch)
tree9cb476a034740ca187da5e78ab7557d12522b690 /graphics/xli
parentd45ebc6c6fe9699188f3fbe7930f24995ef47e1a (diff)
downloadports-b0cf11b5677ae92c508c406f3ac61ed15a7e0175.tar.gz
ports-b0cf11b5677ae92c508c406f3ac61ed15a7e0175.zip
Notes
Diffstat (limited to 'graphics/xli')
-rw-r--r--graphics/xli/Makefile2
-rw-r--r--graphics/xli/files/patch-xpixmap.c14
2 files changed, 15 insertions, 1 deletions
diff --git a/graphics/xli/Makefile b/graphics/xli/Makefile
index 2f8de957dae5..a54f665701d8 100644
--- a/graphics/xli/Makefile
+++ b/graphics/xli/Makefile
@@ -7,7 +7,7 @@
PORTNAME= xli
PORTVERSION= 1.17.0
-PORTREVISION= 11
+PORTREVISION= 12
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_DEBIAN}
MASTER_SITE_SUBDIR= pool/main/x/${PORTNAME}
diff --git a/graphics/xli/files/patch-xpixmap.c b/graphics/xli/files/patch-xpixmap.c
new file mode 100644
index 000000000000..d1884221759e
--- /dev/null
+++ b/graphics/xli/files/patch-xpixmap.c
@@ -0,0 +1,14 @@
+--- xpixmap.c.orig 2006-11-10 23:52:14.000000000 -0600
++++ xpixmap.c 2011-05-17 01:08:15.566413745 -0500
+@@ -463,7 +463,10 @@ Image *xpixmapLoad(char *fullname, Image
+ } else
+ p = buf;
+
+- if (!xliParseXColor(&globals.dinfo, p, &xcolor)) {
++ if (!strcmp(p, "None"))
++ xliParseXColor(&globals.dinfo,
++ image_ops->bg ? image_ops->bg : "black", &xcolor);
++ else if (!xliParseXColor(&globals.dinfo, p, &xcolor)) {
+ fprintf(stderr, "xpixmapLoad: %s - Bad color name '%s'\n", name, p);
+ xcolor.red = xcolor.green = xcolor.blue = 0;
+ }