aboutsummaryrefslogtreecommitdiff
path: root/graphics/xmfract
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-06-20 14:11:10 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-06-20 14:11:10 +0000
commit6669e3830499d4ba43eef9e160ad58c98c036570 (patch)
treec66b4382cab448e63d5bb09f5b939ab0ea50530a /graphics/xmfract
parent300d2b52671d225223dfc26ec0272cd2126d952e (diff)
downloadports-6669e3830499d4ba43eef9e160ad58c98c036570.tar.gz
ports-6669e3830499d4ba43eef9e160ad58c98c036570.zip
Notes
Diffstat (limited to 'graphics/xmfract')
-rw-r--r--graphics/xmfract/Makefile2
-rw-r--r--graphics/xmfract/files/patch-src__window_size.c13
2 files changed, 14 insertions, 1 deletions
diff --git a/graphics/xmfract/Makefile b/graphics/xmfract/Makefile
index 84c826124cc1..43f6507c7f41 100644
--- a/graphics/xmfract/Makefile
+++ b/graphics/xmfract/Makefile
@@ -23,7 +23,7 @@ GNU_CONFIGURE= yes
.include <bsd.port.pre.mk>
.if ${ARCH} != "i386" && ${OSVERSION} >= 600034
-BROKEN= "Internal compiler error during build on FreeBSD >= 6.0 and !i386"
+BROKEN= Internal compiler error during build on FreeBSD >= 6.0 and !i386
.endif
.include <bsd.port.post.mk>
diff --git a/graphics/xmfract/files/patch-src__window_size.c b/graphics/xmfract/files/patch-src__window_size.c
new file mode 100644
index 000000000000..994896796a1c
--- /dev/null
+++ b/graphics/xmfract/files/patch-src__window_size.c
@@ -0,0 +1,13 @@
+--- src/window_size.c.orig Wed Jun 21 00:47:14 1995
++++ src/window_size.c Fri Jun 15 00:33:44 2007
+@@ -28,8 +28,8 @@
+ /* static variables */
+ static Widget resize_main_window_shell = NULL;
+ static Widget resize_main_window_dialog = NULL;
+-static Widget explicit_x_size_scale = NULL;
+-static Widget explicit_y_size_scale = NULL;
++Widget explicit_x_size_scale = NULL;
++Widget explicit_y_size_scale = NULL;
+
+ /*ARGSUSED*/
+ void window_size_cb(