aboutsummaryrefslogtreecommitdiff
path: root/graphics/xmms-blursk/Makefile
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2002-08-21 02:56:07 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2002-08-21 02:56:07 +0000
commitddfe40a7350547b3101604a9e98ecb1942f0b32b (patch)
tree653e3117a38038504aa732d552ce8db7d030b830 /graphics/xmms-blursk/Makefile
parente0ff515ec78aa3f7caa47eba587446153f1e7ffc (diff)
downloadports-ddfe40a7350547b3101604a9e98ecb1942f0b32b.tar.gz
ports-ddfe40a7350547b3101604a9e98ecb1942f0b32b.zip
Notes
Diffstat (limited to 'graphics/xmms-blursk/Makefile')
-rw-r--r--graphics/xmms-blursk/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/graphics/xmms-blursk/Makefile b/graphics/xmms-blursk/Makefile
new file mode 100644
index 000000000000..2499120afe89
--- /dev/null
+++ b/graphics/xmms-blursk/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: xmms-blursk
+# Date created: 19 Aug 2002
+# Whom: David Yeske <dyeske@yahoo.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= blursk
+PORTVERSION= 1.3
+CATEGORIES= graphics
+MASTER_SITES= http://www.cs.pdx.edu/~kirkenda/blursk/
+PKGNAMEPREFIX= xmms-
+DISTNAME= Blursk-${PORTVERSION}
+
+MAINTAINER= dyeske@yahoo.com
+
+BUILD_DEPENDS= xmms-config:${PORTSDIR}/audio/xmms
+RUN_DEPENDS= xmms:${PORTSDIR}/audio/xmms
+
+USE_X_PREFIX= yes
+USE_GNOMENG= yes
+USE_GNOME= gtk12
+USE_REINPLACE= yes
+GNU_CONFIGURE= yes
+
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} ${CFLAGS} ${PTHREAD_CFLAGS}"
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-O2||' \
+ ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT} \
+ ${BUILD_WRKSRC}/Makefile.in
+
+.include <bsd.port.mk>