aboutsummaryrefslogtreecommitdiff
path: root/graphics/xmms-gdancer
diff options
context:
space:
mode:
authorAlexander Leidinger <netchild@FreeBSD.org>2002-04-23 16:46:05 +0000
committerAlexander Leidinger <netchild@FreeBSD.org>2002-04-23 16:46:05 +0000
commit4231616b5c34d49d6b24bce4ff9657c730322f5f (patch)
tree70cc12bfc0162856bca1ca7a295078638f9e52a6 /graphics/xmms-gdancer
parent8575472dca59479c2f26b01f946ddf176e950efd (diff)
downloadports-4231616b5c34d49d6b24bce4ff9657c730322f5f.tar.gz
ports-4231616b5c34d49d6b24bce4ff9657c730322f5f.zip
Notes
Diffstat (limited to 'graphics/xmms-gdancer')
-rw-r--r--graphics/xmms-gdancer/Makefile34
-rw-r--r--graphics/xmms-gdancer/distinfo1
-rw-r--r--graphics/xmms-gdancer/pkg-comment1
-rw-r--r--graphics/xmms-gdancer/pkg-descr3
-rw-r--r--graphics/xmms-gdancer/pkg-plist1
5 files changed, 40 insertions, 0 deletions
diff --git a/graphics/xmms-gdancer/Makefile b/graphics/xmms-gdancer/Makefile
new file mode 100644
index 000000000000..0d224aed9860
--- /dev/null
+++ b/graphics/xmms-gdancer/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: xmms-gdancer
+# Date created: 2. Jul 2001
+# Whom: Alexander@Leidinger.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= xmms-gdancer
+PORTVERSION= 0.4.4
+CATEGORIES= audio
+MASTER_SITES= http://www.figz.com/gdancer/files/
+DISTNAME= gdancer-$(PORTVERSION)
+
+MAINTAINER= netchild@FreeBSD.org
+
+LIB_DEPENDS= xmms.3:${PORTSDIR}/audio/xmms \
+ gdk_pixbuf.2:${PORTSDIR}/graphics/gdk-pixbuf
+
+USE_X_PREFIX= yes
+USE_GTK= yes
+INSTALLS_SHLIB= yes
+
+GNU_CONFIGURE= yes
+
+CONFIGURE_ARGS= --enable-pixbuf
+
+post-install:
+ -${RM} ${PREFIX}/lib/xmms/Visualization/gdancer.la
+ @${ECHO_CMD} +++
+ @${ECHO_CMD} Now you have to install some themes from http://www.figz.com/gdancer/themes.php
+ @${ECHO_CMD} into .xmms/gdancer_themes. If it does not exist in your HOME directory, just
+ @${ECHO_CMD} create it.
+
+.include <bsd.port.mk>
diff --git a/graphics/xmms-gdancer/distinfo b/graphics/xmms-gdancer/distinfo
new file mode 100644
index 000000000000..ca0f35189e65
--- /dev/null
+++ b/graphics/xmms-gdancer/distinfo
@@ -0,0 +1 @@
+MD5 (gdancer-0.4.4.tar.gz) = 49a1f116c6cf64209c366381adeecc60
diff --git a/graphics/xmms-gdancer/pkg-comment b/graphics/xmms-gdancer/pkg-comment
new file mode 100644
index 000000000000..a65eea38f751
--- /dev/null
+++ b/graphics/xmms-gdancer/pkg-comment
@@ -0,0 +1 @@
+XMMS Visualization plugin, displays dancing figures
diff --git a/graphics/xmms-gdancer/pkg-descr b/graphics/xmms-gdancer/pkg-descr
new file mode 100644
index 000000000000..987c245ac7dc
--- /dev/null
+++ b/graphics/xmms-gdancer/pkg-descr
@@ -0,0 +1,3 @@
+XMMS Visualization plugin, displays dancing figures.
+
+WWW: http://www.figz.com/gdancer/
diff --git a/graphics/xmms-gdancer/pkg-plist b/graphics/xmms-gdancer/pkg-plist
new file mode 100644
index 000000000000..31f0ef9e91ac
--- /dev/null
+++ b/graphics/xmms-gdancer/pkg-plist
@@ -0,0 +1 @@
+lib/xmms/Visualization/gdancer.so