aboutsummaryrefslogtreecommitdiff
path: root/graphics/xmms-gdancer
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2014-01-19 08:53:58 +0000
committerMartin Wilke <miwi@FreeBSD.org>2014-01-19 08:53:58 +0000
commit8803047244bcfc36702e3dd905b4bd159f2f7b40 (patch)
tree1d2dbd8c337f952801dbaa2441b79bd934c2f744 /graphics/xmms-gdancer
parent5441ff34e617a48650e4a64567c8c1b8f2f1d3a0 (diff)
downloadports-8803047244bcfc36702e3dd905b4bd159f2f7b40.tar.gz
ports-8803047244bcfc36702e3dd905b4bd159f2f7b40.zip
Notes
Diffstat (limited to 'graphics/xmms-gdancer')
-rw-r--r--graphics/xmms-gdancer/Makefile19
-rw-r--r--graphics/xmms-gdancer/files/patch-src__image.c37
2 files changed, 49 insertions, 7 deletions
diff --git a/graphics/xmms-gdancer/Makefile b/graphics/xmms-gdancer/Makefile
index e7ccbcab4287..31f73abe5743 100644
--- a/graphics/xmms-gdancer/Makefile
+++ b/graphics/xmms-gdancer/Makefile
@@ -11,20 +11,25 @@ DISTNAME= gdancer-$(PORTVERSION)
MAINTAINER= ports@FreeBSD.org
COMMENT= XMMS Visualization plugin, displays dancing figures
-LIB_DEPENDS= xmms.4:${PORTSDIR}/multimedia/xmms
+LICENSE= GPLv2 # (or later)
+LIB_DEPENDS= libxmms.so:${PORTSDIR}/multimedia/xmms
+
+USES= gmake
USE_GNOME= gtk12
-USE_GMAKE= yes
-GNU_CONFIGURE= yes
+USE_CSTD= gnu89
+USE_AUTOTOOLS= libtool
PLIST_FILES= lib/xmms/Visualization/gdancer.so
-NO_STAGE= yes
post-patch:
- @${REINPLACE_CMD} -e '/objformat=/s|=.*|=elf|' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e \
+ 's|-O2|@CFLAGS@| ; \
+ s|@GDK_PIXBUF_LIBS@||' ${WRKSRC}/src/Makefile.in
do-install:
- ${INSTALL_DATA} ${WRKSRC}/src/.libs/gdancer.so ${PREFIX}/lib/xmms/Visualization
- @${CAT} ${PKGMESSAGE}
+ @${MKDIR} ${STAGEDIR}${PREFIX}/lib/xmms/Visualization
+ (cd ${WRKSRC}/src/.libs && ${INSTALL_LIB} gdancer.so \
+ ${STAGEDIR}${PREFIX}/lib/xmms/Visualization)
.include <bsd.port.mk>
diff --git a/graphics/xmms-gdancer/files/patch-src__image.c b/graphics/xmms-gdancer/files/patch-src__image.c
new file mode 100644
index 000000000000..ae3d02a12fa2
--- /dev/null
+++ b/graphics/xmms-gdancer/files/patch-src__image.c
@@ -0,0 +1,37 @@
+--- src/image.c.orig
++++ src/image.c
+@@ -1,5 +1,6 @@
+ #include <gtk/gtk.h>
+ #include <unistd.h>
++#include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>
+
+@@ -12,6 +13,9 @@
+ #include "../pics/neutral.xpm" // *neutralimage[]
+ #include "../pics/treble.xpm" // *trebleimage[]
+
++void gd_image_change (GDancer *, enum gd_freq_type, gboolean);
++void load_images (GDancer *);
++
+ // Clears the pixmaps from memory
+ void clear_images_sub (frame *frame)
+ {
+@@ -109,7 +113,7 @@
+ }
+ }
+
+-gint load_images (GDancer *dancer)
++void load_images (GDancer *dancer)
+ {
+ if (dancer->window == NULL) return; // Make sure dancer exists
+
+@@ -183,7 +187,7 @@
+ gd_move_window (dancer);
+ }
+
+-gint gd_image_change (GDancer *dancer, enum gd_freq_type newtype, gboolean always_draw)
++void gd_image_change (GDancer *dancer, enum gd_freq_type newtype, gboolean always_draw)
+ {
+ static frame *oldtype = NULL;
+ frame *type;