aboutsummaryrefslogtreecommitdiff
path: root/graphics/xmms-goom/Makefile
diff options
context:
space:
mode:
authorPatrick Li <pat@FreeBSD.org>2002-01-27 17:59:44 +0000
committerPatrick Li <pat@FreeBSD.org>2002-01-27 17:59:44 +0000
commit47656f37c4a4f175103527e7ca7364ebde64e341 (patch)
tree5010485170f3aa697419cc0ef0b0206f16606131 /graphics/xmms-goom/Makefile
parentbd71a8310f23517d9ec39c001dee4f8bc6ba13e1 (diff)
Notes
Diffstat (limited to 'graphics/xmms-goom/Makefile')
-rw-r--r--graphics/xmms-goom/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/graphics/xmms-goom/Makefile b/graphics/xmms-goom/Makefile
new file mode 100644
index 000000000000..7d0405197b4b
--- /dev/null
+++ b/graphics/xmms-goom/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: xmms-goom
+# Date created: 20 Jan 2002
+# Whom: David Yeske <dyeske@yahoo.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= goom
+PORTVERSION= 1.7.6
+CATEGORIES= graphics
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= goom
+PKGNAMEPREFIX= xmms-
+DISTNAME= xmms-goom_${PORTVERSION:S/.p/pre/}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= dyeske@yahoo.com
+
+LIB_DEPENDS= xmms.3:${PORTSDIR}/audio/xmms
+
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+USE_LIBTOOL= yes
+USE_GTK= yes
+
+pre-patch:
+ @${PERL} -pi -e 's|gtk-config|${GTK_CONFIG}|g;' \
+ ${WRKSRC}/configure
+ @${PERL} -pi -e 's|gtk-config|${GTK_CONFIG}|g; s|-lgtk|-lgtk12|g;' \
+ ${WRKSRC}/src/Makefile.in
+
+.include <bsd.port.mk>