aboutsummaryrefslogtreecommitdiff
path: root/graphics/xmms-scivi/Makefile
diff options
context:
space:
mode:
authorMarcus Alves Grando <mnag@FreeBSD.org>2005-10-16 00:09:24 +0000
committerMarcus Alves Grando <mnag@FreeBSD.org>2005-10-16 00:09:24 +0000
commitb3cd987b5347643efed3434e2639bdee920bbb14 (patch)
tree665a0cfbdcb23dd93b79ff049d791f0ea1621765 /graphics/xmms-scivi/Makefile
parent9b836cde7d0a24b52580267173174ba8a276e4e6 (diff)
downloadports-b3cd987b5347643efed3434e2639bdee920bbb14.tar.gz
ports-b3cd987b5347643efed3434e2639bdee920bbb14.zip
Notes
Diffstat (limited to 'graphics/xmms-scivi/Makefile')
-rw-r--r--graphics/xmms-scivi/Makefile44
1 files changed, 44 insertions, 0 deletions
diff --git a/graphics/xmms-scivi/Makefile b/graphics/xmms-scivi/Makefile
new file mode 100644
index 000000000000..1769ed7e8ea4
--- /dev/null
+++ b/graphics/xmms-scivi/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: xmms-scivi
+# Date created: 15 Oct 2005
+# Whom: Alejandro Pulver <alejandro@varnet.biz>
+#
+# $FreeBSD$
+#
+
+PORTNAME= scivi
+DISTVERSION= 0.2.0-rc3
+CATEGORIES= graphics
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PKGNAMEPREFIX}${PORTNAME}
+PKGNAMEPREFIX= xmms-
+
+MAINTAINER= alejandro@varnet.biz
+COMMENT= Scivi is a visualization plugin for XMMS
+
+LIB_DEPENDS= xmms.4:${PORTSDIR}/multimedia/xmms
+
+USE_X_PREFIX= yes
+USE_BZIP2= yes
+USE_REINPLACE= yes
+USE_GL= yes
+USE_GNOME= gtk12
+
+USE_LIBTOOL_VER=15
+
+post-patch:
+ @${REINPLACE_CMD} -e "s|-lpthread|${PTHREAD_LIBS}|g" \
+ ${WRKSRC}/configure ${WRKSRC}/src/Makefile.in
+ @${REINPLACE_CMD} -e "s|<stdint.h>|<inttypes.h>|g" \
+ ${WRKSRC}/src/dynam.c ${WRKSRC}/src/glstuff.c \
+ ${WRKSRC}/src/gui.c ${WRKSRC}/src/plugin.c \
+ ${WRKSRC}/src/presets.c ${WRKSRC}/src/scivi.c \
+ ${WRKSRC}/src/utilx.c ${WRKSRC}/src/utilf.c \
+ ${WRKSRC}/src/utilsnd.c
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>