aboutsummaryrefslogtreecommitdiff
path: root/graphics/xmrm
diff options
context:
space:
mode:
authorMichael Reifenberger <mr@FreeBSD.org>2005-11-13 08:47:45 +0000
committerMichael Reifenberger <mr@FreeBSD.org>2005-11-13 08:47:45 +0000
commit6966949fc557d6a5e82f275c35b5f47f77ad3603 (patch)
tree00c880ab4013fe7d4750fd0cfe5ca20fd6afee4c /graphics/xmrm
parent77683c01d1d09ac0ff9024c9c52888e22c17f708 (diff)
downloadports-6966949fc557d6a5e82f275c35b5f47f77ad3603.tar.gz
ports-6966949fc557d6a5e82f275c35b5f47f77ad3603.zip
Notes
Diffstat (limited to 'graphics/xmrm')
-rw-r--r--graphics/xmrm/Makefile6
-rw-r--r--graphics/xmrm/files/patch-io.cc116
-rw-r--r--graphics/xmrm/files/patch-xmrm_mpeg_main.cc42
3 files changed, 154 insertions, 10 deletions
diff --git a/graphics/xmrm/Makefile b/graphics/xmrm/Makefile
index 18957de669f2..7c4b7134cbe3 100644
--- a/graphics/xmrm/Makefile
+++ b/graphics/xmrm/Makefile
@@ -28,12 +28,6 @@ NO_WRKSUBDIR= yes
.include <bsd.port.pre.mk>
-.if ${ARCH} != "i386"
-BROKEN= "Does not compile on !i386"
-.else
-BROKEN= "Does not compile on i386"
-.endif
-
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/xmrm ${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/xmrm_mpeg ${PREFIX}/bin
diff --git a/graphics/xmrm/files/patch-io.cc b/graphics/xmrm/files/patch-io.cc
index 612e48245343..8bc60ccde99e 100644
--- a/graphics/xmrm/files/patch-io.cc
+++ b/graphics/xmrm/files/patch-io.cc
@@ -1,5 +1,5 @@
---- io.cc.orig Tue Mar 10 00:00:00 1998
-+++ io.cc Fri Nov 29 18:01:04 2002
+--- io.cc.orig Tue Mar 10 07:00:00 1998
++++ io.cc Sun Nov 13 16:19:00 2005
@@ -87,7 +87,7 @@
extern ControlClass control;
@@ -9,6 +9,24 @@
{
int i;
+@@ -301,7 +301,7 @@
+ raster = pic->GetPicPointer();
+
+ // Reading TIFF-Image into memory:
+- if ( (TIFFReadRGBAImage(tif,tif_w,tif_h,raster,0))==0 )
++ if ( (TIFFReadRGBAImage(tif,tif_w,tif_h,(uint32*)raster,0))==0 )
+ {
+ TIFFClose(tif);
+ return 1;
+@@ -435,7 +435,7 @@
+
+ // Reading TIFF-Image into memory: bit 24 16 8 0
+ // Internal raster-format: one unsigned long per pixel: | a | b | g | r |
+- if ( (TIFFReadRGBAImage(tif,tif_w,tif_h,raster,0))==0 )
++ if ( (TIFFReadRGBAImage(tif,tif_w,tif_h,(uint32*)raster,0))==0 )
+ {
+ TIFFClose(tif);
+ return 1;
@@ -573,7 +573,7 @@
TIFFSetField(tif,TIFFTAG_IMAGELENGTH,size_h);
TIFFSetField(tif,TIFFTAG_BITSPERSAMPLE,8);
@@ -18,6 +36,35 @@
TIFFSetField(tif,TIFFTAG_PLANARCONFIG,PLANARCONFIG_CONTIG);
TIFFSetField(tif,TIFFTAG_PHOTOMETRIC,PHOTOMETRIC_RGB);
TIFFSetField(tif,TIFFTAG_ORIENTATION,ORIENTATION_TOPLEFT);
+@@ -592,8 +592,8 @@
+
+ TIFFClose(tif);
+
+- extension = NULL;
+- filename_only = NULL;
++ extension = (char*)NULL;
++ filename_only = (char*)NULL;
+ free(savename);
+ }
+
+@@ -644,7 +644,7 @@
+ }
+
+ // Reading TIFF-Image into memory:
+- if ( (TIFFReadRGBAImage(tif,tif_w,tif_h,raster,0))==0 )
++ if ( (TIFFReadRGBAImage(tif,tif_w,tif_h,(uint32*)raster,0))==0 )
+ {
+ fl_show_alert("ERROR:","Unable to load Detail-map:",filename,1);
+ TIFFClose(tif);
+@@ -930,7 +930,7 @@
+ (void) strcpy( directory, filename );
+ help = strrchr(directory, '/');
+ *(++help) = '\0';
+- help = NULL;
++ help = (char*)NULL;
+ }
+
+ if( !filename )
@@ -1154,7 +1154,9 @@
if ( proj.akima_points[i][0] < 0.0 || proj.akima_points[i][0] > 1.0 ||\
proj.akima_points[i][1] < 0.0 || proj.akima_points[i][1] > 1.0 )
@@ -43,6 +90,53 @@
proj.weight_a = control.warp_a;
proj.weight_b = control.warp_b;
proj.weight_p = control.warp_p;
+@@ -1407,16 +1410,16 @@
+ fprintf(fp,"%s\n\n", PROJECT_FILE_V20_ID);
+ help = strrchr(proj.filename_source, '/');
+ fprintf(fp,"[Source_Image]\n%s\n\n", help ? ++help : proj.filename_source);
+- help = NULL;
++ help = (char*)NULL;
+ help = strrchr(proj.filename_destination, '/');
+ fprintf(fp,"[Destination_Image]\n%s\n\n", help ? ++help : proj.filename_destination);
+ // help = NULL;
+ // help = strrchr(proj.filename_vector, '/');
+ // fprintf(fp,"[Vector_File]\n%s\n\n", help ? ++help : proj.filename_vector);
+- help = NULL;
++ help = (char*)NULL;
+ help = strrchr(proj.filename_area_map, '/');
+ fprintf(fp,"[Detail_Map]\n%s\n\n", help ? ++help : proj.filename_area_map);
+- help = NULL;
++ help = (char*)NULL;
+ fprintf(fp,"[Morph_Mode]\n%i\n\n", proj.morph_mode);
+ fprintf(fp,"[Border_Vectors]\n%i\n\n", proj.border_vecs);
+ fprintf(fp,"[Use_Wavelets]\n%i\n\n", proj.use_wavelets);
+@@ -1543,7 +1546,7 @@
+ switch(arg)
+ {
+ case 1: // Load_Source
+- switch (ReadPicture( NULL, s_pic, 1 ))
++ switch (ReadPicture( (const char*)NULL, s_pic, 1 ))
+ {
+ case 1:// io error
+ fl_show_alert("ERROR:","Cannot load Source image !","",1);
+@@ -1576,7 +1579,7 @@
+ return;
+ }
+
+- switch (ReadPicture( NULL, d_pic, 0 ))
++ switch (ReadPicture( (const char*)NULL, d_pic, 0 ))
+ {
+ case 1:// io error
+ fl_show_alert("ERROR:","Cannot load Destination image !","",1);
+@@ -1616,7 +1619,7 @@
+ }
+ }
+
+- switch ( Load_Vectors(NULL) )
++ switch ( Load_Vectors((const char*)NULL) )
+ {
+ case 0:// OK
+ control.vec_changed=0;
@@ -1720,7 +1723,7 @@
// extension--;
@@ -52,6 +146,24 @@
while ( !(extension = strstr(extension,number)) && i<=999 )
{
i++;
+@@ -2217,7 +2220,7 @@
+ //case 16-25: See default-branch !!!
+
+ case 28:// OpenProject:
+- Load_Project(NULL);
++ Load_Project((const char*)NULL);
+ break;
+
+ case 29:// Save_Project
+@@ -2235,7 +2238,7 @@
+ return;
+ }
+
+- if ( ReadAreaMap(NULL, area)==0 )
++ if ( ReadAreaMap((const char*)NULL, area)==0 )
+ {
+ fl_set_button(fd_MRM->CB_Area_Morph,1);
+ fl_call_object_callback(fd_MRM->CB_Area_Morph);
@@ -2336,20 +2339,20 @@
break;
diff --git a/graphics/xmrm/files/patch-xmrm_mpeg_main.cc b/graphics/xmrm/files/patch-xmrm_mpeg_main.cc
index f931edd5f69d..618f0b081b80 100644
--- a/graphics/xmrm/files/patch-xmrm_mpeg_main.cc
+++ b/graphics/xmrm/files/patch-xmrm_mpeg_main.cc
@@ -1,5 +1,5 @@
---- xmrm_mpeg_main.cc.orig Tue Mar 10 00:00:00 1998
-+++ xmrm_mpeg_main.cc Fri Nov 29 15:06:47 2002
+--- xmrm_mpeg_main.cc.orig Tue Mar 10 07:00:00 1998
++++ xmrm_mpeg_main.cc Sun Nov 13 16:25:33 2005
@@ -8,6 +8,7 @@
#include <forms.h>
#include <unistd.h>
@@ -8,6 +8,22 @@
#define MAX_PIC_NUM 999
#define BORDER_WIDTH -1
+@@ -50,11 +51,11 @@
+ //------------------------------
+ names_n_numbers::names_n_numbers()
+ {
+- START_Frame = NULL;
+- START_fname_only = NULL;
+- END_Frame = NULL;
++ START_Frame = (char*)NULL;
++ START_fname_only = (char*)NULL;
++ END_Frame = (char*)NULL;
+
+- filename_ppm = filename_yuv = extension = NULL;
++ filename_ppm = filename_yuv = extension = (char*)NULL;
+
+ abs_count = first_width = first_height = start_number = 0;
+ end_number = MAX_PIC_NUM;
@@ -68,7 +69,7 @@
{
int count = 0;
@@ -35,3 +51,25 @@
if ( Even_Size( tif, tif_w, tif_h) )
return 1;
}
+@@ -713,8 +714,8 @@
+ break;
+
+ case 2: // Choose Start/Stop Frame
+- backup_class->START_Frame = NULL;
+- backup_class->END_Frame = NULL;
++ backup_class->START_Frame = (char*)NULL;
++ backup_class->END_Frame = (char*)NULL;
+
+ fl_hide_object(fd_CREATE_MPEG->BT_Go);
+
+@@ -786,8 +787,8 @@
+ }
+
+ // redirect TIFF-Error- and Warnig-Handler
+- (void) TIFFSetErrorHandler(NULL);
+- (void) TIFFSetWarningHandler(NULL);
++ (TIFFErrorHandler) TIFFSetErrorHandler((TIFFErrorHandler)NULL);
++ (TIFFErrorHandler) TIFFSetWarningHandler((TIFFErrorHandler)NULL);
+
+ // show the first form
+ fl_hide_object(fd_CREATE_MPEG->BT_Go);