aboutsummaryrefslogtreecommitdiff
path: root/graphics/xoris
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2009-01-30 06:05:25 +0000
committerBeech Rintoul <beech@FreeBSD.org>2009-01-30 06:05:25 +0000
commit0b817a7e29333e13fb79b8fcecc5374ec4ceabcf (patch)
tree9773a328594437b2aaa26e4489862e8d75ba0654 /graphics/xoris
parent5cb2b3bedfd096ed18d25c17f9c562a8df5f2379 (diff)
downloadports-0b817a7e29333e13fb79b8fcecc5374ec4ceabcf.tar.gz
ports-0b817a7e29333e13fb79b8fcecc5374ec4ceabcf.zip
Notes
Diffstat (limited to 'graphics/xoris')
-rw-r--r--graphics/xoris/Makefile15
-rw-r--r--graphics/xoris/distinfo6
-rw-r--r--graphics/xoris/files/xoris-run.sh11
-rw-r--r--graphics/xoris/pkg-plist1
4 files changed, 24 insertions, 9 deletions
diff --git a/graphics/xoris/Makefile b/graphics/xoris/Makefile
index c49cd5ed6a4d..35b140c5473c 100644
--- a/graphics/xoris/Makefile
+++ b/graphics/xoris/Makefile
@@ -1,25 +1,28 @@
# New ports collection makefile for: xoris
# Date created: 02 April 2006
-# Whom: Alexander Gromnizki
+# Whom: Alexander Gromnitsky
#
# $FreeBSD$
#
PORTNAME= xoris
-PORTVERSION= 0.1b
-PORTREVISION= 1
-CATEGORIES= graphics x11
-MASTER_SITES= http://gromnizki.unixdev.net/soft/
+PORTVERSION= 0.1e
+CATEGORIES= graphics
+MASTER_SITES= SF
-MAINTAINER= grommizki@unixdev.net
+MAINTAINER= alexander.gromnitsky@gmail.com
COMMENT= An X11 pixel color grabber
+USE_XLIB= yes
USE_IMAKE= yes
.if !defined(NOPORTDOCS)
SUB_FILES= pkg-message
+.endif
post-install:
+ @ ${INSTALL_SCRIPT} ${FILESDIR}/xoris-run.sh ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
@ ${ECHO_MSG} "===> Installing documentation for ${PORTNAME}"
@ ${MKDIR} ${DOCSDIR}
@ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}/
diff --git a/graphics/xoris/distinfo b/graphics/xoris/distinfo
index 010554d121ff..c87bfe5b2d55 100644
--- a/graphics/xoris/distinfo
+++ b/graphics/xoris/distinfo
@@ -1,3 +1,3 @@
-MD5 (xoris-0.1b.tar.gz) = 4623c6b7e7899e2e0f0c35dea01a8343
-SHA256 (xoris-0.1b.tar.gz) = aa4ae97dd10dec27fd77e44839674a6ca5d8288b093bfc64b6b2cffe5819a2e4
-SIZE (xoris-0.1b.tar.gz) = 6311
+MD5 (xoris-0.1e.tar.gz) = f1e8abbb5e57f66f52335a37f5405207
+SHA256 (xoris-0.1e.tar.gz) = 8902d391bfb1a15f21afdd7626634fb3dfa6240814d6c2bcde2ee06377bd675c
+SIZE (xoris-0.1e.tar.gz) = 6731
diff --git a/graphics/xoris/files/xoris-run.sh b/graphics/xoris/files/xoris-run.sh
new file mode 100644
index 000000000000..cf5b88b2dc83
--- /dev/null
+++ b/graphics/xoris/files/xoris-run.sh
@@ -0,0 +1,11 @@
+#!/bin/sh
+
+while true
+do
+ xoris | xmessage -buttons 'Grab,Quit' -nearmouse \
+ -xrm '*iconName:xoris output' \
+ -title 'xoris output' \
+ -geometry 180x65 \
+ -file -
+ [ $? -eq 102 ] && exit
+done
diff --git a/graphics/xoris/pkg-plist b/graphics/xoris/pkg-plist
index 89966696c9e1..5189410bdb63 100644
--- a/graphics/xoris/pkg-plist
+++ b/graphics/xoris/pkg-plist
@@ -1,3 +1,4 @@
bin/xoris
+bin/xoris-run.sh
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%@dirrm %%DOCSDIR%%